]> git.donarmstrong.com Git - neurodebian.git/commitdiff
templates, tune up of --help for configurerepo tool, etc
authorYaroslav Halchenko <debian@onerussian.com>
Fri, 8 Aug 2014 19:11:28 +0000 (15:11 -0400)
committerYaroslav Halchenko <debian@onerussian.com>
Fri, 8 Aug 2014 19:11:28 +0000 (15:11 -0400)
debian/control
debian/neurodebian-desktop.manpages
debian/neurodebian.manpages [new file with mode: 0644]
debian/neurodebian.templates
debian/rules
tools/nd-configurerepo

index 02de2572025a428d51b0aca23cd8b2dd890dace2..425efb24d8a38d4cf4aac11bdd3e31f19c751d06 100644 (file)
@@ -11,7 +11,7 @@ Vcs-Git: git://git.debian.org/git/pkg-exppsy/neurodebian.git
 
 Package: neurodebian
 Architecture: all
 
 Package: neurodebian
 Architecture: all
-Pre-depends: python-minimal, wget
+Pre-depends: python, wget
 Depends: neurodebian-keyring, ${misc:Depends}
 Recommends: netselect
 Suggests: neurodebian-desktop, neurodebian-popularity-contest
 Depends: neurodebian-keyring, ${misc:Depends}
 Recommends: netselect
 Suggests: neurodebian-desktop, neurodebian-popularity-contest
index 06ff84cc13d3914b837b4dcea52243aab45b8a7a..0e6ca74fee19866bb5368853922710585b9cdb77 100644 (file)
@@ -1 +1 @@
-build/man/nd-*
+build/man/nd-autoinstall.1
diff --git a/debian/neurodebian.manpages b/debian/neurodebian.manpages
new file mode 100644 (file)
index 0000000..0e6ca74
--- /dev/null
@@ -0,0 +1 @@
+build/man/nd-autoinstall.1
index 5c0e64cc805132746c874c7fea094361fdbdb5e6..70f61d7256a6f2a28570bee33f0b47292b3283f9 100644 (file)
@@ -53,7 +53,7 @@ Template: neurodebian/components
 Type: multiselect
 Choices: software, data, devel
 Default: software, data
 Type: multiselect
 Choices: software, data, devel
 Default: software, data
-_Description: Select NeuroDebian repository components to enable
+_Description: NeuroDebian repository components to enable:
  NeuroDebian repository provides
  .
   software
  NeuroDebian repository provides
  .
   software
@@ -78,18 +78,18 @@ _Description: Should existing NeuroDebian APT file be overridden?
 Template: neurodebian/suffix
 Type: string
 Default:
 Template: neurodebian/suffix
 Type: string
 Default:
-_Description: Additional suffix to use in the NeuroDebian APT file name:
+_Description: Additional suffix for the NeuroDebian APT file name:
  For instance if you would like to enable additional repository
  (e.g. NeuroDebian devel) or release, without interfering with the
  For instance if you would like to enable additional repository
  (e.g. NeuroDebian devel) or release, without interfering with the
- main/default configuration file.
+ main/default configuration file.  Generally should be left empty.
 
 Template: neurodebian/run-update-note
 Type: note
 
 Template: neurodebian/run-update-note
 Type: note
-_Description: Upon completion of installation invoke update in your APT frontend.
+_Description: APT list of packages needs to be updated.
  For the installed NeuroDebian APT configuration to take an effect,
  list of packages needs to be updated.  This needs to be done
  For the installed NeuroDebian APT configuration to take an effect,
  list of packages needs to be updated.  This needs to be done
- "manually" (e.g. apt-get update) upon completion of installation of
- the neurodebian package.
+ "manually" (e.g., via apt-get update) upon completion of installation
of the neurodebian package.
 
 Template: neurodebian/netselect-not-found
 Type: error
 
 Template: neurodebian/netselect-not-found
 Type: error
index c24da78693a6351c23c08f9b06a38b239d518d2a..c4075159743b4f9c3e31e15520fea3a5cf1bef57 100755 (executable)
@@ -27,6 +27,8 @@ override_dh_auto_build::
                -n "backport Debian source packages" > build/man/backport-dsc.1
        help2man --no-info tools/nd-autoinstall \
                -n "install (if necessary) and run an application" > build/man/nd-autoinstall.1
                -n "backport Debian source packages" > build/man/backport-dsc.1
        help2man --no-info tools/nd-autoinstall \
                -n "install (if necessary) and run an application" > build/man/nd-autoinstall.1
+       help2man --no-info tools/nd-configurerepo \
+               -n "configure APT to use NeuroDebian repository" build/man/nd-configurerepo.1
 
 override_dh_auto_install::
 
 
 override_dh_auto_install::
 
index 5720fe8a892f6b7b125defb91e18d92344ef267c..c2b6cf3aa2c3dd7aa6aeb2762deb84dbc55d9033 100755 (executable)
@@ -113,8 +113,8 @@ Enables NeuroDebian repository for the current Debian or Ubuntu release.
 Options:
 
   -r, --release=RELEASE
 Options:
 
   -r, --release=RELEASE
-    Name of the Debian/Ubuntu release to be used.  If not specified,
-    it is deduced from the  apt-cache policy  output, by taking repository
+    Name of the Debian/Ubuntu release to be used. If not specified,
+    it is deduced from the 'apt-cache policy' output, by taking repository
     of Debian or Ubuntu origin with highest priority.
 
   --print-releases
     of Debian or Ubuntu origin with highest priority.
 
   --print-releases
@@ -125,8 +125,10 @@ Options:
 
   -f, --flavor=full|libre
     Which flavor of the repository should be enabled:
 
   -f, --flavor=full|libre
     Which flavor of the repository should be enabled:
-     libre -- Only  main  component, containing only DFSG-compliant content.
-     full -- Includes main, contrib, and non-free.
+
+      libre  Only 'main' component, containing only DFSG-compliant content.
+      full   Includes 'main', 'contrib', and 'non-free'.
+
     If not specified -- deduced from the output of apt-cache policy.
 
   --print-flavor
     If not specified -- deduced from the output of apt-cache policy.
 
   --print-flavor
@@ -134,14 +136,16 @@ Options:
 
   -c, --components=c1,c2,c3
     Comma separated list of components to enable among:
 
   -c, --components=c1,c2,c3
     Comma separated list of components to enable among:
-     software -- primary software repository
-     data -- data packages
-     devel -- "overlay" of development versions (like Debians' "experimental").
-              Not sufficient on its own and available only from the main site
+
+     software  primary software repository
+     data      data packages
+     devel     "overlay" of development versions (like Debians' "experimental").
+               Not sufficient on its own and available only from the main site
+
     If not specified -- "software,data"
 
   -m, --mirror=NAME|URL
     If not specified -- "software,data"
 
   -m, --mirror=NAME|URL
-    Which mirror to use.  Could be a mirror code-name (as specified in
+    Which mirror to use. Could be a mirror code-name (as specified in
     /etc/neurodebian/neurodebian.cfg), or a URL.
 
   --print-mirrors
     /etc/neurodebian/neurodebian.cfg), or a URL.
 
   --print-mirrors
@@ -156,7 +160,7 @@ Options:
     multiple repositories
 
   --sources, --no-sources
     multiple repositories
 
   --sources, --no-sources
-    Either to enable deb-src lines.  If none specified -- would be enabled if
+    Either to enable deb-src lines. If none specified -- would be enabled if
     sources for a core package (apt) are available.
 
   -n, --dry-run
     sources for a core package (apt) are available.
 
   -n, --dry-run
@@ -168,7 +172,7 @@ Options:
     be apt-get installed
 
   -v, --verbose
     be apt-get installed
 
   -v, --verbose
-    Enable additional progress messages.  Could be used multiple times
+    Enable additional progress messages. Could be used multiple times
 
   -q, --quiet
     Make operation quiet -- only error messages would be output
 
   -q, --quiet
     Make operation quiet -- only error messages would be output
@@ -181,25 +185,20 @@ Options:
 
 Exit status:
 
 
 Exit status:
 
-  non-0 exit status in case of error.  Error exit code would depend
-  on which command has failed
+  non-0 exit status in case of error.
+  Error exit code would depend on which command has failed.
 
 Examples:
 
 Examples:
-
-  - Enable software and data components from the optimal (according to
+  nd-configurerepo
+    Enable software and data components from the optimal (according to
     netselect) mirror.  Some information about progress will be printed
 
     netselect) mirror.  Some information about progress will be printed
 
-    nd-configurerepo
-
-  - Quietly enable -devel repository for the current release, and place apt
+  nd-configurerepo -q --suffix=-devel -c devel
+    Quietly enable -devel repository for the current release, and place apt
     configuration into /etc/apt/sources.list.d/neurodebian.sources-devel.list
 
     configuration into /etc/apt/sources.list.d/neurodebian.sources-devel.list
 
-    nd-configurerepo -q --suffix=-devel -c devel
-
-  - Force sid distribution, all the components, from the Japan mirror:
-
-    nd-configurerepo -q --suffix=-de-sid-full -c software,data,devel -m jp
-
+  nd-configurerepo -q --suffix=-de-sid-full -c software,data,devel -m jp
+    Force sid distribution, all the components, from the Japan mirror
 EOT
 }
 
 EOT
 }