]> git.donarmstrong.com Git - cran2deb.git/blobdiff - trunk/debian/rules
Added code for a nicely working Debian package.
[cran2deb.git] / trunk / debian / rules
diff --git a/trunk/debian/rules b/trunk/debian/rules
new file mode 100755 (executable)
index 0000000..99faf0f
--- /dev/null
@@ -0,0 +1,10 @@
+#!/usr/bin/make -f
+#                                                      -*- makefile -*-
+
+include /usr/share/R/debian/r-cran.mk
+
+DEB_COMPRESS_EXCLUDE := .pdf
+
+install/$(package)::
+       # Require a number equal or superior than the R version the package was built with.
+       echo "R:Depends=r-base-core (>= $(shell R --version | head -n1 | perl -ne 'print / +([0-9]\.[0-9]+\.[0-9])/')~)" >> debian/r-$(debRreposname)-$(cranName).substvars