]> git.donarmstrong.com Git - cran2deb.git/blobdiff - trunk/R/debianpkg.R
add more notices to debianpkg
[cran2deb.git] / trunk / R / debianpkg.R
index d8835412dc1206528a19f0d9b2d849340d6a9dab..a4568bd39e21f3007ef34a79bee24e7a9d919e41 100644 (file)
@@ -23,7 +23,7 @@ generate_changelog <- function(pkg) {
 
 generate_changelog_entry <- function(build, changelog) {
     # TODO: should say 'New upstream release' when necessary
-    debversion <- version_new(build$r_version, build$deb_revision, build$deb_epoch)
+    debversion <- version_new(build$r_version, pkgname=build$package, build$deb_revision, build$deb_epoch)
     cat(paste(paste(build$srcname,' (',debversion,') unstable; urgency=low',sep='')
              ,'' ,paste('  * cran2deb ',build$scm_revision
                        ,' with DB version ',as.integer(build$db_version),'.',sep='')
@@ -37,6 +37,9 @@ generate_rules <- function(pkg) {
              ,'include /usr/share/R/debian/r-cran.mk'
              ,'',sep='\n')
        ,file=pkg$debfile('rules'))
+    if (pkg$name %in% c("Rmpi", "npRmpi", "doMPI")) {
+        cat("extraInstallFlags=\"--no-test-load\"\n", file=pkg$debfile('rules'), append=TRUE)
+    }      
     Sys.chmod(pkg$debfile('rules'),'0700')
 }
 
@@ -109,30 +112,26 @@ prepare_new_debian <- function(pkg,extra_deps) {
     # says: ``The sources and headers for the compiled code are in src, plus
     # optionally file Makevars or Makefile.'' It seems unlikely that
     # architecture independent code would end up here.
-    if (pkg$is_bundle) {
-        # if it's a bundle, check each of the packages
-        pkg$archdep = F
-        for (pkgname in r_bundle_contains(pkg$name)) {
-            pkg$archdep = file.exists(file.path(pkg$path,pkgname,'src'))
-            if (pkg$archdep) {
-                break
-            }
-        }
-    } else {
-        pkg$archdep = file.exists(file.path(pkg$path,'src'))
-    }
+    pkg$archdep = file.exists(file.path(pkg$path,'src'))
     pkg$arch <- 'all'
     if (pkg$archdep) {
         pkg$arch <- host_arch()
     }
 
     pkg$license <- accept_license(pkg)
+    notice('getting dependencies')
     pkg$depends <- get_dependencies(pkg,extra_deps)
+    notice('applying patches')
     apply_patches(pkg)
+    notice('applying lintian fixes')
+    generate_lintian(pkg)
+    notice('generating changelog, rules, copyright, and control')
     generate_changelog(pkg)
     generate_rules(pkg)
     generate_copyright(pkg)
     generate_control(pkg)
+    ## debdir <- file.path(pkg$path,'debian')
+    ## system(paste("ls ", debdir, "; ls -l ", debdir, "/patches/*", sep=""))
 
     # convert text to utf8 (who knows what the original character set is --
     # let's hope iconv DTRT).