]> git.donarmstrong.com Git - neurodebian.git/blobdiff - debian/rules
Adding icons for "Imaging" and "Electrophysiology"
[neurodebian.git] / debian / rules
index 3c8585f864657ad5ea52ee31e52287635c375ba7..e18173a98b020c49a77215685e39fdeda67cc93b 100755 (executable)
@@ -1,5 +1,7 @@
 #!/usr/bin/make -f
 
+ICONS_SIZE=32
+
 # one ring to rule them all ...
 %:
        dh $@
@@ -10,6 +12,14 @@ override_dh_auto_build::
        # wallpaper
        [ ! -d build/wallpaper ] && mkdir -p build/wallpaper
        xcf2png -o build/wallpaper/neurodebian.png artwork/wallpaper_hotbrain.xcf
+       # icons
+       [ ! -d build/icons ] && mkdir -p build/icons
+       inkscape artwork/icon.svg -w $(ICONS_SIZE) -h $(ICONS_SIZE) \
+               -e build/icons/neurodebian.png
+       inkscape artwork/electrophysiology.svg -w $(ICONS_SIZE) -h $(ICONS_SIZE) \
+               -e build/icons/neurodebian-electrophysiology.png
+       cp artwork/icon.svg build/icons/neurodebian.svg
+       convert -geometry $(ICONS_SIZE)x$(ICONS_SIZE) artwork/mri.png build/icons/neurodebian-imaging.png
        # manpages
        [ ! -d build/man ] && mkdir -p build/man
        help2man -h '--verbose-help' --no-info tools/backport-dsc \