]> git.donarmstrong.com Git - debhelper.git/blobdiff - debian/rules
r284: * Enhanced debconf support -- the database is now cleaned up on package
[debhelper.git] / debian / rules
index 929f0c417a9b48126257821c7d4b4371bd4ae00b..ccc0a36317d754a35f007cb4a204d426ec135911 100755 (executable)
@@ -3,7 +3,9 @@
 # I run the most current ones. That's also why there is a symlink to the 
 # current Dh_lib.pm and the current Dh_getopt.pm in this debian/ directory.
 #
-# This is _not_ a good example of a debhelper rules file.
+# This is _not_ a good example of a debhelper rules file, but I didn't need
+# to tell you that; just see the 25 lines of inlined perl below.. See
+# examples/ for some good examples.
 
 # If any automatic script generation is done in building this package, 
 # be sure to use the new templates from this package.
@@ -17,9 +19,8 @@ VERSION=$(shell expr "`dpkg-parsechangelog 2>/dev/null |grep Version:`" : '.*Ver
 
 export DH_VERBOSE=1
 
-build: link-stamp
-       # Run regression tests.
-       $(MAKE) test
+build: link-stamp test
+# Nothing to do.       
 
 clean: link-stamp
        ./dh_testdir
@@ -47,9 +48,10 @@ binary-indep: link-stamp build
                -exec install -p {} debian/debhelper/usr/bin \;
        cp -a Dh_*.pm debian/debhelper/usr/share/debhelper
        cp -a autoscripts debian/debhelper/usr/share/debhelper
+       rm -rf debian/debhelper/usr/share/debhelper/autoscripts/CVS
 
-       ./dh_installdocs doc/*
-       ./dh_installexamples examples/*
+       ./dh_installdocs `find doc -type f | grep -v CVS`
+       ./dh_installexamples `find examples -type f | grep -v CVS`
        ./dh_installmenu
        ./dh_installmanpages
        ./dh_installinfo
@@ -67,7 +69,7 @@ binary-indep: link-stamp build
                open (OUT,">$$f"); \
                print OUT @lines; \
                close OUT; \
-       }' debian/debhelper/usr/man/man1/*.1
+       }' debian/debhelper/usr/share/man/man1/*.1
        # Fix up the debhelper.1 man page, substituting in a list of all
        # debhelper commands. eek!
        perl -ne ' \
@@ -75,10 +77,10 @@ binary-indep: link-stamp build
                $$collect.=".TP\n.BR $$_" if $$. eq 3 && /^dh_/; \
                close(ARGV) if eof; \
                END { \
-                       open(I,"debian/debhelper/usr/man/man1/debhelper.1"); \
+                       open(I,"debian/debhelper/usr/share/man/man1/debhelper.1"); \
                        @lines=<I>; \
                        close I; \
-                       open(O,">debian/debhelper/usr/man/man1/debhelper.1"); \
+                       open(O,">debian/debhelper/usr/share/man/man1/debhelper.1"); \
                        foreach (@lines) { \
                                s/#LIST#/$$collect/; \
                                print O; \
@@ -96,44 +98,16 @@ binary-indep: link-stamp build
        ./dh_md5sums
        ./dh_builddeb
 
-# Install in the proper location on my ftp server and web server. Not intended
-# for use by anyone except the author.
-OLD_VER=$(shell perl -e '<>;<>;while(<>){last if /^ --/};<>;$$_=<>;print m/\((.*?)\)/'<debian/changelog)
-dist: link-stamp
-       dpkg-buildpackage -rfakeroot -tc
-       if [ `hostname` = 'kite' ] ; then \
-               cp ../debhelper_$(VERSION).tar.gz ../../public; \
-               rm /home/ftp/pub/code/debhelper/* || true; \
-               cp debian/changelog /home/pub/programs/debhelper/CHANGES; \
-               echo $(VERSION) > /home/pub/programs/debhelper/LATEST-VERSION-IS; \
-               cd ..; rm -rf debhelper-$(OLD_VER); \
-               [ -f ../public/debhelper_$(OLD_VER).tar.gz ] && \
-               tar zxf ../public/debhelper_$(OLD_VER).tar.gz || \
-               tar zxf ../outdated/debhelper_$(OLD_VER).tar.gz; \
-               diff -r -u --new-file debhelper-$(OLD_VER) debhelper-$(VERSION) > \
-                       /home/ftp/pub/code/debhelper/diffs/debhelper-$(VERSION).diff; \
-               gzip -9f /home/ftp/pub/code/debhelper/diffs/debhelper-$(VERSION).diff; \
-               cd /tmp; rm -f debhelper-$(OLD-VER); \
-        fi
-
+# Fix links when checking out of cvs by calling this target.
 link-stamp:
        sh -e debian/fixlinks
        touch link-stamp
 
-# This is for local use - it tags the current code with the debian version
-# number, then commits the current code using the contents of the changelog
-# as the cvs changelog, then increments the version number
-commit:
-       cvs -Q commit -m "dpkg-parsechangelog | grep '^  '"
-       cvs -Q tag rel-$(shell dpkg-parsechangelog | grep ^Version: \
-               |cut -d " " -f 2 |tr '.' '-')
-       $(MAKE) new
-       
-new:
-       # Update w/o editing.
-       EDITOR=true dch -i 2>/dev/null
-       # Dch has to change the bloody directory name. Feh.
-       mv . ../debhelper
+# Update the debhelper web page. Not intended for use by anyone except the
+# author.
+installhook:
+       cp debian/changelog /home/pub/programs/debhelper/CHANGES
+       echo $(VERSION) > /home/pub/programs/debhelper/LATEST-VERSION-IS
 
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary dist