]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - debian/rules
Retire the separate MIME Policy document
[debian/debian-policy.git] / debian / rules
index 7b8729090a70ca527909321f1945583bc0f0ffa9..c80e34853b3344291933d7928f83b8fce5b30349 100755 (executable)
@@ -32,9 +32,9 @@ LIBDIR          := $(TMPTOP)/usr/share/doc-base
 
 sanitycheck := debian/rules policy.sgml
 
-SGML_FILES := policy menu-policy mime-policy perl-policy upgrading-checklist
-DESC_FILES := debian-policy debian-menu-policy debian-perl-policy \
-              debian-mime-policy debconf-spec fhs
+SGML_FILES := policy menu-policy perl-policy upgrading-checklist
+DESC_FILES := copyright-format debian-policy debian-menu-policy \
+             debian-perl-policy debconf-spec fhs
 
 # While we have two versions of the FHS installed in the source package,
 # we need to modify this to handle it.  This is the easiest way to do it.
@@ -49,6 +49,8 @@ FHS_NEW_FILES    :=
 POLICY_FILES = $(SGML_FILES:=.sgml) $(SGML_FILES:=.txt.gz) \
               virtual-package-names-list.txt \
               libc6-migration.txt version.ent \
+               copyright-format/copyright-format.html \
+               copyright-format/copyright-format.txt.gz \
                debconf_spec/debconf_specification.html \
                debconf_spec/debconf_specification.txt.gz \
                policy.ps.gz policy.pdf.gz README.txt README.html \
@@ -57,7 +59,8 @@ POLICY_FILES = $(SGML_FILES:=.sgml) $(SGML_FILES:=.txt.gz) \
 FILES_FROM_ORG := Process.html Process.txt README.txt README.html
 
 # policy.{pdf,ps,tpt,txt} are generated files
-FILES_TO_CLEAN  = debian/files debian/buildinfo  debian/substvars \
+FILES_TO_CLEAN  = copyright-format.xml.tar.gz \
+                  debian/files debian/buildinfo  debian/substvars \
                  debian/postinst debian/prerm \
                  version.ent \
                  $(SGML_FILES:=.txt.gz) $(SGML_FILES:=.html.tar.gz) \
@@ -77,7 +80,8 @@ install_program := install -p -o root -g root  -m  755
 make_directory  := install -p -d       -o root -g root  -m  755
 
 
-all build: stamp-build
+all build build-indep: stamp-build
+build-arch:
 stamp-build: version.ent $(sanitycheck)
        $(MAKE) $(SGML_FILES:=.sgml.validate) \
                $(SGML_FILES:=.html.tar.gz) \
@@ -85,6 +89,7 @@ stamp-build: version.ent $(sanitycheck)
                $(SGML_FILES:=.txt.gz) \
                policy.ps.gz policy.pdf.gz
        $(MAKE) $(FILES_FROM_ORG)
+       $(MAKE) -C copyright-format all
        $(MAKE) -C debconf_spec all
        touch stamp-build
 
@@ -96,6 +101,7 @@ version.ent: debian/changelog
 
 clean: $(sanitycheck)
 # Undoes the effect of `make -f debian/rules build'.
+       $(MAKE) -C copyright-format clean
        $(MAKE) -C debconf_spec clean
        rm -f  $(FILES_TO_CLEAN) $(STAMPS_TO_CLEAN)
        rm -rf $(DIRS_TO_CLEAN)
@@ -136,6 +142,10 @@ stamp-policy:  build $(sanitycheck)
        #$(install_file)    $(FHS_NEW_FILES)         $(DOCDIR)/fhs/
        $(install_file)     $(FHS_FILES)             $(DOCDIR)/fhs/
        $(install_file)     debian/copyright         $(DOCDIR)/
+       GZIP=-9 cd copyright-format && \
+         tar -zcf ../copyright-format.xml.tar.gz *
+       $(install_file)     copyright-format.xml.tar.gz $(DOCDIR)/
+       @set -ex; \
        GZIP=-9 cd debconf_spec && \
          tar -zcf ../debconf_specification.xml.tar.gz *
        $(install_file)     debconf_specification.xml.tar.gz $(DOCDIR)/
@@ -162,7 +172,8 @@ stamp-policy:  build $(sanitycheck)
        touch               stamp-policy
 
 
-.PHONY: configure build binary binary-arch binary-indep clean checkroot
+.PHONY: configure build build-arch build-indep binary binary-arch
+.PHONY: binary-indep clean checkroot
 
 #Local variables:
 #mode: makefile