]> git.donarmstrong.com Git - deb_pkgs/libhtml-calendarmonth-perl.git/blobdiff - debian/rules
fix spelling error in HTML::CalendarMonth
[deb_pkgs/libhtml-calendarmonth-perl.git] / debian / rules
index 13b11fe485377aff701d69c014ee5f8f2cbc5f3c..c5814f2049edc546eb012f4d3fc00e4457d8c033 100755 (executable)
@@ -33,18 +33,15 @@ clean:
 install: build test
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs
 
        $(MAKE) install PREFIX=$(DESTDIR)/usr
-       rmdir -p $(DESTDIR)/usr/lib/perl5 || true
+       [ ! -d $(DESTDIR)/usr/lib/perl5 ] || \
+               rmdir -p --ignore-fail-on-non-empty $(DESTDIR)/usr/lib/perl5
 
 # Build architecture-independent files here.
-binary-indep: install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
+binary-indep: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs
@@ -61,5 +58,8 @@ binary-arch: build install
        dh_md5sums
        dh_builddeb
 
+# Build architecture-dependent files here.
+binary-arch: 
+
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install