]> git.donarmstrong.com Git - debhelper.git/blobdiff - debian/rules
r472: * Fixed issues with extended parameters to dh_gencontrol including spaces
[debhelper.git] / debian / rules
index f889fee53d1349fd0ef6124d0f55f588b8d6e504..bf37bcab11cb1e37bb93f367e84a55ca14f8833b 100755 (executable)
@@ -17,21 +17,19 @@ export DH_AUTOSCRIPTDIR=autoscripts
 # Use most recent compatability level.
 export DH_COMPAT=3
 
-# Figure out the current debhelper version.
+# Figure out the `current debhelper version.
 VERSION=$(shell expr "`dpkg-parsechangelog 2>/dev/null |grep Version:`" : '.*Version: \(.*\)')
 
+PERLLIBDIR=$(shell perl -MConfig -e 'print $$Config{vendorlib}')
+
 # Debug
 #export DH_VERBOSE=1
 
 build: test build-stamp
 build-stamp:
-       # Turn all executables and .pod files into man pages.
-       find . \( \( -type f -perm +1 -maxdepth 1 \) -or \
-                 \( -type f -name '*.pod' \) \) \
-               -exec pod2man -c Debhelper -r "$(VERSION)" {} {}.1 \;
-       mv -f debhelper.pod.1 debhelper.1
-       # Fix up the debhelper.1 man page, substituting in a list of all
-       # debhelper commands. Eek!
+       # Generate the main man page. All the perl cruft is to get a list
+       # of debhelper commands with short descriptions into the man page.
+       pod2man -c Debhelper -r "$(VERSION)" debhelper.pod | \
        perl -e ' \
                undef $$/; \
                foreach (@ARGV) { \
@@ -43,13 +41,14 @@ build-stamp:
                        } \
                } \
                END { \
-                       open(IN,"debhelper.1") or die "debhelper.1: $$!"; \
-                       $$file=<IN>; \
-                       open(OUT,">debhelper.1") or die "debhelper.1: $$!";; \
-                       $$file=~s/#LIST#/$$collect/; \
-                       print OUT $$file; \
-                       close OUT; \
-               }' dh_*
+                       while (<STDIN>) { \
+                               s/#LIST#/$$collect/; \
+                               print; \
+                       }; \
+               }' `find . -type f -perm +1 -maxdepth 1 -name "dh_*" | sort` > debhelper.1
+       # Turn all executables into man pages.
+       find . -type f -perm +1 -maxdepth 1 -name "dh_*" \
+               -exec pod2man -c Debhelper -r "$(VERSION)" {} {}.1 \;
        touch build-stamp
 
 clean:
@@ -74,14 +73,15 @@ binary-indep: build
        ./dh_testroot
        ./dh_clean -k
        ./dh_installdirs usr/bin usr/share/debhelper \
-               usr/lib/perl5/Debian/Debhelper
+               $(PERLLIBDIR)/Debian/Debhelper
+
+       printf "package Debian::Debhelper::Dh_Version;\n\$$version='$(VERSION)';" > \
+               debian/debhelper/$(PERLLIBDIR)/Debian/Debhelper/Dh_Version.pm
 
-       echo -e "package Debian::Debhelper::Dh_Version;\n\$$version='$(VERSION)';" > \
-               debian/debhelper/usr/lib/perl5/Debian/Debhelper/Dh_Version.pm
        find . -perm +111 -maxdepth 1 -type f -not -name "*.pl" \
                -exec install -p {} debian/debhelper/usr/bin \;
        cp -a Debian/Debhelper/*.pm \
-               debian/debhelper/usr/lib/perl5/Debian/Debhelper/
+               debian/debhelper/$(PERLLIBDIR)/Debian/Debhelper/
        cp -a autoscripts debian/debhelper/usr/share/debhelper
        rm -rf debian/debhelper/usr/share/debhelper/autoscripts/CVS
 
@@ -91,9 +91,11 @@ binary-indep: build
        ./dh_installman *.1
        ./dh_installinfo
        ./dh_installchangelogs
+       ./dh_shlibdeps
        ./dh_link
        ./dh_compress
        ./dh_fixperms
+       ./dh_perl
        ./dh_installdeb
        ./dh_gencontrol
        ./dh_md5sums