]> git.donarmstrong.com Git - debhelper.git/blobdiff - debian/rules
r472: * Fixed issues with extended parameters to dh_gencontrol including spaces
[debhelper.git] / debian / rules
index a746144ad760327d6780d41c3003c5d06256b344..bf37bcab11cb1e37bb93f367e84a55ca14f8833b 100755 (executable)
@@ -17,9 +17,11 @@ export DH_AUTOSCRIPTDIR=autoscripts
 # Use most recent compatability level.
 export DH_COMPAT=3
 
-# Figure out the current debhelper version.
+# Figure out the `current debhelper version.
 VERSION=$(shell expr "`dpkg-parsechangelog 2>/dev/null |grep Version:`" : '.*Version: \(.*\)')
 
+PERLLIBDIR=$(shell perl -MConfig -e 'print $$Config{vendorlib}')
+
 # Debug
 #export DH_VERBOSE=1
 
@@ -43,7 +45,7 @@ build-stamp:
                                s/#LIST#/$$collect/; \
                                print; \
                        }; \
-               }' `find . -type f -perm +1 -maxdepth 1 -name "dh_*"` > debhelper.1
+               }' `find . -type f -perm +1 -maxdepth 1 -name "dh_*" | sort` > debhelper.1
        # Turn all executables into man pages.
        find . -type f -perm +1 -maxdepth 1 -name "dh_*" \
                -exec pod2man -c Debhelper -r "$(VERSION)" {} {}.1 \;
@@ -71,14 +73,15 @@ binary-indep: build
        ./dh_testroot
        ./dh_clean -k
        ./dh_installdirs usr/bin usr/share/debhelper \
-               usr/lib/perl5/Debian/Debhelper
+               $(PERLLIBDIR)/Debian/Debhelper
+
+       printf "package Debian::Debhelper::Dh_Version;\n\$$version='$(VERSION)';" > \
+               debian/debhelper/$(PERLLIBDIR)/Debian/Debhelper/Dh_Version.pm
 
-       echo -e "package Debian::Debhelper::Dh_Version;\n\$$version='$(VERSION)';" > \
-               debian/debhelper/usr/lib/perl5/Debian/Debhelper/Dh_Version.pm
        find . -perm +111 -maxdepth 1 -type f -not -name "*.pl" \
                -exec install -p {} debian/debhelper/usr/bin \;
        cp -a Debian/Debhelper/*.pm \
-               debian/debhelper/usr/lib/perl5/Debian/Debhelper/
+               debian/debhelper/$(PERLLIBDIR)/Debian/Debhelper/
        cp -a autoscripts debian/debhelper/usr/share/debhelper
        rm -rf debian/debhelper/usr/share/debhelper/autoscripts/CVS
 
@@ -88,9 +91,11 @@ binary-indep: build
        ./dh_installman *.1
        ./dh_installinfo
        ./dh_installchangelogs
+       ./dh_shlibdeps
        ./dh_link
        ./dh_compress
        ./dh_fixperms
+       ./dh_perl
        ./dh_installdeb
        ./dh_gencontrol
        ./dh_md5sums