]> git.donarmstrong.com Git - debhelper.git/blobdiff - debian/rules
r130: Initial Import
[debhelper.git] / debian / rules
index 6ac6d672a987e7be9218594863b002f2fd9c8536..bb790cd38f5c7f80ac63e648800f18b54e003ace 100755 (executable)
@@ -1,60 +1,75 @@
 #!/usr/bin/make -f
 # Note that I have to refer to debhelper programs with ./, to make sure
 # I run the most current ones. That's also why there is a symlink to the 
-# current dh_lib in this debian/ directory.
+# current dh_lib and the current dh_getopt.pl in this debian/ directory.
 
 # If any automatic script generation is done in building this package, 
 # be sure to use the new templates from this package.
 export DH_AUTOSCRIPTDIR=autoscripts
 
 # Figure out the current debhelper version.
-VERSION=$(shell expr "`dpkg-parsechangelog 2>/dev/null`" : \
-       '.*Version: \(.*\).*Distribution:')
+VERSION=$(shell expr "`dpkg-parsechangelog 2>/dev/null |grep Version:`" : '.*Version: \(.*\)')
 
 export DH_VERBOSE=1
 
-test_files=dh_lib
-
 build:
-       ./dh_testdir $(test_files)
-       sed "s/#DEBHELPER_VERSION#/$(VERSION)/" < dh_testversion.in \
-               > dh_testversion
-       chmod 755 dh_testversion
+# Nothing to do.
 
 clean:
-       ./dh_testdir $(test_files)
+       ./dh_testdir
        ./dh_testroot
-       ./dh_clean dh_testversion
+       ./dh_clean
 
 # Build architecture-dependent files here.
 binary-arch: build
-# We have nothing to do by default.
+# Nothing to do.
 
 # Build architecture-independent files here.
 binary-indep: build
-       ./dh_testdir $(test_files)
+       ./dh_testdir
        ./dh_testroot
        ./dh_clean -k
        ./dh_installdirs usr/bin usr/lib/debhelper
 
-       find . -perm +111 -maxdepth 1 -type f \
+       echo -e "package Dh_Version;\n\$$version='$(VERSION)';" > debian/tmp/usr/lib/debhelper/Dh_Version.pm
+       find . -perm +111 -maxdepth 1 -type f -not -name "*.pl" \
                -exec install -p {} debian/tmp/usr/bin \;
-       cp dh_lib debian/tmp/usr/lib/debhelper
+       cp -a dh_lib dh_getopt.pl *.pm debian/tmp/usr/lib/debhelper
        cp -a autoscripts debian/tmp/usr/lib/debhelper
 
-       ./dh_installdocs TODO README
+       ./dh_installdocs doc/TODO doc/README doc/PROGRAMMING doc/from-debstd
        ./dh_installexamples examples/*
        ./dh_installmenu
        ./dh_installmanpages
        ./dh_installchangelogs
+       ./dh_movefiles
        ./dh_compress
        ./dh_fixperms
        ./dh_suidregister
        ./dh_installdeb
        ./dh_gencontrol
-       ./dh_du
        ./dh_md5sums
        ./dh_builddeb
 
+# Install in the proper location on my ftp server and web server. Not intended
+# for use by anyone except the author.
+OLD_VER=$(shell perl -e '<>;<>;while(<>){last if /^ --/};<>;$$_=<>;print m/\((.*?)\)/'<debian/changelog)
+dist:
+       dpkg-buildpackage -rfakeroot -tc
+       if [ `hostname` = 'kite' ] ; then \
+               cp ../debhelper_$(VERSION).tar.gz ../../public; \
+               rm /home/ftp/pub/code/debhelper/* || true; \
+               cp debian/changelog /home/pub/programs/debhelper/CHANGES; \
+               echo $(VERSION) > /home/pub/programs/debhelper/LATEST-VERSION-IS; \
+               cd ..; rm -rf debhelper-$(OLD_VER); \
+               [ -f ../public/debhelper_$(OLD_VER).tar.gz ] && \
+               tar zxf ../public/debhelper_$(OLD_VER).tar.gz || \
+               tar zxf ../outdated/debhelper_$(OLD_VER).tar.gz; \
+               diff -r -u --new-file debhelper-$(OLD_VER) debhelper-$(VERSION) > \
+                       /home/ftp/pub/code/debhelper/diffs/debhelper-$(VERSION).diff; \
+               gzip -9f /home/ftp/pub/code/debhelper/diffs/debhelper-$(VERSION).diff; \
+               cd /tmp; rm -f debhelper-$(OLD-VER); \
+        fi
+
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary
+.PHONY: build clean binary-indep binary-arch binary localdist