]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - debian/rules
typo fix from Frédéric Bothamy
[debian/debian-policy.git] / debian / rules
index 887f866f9e07e01d30f6b882a312f8b747a57cb1..b60838c071ff6462e082d49b8c94c3456e3311d1 100755 (executable)
@@ -5,30 +5,30 @@
 ## Created On      : Thu Oct 29 15:35:55 1998
 ## Created On Node  : tiamat.datasync.com
 ## Last Modified By : Manoj Srivastava
-## Last Modified On : Sat Oct 26 12:29:03 2002
+## Last Modified On : Sat Jun  7 13:31:08 2003
 ## Last Machine Used: glaurung.green-gryphon.com
-## Update Count            : 58
+## Update Count            : 60
 ## Status          : Unknown, Use with caution!
 ## HISTORY         :
 ## Description     :
 ## $Id$
 ###############################################################################
 
-ifdef ARCH
-  ha:=-a$(ARCH)
-endif
+ifdef ARCH
+  ha:=-a$(ARCH)
+endif
 
 # set the dpkg-architecture vars; but we don't use them, so we'll comment out
-export DEB_BUILD_ARCH      ?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_ARCH)
-export DEB_BUILD_GNU_CPU   ?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_CPU)
-export DEB_BUILD_GNU_SYSTEM?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_SYSTEM)
-export DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_TYPE)
-export DEB_HOST_ARCH       ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_ARCH)
-export DEB_HOST_GNU_CPU    ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_CPU)
-export DEB_HOST_GNU_SYSTEM ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_SYSTEM)
-export DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_TYPE)
+export DEB_BUILD_ARCH      ?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_ARCH)
+export DEB_BUILD_GNU_CPU   ?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_CPU)
+export DEB_BUILD_GNU_SYSTEM?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_SYSTEM)
+export DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_TYPE)
+export DEB_HOST_ARCH       ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_ARCH)
+export DEB_HOST_GNU_CPU    ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_CPU)
+export DEB_HOST_GNU_SYSTEM ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_SYSTEM)
+export DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_TYPE)
 
-# arch := $(shell dpkg --print-installation-architecture)
+arch   := $(shell dpkg --print-installation-architecture)
 
 # Basic information
 package := $(shell grep Source debian/control | sed 's/^Source: //')
@@ -55,19 +55,13 @@ DESC_FILES := debian-policy debian-menu-policy debian-perl-policy \
 FHS_ARCHIVE  := fhs-2.1-source.tar.gz
 FHS_HTML     := fhs-2.1.html.tar.gz
 FHS_FILES    := fhs/fhs.ps fhs/fhs.txt fhs/fhs.pdf
-FHS_BYHAND   := fhs-2.1.html.tar.gz fhs/fhs.txt
 # FSSTND_FILES := FSSTND-FAQ fsstnd-1.2.dvi.gz fsstnd-1.2.ps.gz fsstnd-1.2.txt.gz
 POLICY_FILES = $(SGML_FILES:=.sgml) $(SGML_FILES:=.txt.gz) \
               virtual-package-names-list.txt \
               upgrading-checklist.txt libc6-migration.txt version.ent \
                debconf_spec/debconf_specification.html \
-               debconf_spec/debconf_specification.txt.gz
-BYHAND_FILES = $(SGML_FILES:=.txt.gz) $(SGML_FILES:=.html.tar.gz) \
-              debconf_spec/debconf_specification.txt.gz \
-              debconf_spec/debconf_specification.html \
-              libc6-migration.txt virtual-package-names-list.txt \
-              policy.ps.gz policy.pdf.gz upgrading-checklist.txt \
-              $(FHS_BYHAND)
+               debconf_spec/debconf_specification.txt.gz \
+               policy.ps.gz policy.pdf.gz
 
 FILES_TO_CLEAN  = debian/files debian/buildinfo  debian/substvars \
                  debian/postinst debian/prerm \
@@ -89,7 +83,8 @@ all build: stamp-build
 stamp-build: version.ent $(sanitycheck)
        $(MAKE) $(SGML_FILES:=.sgml.validate) \
                $(SGML_FILES:=.html.tar.gz) \
-               $(SGML_FILES:=.txt.gz)
+               $(SGML_FILES:=.txt.gz) \
+               policy.ps.gz policy.pdf.gz
        tar -zxf $(FHS_ARCHIVE)
        # Need to use a patched tmac.m macro file if we're using a pre-1.16
        # groff; version 1.16 is apparently fixed
@@ -104,7 +99,6 @@ stamp-build: version.ent $(sanitycheck)
        links -dump upgrading-checklist.html | perl -pe 's/[\r\0]//g' > \
                     upgrading-checklist.txt
        $(MAKE) -C debconf_spec all
-       gzip -9f debconf_spec/debconf_specification.txt
        touch stamp-build
 
 configure: version.ent
@@ -175,15 +169,6 @@ stamp-policy:  build $(sanitycheck)
        chown               -R root:root debian/tmp
        chmod               -R go=rX debian/tmp
        dpkg                --build debian/tmp ..
-       debiandoc2latexps   policy.sgml
-       gzip -9f            policy.ps
-       debiandoc2latexpdf  policy.sgml
-       gzip -9f            policy.pdf
-       set -e; \
-       for i in            $(BYHAND_FILES); do                          \
-         $(install_file)   $$i            ..                          ; \
-         dpkg-distaddfile  -fdebian/files `basename $$i`     byhand - ; \
-       done
        touch               stamp-policy