]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - debian/rules
Make wording about following the FHS less ambiguous
[debian/debian-policy.git] / debian / rules
index d242b66020baaee7f0d0acb3934ce63ffab7b099..a3950ca7e2e88416cad8c5655315e1b70c4fbdbc 100755 (executable)
@@ -57,7 +57,7 @@ FILES_TO_CLEAN        := $(SGML_FILES:=.txt) $(SGML_FILES:=.txt.gz)           \
                   policy.pdf.gz policy.ps.gz                           \
                   policy.pdf policy.ps policy.tpt policy.txt           \
                   version.ent                                          \
-                  copyright-format-1.0.xml.tar.gz                      \
+                  copyright-format.xml.tar.gz                          \
                   debconf_specification.xml.tar.gz                     \
                   debian/files
 
@@ -79,7 +79,7 @@ stamp-build: version.ent
        $(MAKE) -C copyright-format all
        $(MAKE) -C debconf_spec all
        GZIP=-9 cd copyright-format && \
-               tar -zcf ../copyright-format-1.0.xml.tar.gz *
+               tar -zcf ../copyright-format.xml.tar.gz *
        GZIP=-9 cd debconf_spec && \
                tar -zcf ../debconf_specification.xml.tar.gz *
        touch stamp-build
@@ -122,7 +122,7 @@ stamp-binary: stamp-build
 #
 # Install DocBook XML source.
 #
-       $(install)      copyright-format-1.0.xml.tar.gz         $(DOCDIR)/
+       $(install)      copyright-format.xml.tar.gz             $(DOCDIR)/
        $(install)      debconf_specification.xml.tar.gz        $(DOCDIR)/
 #
 # Install generated HTML directories.
@@ -131,6 +131,13 @@ stamp-binary: stamp-build
                tar -C $(DOCDIR) -zxf $$file.html.tar.gz;       \
        done
 #
+# Make upgrading-checklist-1.html a symlink to the copy in the policy.html
+# directory.  This is temporary until it becomes a proper appendix.
+#
+       rm -f $(DOCDIR)/upgrading-checklist-1.html
+       ln -s policy.html/upgrading-checklist.html \
+               $(DOCDIR)/upgrading-checklist-1.html
+#
 # Install doc-base files.
 #
        @set -ex; for file in $(DESC_FILES); do                 \