]> git.donarmstrong.com Git - debhelper.git/blobdiff - debian/rules
r469: * Missing semi-colon.
[debhelper.git] / debian / rules
index e37907c9549c42c23cfc4b88bed24fe6c0bd024d..9ec7d17c2619c86621e38d0316b0d18ef509e8d3 100755 (executable)
@@ -45,7 +45,7 @@ build-stamp:
                                s/#LIST#/$$collect/; \
                                print; \
                        }; \
-               }' `find . -type f -perm +1 -maxdepth 1 -name "dh_*"` > debhelper.1
+               }' `find . -type f -perm +1 -maxdepth 1 -name "dh_*" | sort` > debhelper.1
        # Turn all executables into man pages.
        find . -type f -perm +1 -maxdepth 1 -name "dh_*" \
                -exec pod2man -c Debhelper -r "$(VERSION)" {} {}.1 \;
@@ -75,7 +75,7 @@ binary-indep: build
        ./dh_installdirs usr/bin usr/share/debhelper \
                $(PERLLIBDIR)/Debian/Debhelper
 
-       echo -e "package Debian::Debhelper::Dh_Version;\n\$$version='$(VERSION)';" > \
+       printf "package Debian::Debhelper::Dh_Version;\n\$$version='$(VERSION)';" > \
                debian/debhelper/$(PERLLIBDIR)/Debian/Debhelper/Dh_Version.pm
 
        find . -perm +111 -maxdepth 1 -type f -not -name "*.pl" \
@@ -91,6 +91,7 @@ binary-indep: build
        ./dh_installman *.1
        ./dh_installinfo
        ./dh_installchangelogs
+       ./dh_shlibdeps
        ./dh_link
        ./dh_compress
        ./dh_fixperms