]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/blobdiff - debian/rules
fix UDEV_RULES_DIR location (and set SYSTEMD_UNIT DIR et al.)
[deb_pkgs/autorandr.git] / debian / rules
index 646ff94eb87499283f1498d876c57241494dd579..9308dec10a025d713b15f3092ea73d2829e72e31 100755 (executable)
@@ -3,6 +3,21 @@
 %:
        dh $@
 
+override_dh_auto_build:
+       dh_auto_build -- UDEV_RULES_DIR=/lib/udev/rules.d \
+               SYSTEMD_UNIT_DIR=/lib/systemd/system \
+               BASH_COMPLETIONS_DIR=/usr/share/bash-completion/completions \
+               PM_SLEEPHOOKS_DIR=/etc/pm/sleep.d/
+
+override_dh_auto_install:
+       dh_auto_install -- UDEV_RULES_DIR=/lib/udev/rules.d \
+               SYSTEMD_UNIT_DIR=/lib/systemd/system \
+               BASH_COMPLETIONS_DIR=/usr/share/bash-completion/completions \
+               PM_SLEEPHOOKS_DIR=/etc/pm/sleep.d/
+       install -D -m 755 contrib/pm-utils/40autorandr debian/autorandr/etc/pm/sleep.d/40autorandr
+
+
+
 override_dh_auto_clean:
        dh_auto_clean
        rm -rf .pybuild autorandr.egg-info