]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - debian/rules
Synchronized with patch 43 from Manojs tree
[debian/debian-policy.git] / debian / rules
index 115c1e4d9da40e39e9a0e926fb7cd12a9b1cf8e4..885fd6ddcab4a1450ee7f094f0fe0d3d787d5e6e 100755 (executable)
@@ -4,10 +4,10 @@
 ## Author          : Manoj Srivastava ( srivasta@tiamat.datasync.com )
 ## Created On      : Thu Oct 29 15:35:55 1998
 ## Created On Node  : tiamat.datasync.com
-## Last Modified By : Manoj Srivastava
-## Last Modified On : Tue Jun 29 14:55:15 1999
+## Last Modified By : Julian Gilbey
+## Last Modified On : Mon Dec 20 21:01:12 GMT 1999
 ## Last Machine Used: glaurung.green-gryphon.com
-## Update Count            : 47
+## Update Count            : 51
 ## Status          : Unknown, Use with caution!
 ## HISTORY         :
 ## Description     :
@@ -22,35 +22,43 @@ version := $(shell LC_ALL=C dpkg-parsechangelog | \
 ppackage:= packaging-manual
 
 FILES_TO_CLEAN  = debian/files debian/buildinfo  debian/substvars \
+                 debian/postinst debian/prerm \
                  version.ent  policy.lout policy.lout.ld lout.li \
                  upgrading-checklist.text policy.text.gz \
                  packaging.lout packaging.text.gz packaging.ps \
-                  packaging.pdf.gz menu-policy.text.gz \
-                  proposal.text.gz menu-policy.pdf.gz proposal.pdf.gz
+                 packaging.pdf.gz menu-policy.text.gz \
+                 proposal.text.gz menu-policy.pdf.gz proposal.pdf.gz \
+                 mime-policy.text.gz mime-policy.pdf.gz
 STAMPS_TO_CLEAN = stamp-policy stamp-packaging stamp-build stamp-configure
 DIRS_TO_CLEAN   = debian/tmp policy.html fhs debian/tmp-packaging \
-                  packaging.html menu-policy.html proposal.html
-SGML_FILES      = policy packaging menu-policy proposal
+                 packaging.html menu-policy.html mime-policy.html \
+                 proposal.html
+SGML_FILES      = policy packaging menu-policy mime-policy proposal
 
 # Location of the source dir
 SRCTOP   := $(shell if [ "$$PWD" != "" ]; then echo $$PWD; else pwd; fi;)
 TMPTOP   := $(SRCTOP)/debian/tmp
-DOCDIR   := $(TMPTOP)/usr/doc/$(package)
+DOCDIR   := $(TMPTOP)/usr/share/doc/$(package)
 LIBDIR   := $(TMPTOP)/usr/share/doc-base
 
 PTMPTOP          := $(SRCTOP)/debian/tmp-packaging
-PDOCDIR          := $(PTMPTOP)/usr/doc/$(ppackage)
+PDOCDIR          := $(PTMPTOP)/usr/share/doc/$(ppackage)
 PLIBDIR          := $(PTMPTOP)/usr/share/doc-base
 
-FHS_ARCHIVE  =$(shell ls -1 fhs*.tar.gz)
+# While we have two versions of the FHS installed in the source package,
+# we need to modify this to handle it.  This is the easiest way to do it.
+# FHS_ARCHIVE  =$(shell ls -1 fhs*.tar.gz)
+FHS_ARCHIVE  =fhs-2.1-pre-03.tar.gz
 FHS_FILES    =fhs/fhs.dvi fhs/fhs.ps fhs/fhs.txt
 FSSTND_FILES =FSSTND-FAQ fsstnd-1.2.dvi.gz fsstnd-1.2.ps.gz fsstnd-1.2.txt.gz
 POLICY_FILES =policy.text.gz policy.sgml virtual-package-names-list.text \
              upgrading-checklist.text libc6-migration.text \
              version.ent proposal.sgml proposal.text.gz \
-              menu-policy.sgml menu-policy.text.gz
+             menu-policy.sgml menu-policy.text.gz \
+             mime-policy.sgml mime-policy.text.gz
 BYHAND_FILES =policy.text.gz libc6-migration.text \
-              virtual-package-names-list.text menu-policy.text.gz
+             virtual-package-names-list.text menu-policy.text.gz \
+             mime-policy.text.gz
 PBYHAND_FILES=packaging.text.gz
 
 install_file   = /usr/bin/install -p   -o root -g root  -m  644
@@ -114,6 +122,7 @@ stamp-policy:  build
        # a given that the debian-policy pkg must always comply with
        # itself...
        echo "debian-policy:Version=$(version)"      > debian/substvars
+       echo "packaging-manual:Version=$(version)"   >> debian/substvars
        $(install_file)     $(POLICY_FILES)          $(DOCDIR)/
        $(install_file)     $(FSSTND_FILES)          $(DOCDIR)/fsstnd/
        $(install_file)     $(FHS_FILES)             $(DOCDIR)/fhs/
@@ -123,14 +132,21 @@ stamp-policy:  build
        $(install_file)     debian-policy.desc       $(LIBDIR)/debian-policy
        (tar cf -           policy.html) |           (cd $(DOCDIR);   tar xf -)
        (tar cf -           menu-policy.html) |      (cd $(DOCDIR);   tar xf -)
+       (tar cf -           mime-policy.html) |      (cd $(DOCDIR);   tar xf -)
        (tar cf -           proposal.html) |         (cd $(DOCDIR);   tar xf -)
+       sed -e 's/#PACKAGE#/$(package)/' debian/postinst.in > debian/postinst
+       sed -e 's/#PACKAGE#/$(package)/' debian/prerm.in > debian/prerm
        $(install_program)  debian/{postinst,prerm}  debian/tmp/DEBIAN/
        dpkg-gencontrol     -pdebian-policy -Pdebian/tmp -isp
        chown               -R root.root debian/tmp
        chmod               -R go=rX debian/tmp
        dpkg                --build debian/tmp ..
-       debiandoc2latexps   -O policy.sgml | gzip -9v >  ../policy.ps.gz
-       debiandoc2latexpdf  -O policy.sgml | gzip -9v >  ../policy.pdf.gz
+       debiandoc2latexps    policy.sgml
+       mv policy.ps         ../
+       gzip -9qvf            ../policy.ps
+       debiandoc2latexpdf  policy.sgml
+       mv policy.pdf        ../
+       gzip -9qfv           ../policy.pdf
        GZIP=-9v tar zcf    ../policy.html.tar.gz    policy.html
        dpkg-distaddfile    -fdebian/files           policy.ps.gz       byhand -
        dpkg-distaddfile    -fdebian/files           policy.pdf.gz      byhand -
@@ -149,23 +165,30 @@ stamp-packaging:  build
        $(make_directory)       $(PTMPTOP)/DEBIAN
        $(make_directory)       $(PDOCDIR)
        $(make_directory)       $(PLIBDIR)
-       echo "packaging-manual:Version=$(version)"           > debian/substvars
+       echo "debian-policy:Version=$(version)"      > debian/substvars
+       echo "packaging-manual:Version=$(version)"   >> debian/substvars
 
        $(install_file)    packaging.sgml            $(PDOCDIR)/
        $(install_file)    version.ent               $(PDOCDIR)/
        $(install_file)    debian/changelog          $(PDOCDIR)/
-       -gzip -fqr9        $(DOCDIR)
+       -gzip -fqr9        $(PDOCDIR)
        $(install_file)    packaging.text.gz         $(PDOCDIR)/
        $(install_file)    debian/copyright          $(PDOCDIR)/
        $(install_file)    packaging-manual.desc     $(PLIBDIR)/packaging-manual
        (tar cf -          packaging.html) |         (cd $(PDOCDIR);   tar xf -)
+       sed -e 's/#PACKAGE#/$(ppackage)/' debian/postinst.in > debian/postinst
+       sed -e 's/#PACKAGE#/$(ppackage)/' debian/prerm.in > debian/prerm
        $(install_program) debian/{postinst,prerm}   debian/tmp-packaging/DEBIAN/
        dpkg-gencontrol    -ppackaging-manual -Pdebian/tmp-packaging -isp
        chown              -R root.root debian/tmp-packaging
        chmod              -R go=rX debian/tmp-packaging
        dpkg               --build debian/tmp-packaging ..
-       debiandoc2latexps  -O packaging.sgml | gzip -9f > ../packaging.ps.gz
-       debiandoc2latexpdf -O packaging.sgml | gzip -9f > ../packaging.pdf.gz
+       debiandoc2latexps  packaging.sgml
+       debiandoc2latexpdf packaging.sgml
+       mv packaging.ps    ../
+       mv packaging.pdf   ../
+       gzip -9vf          ../packaging.ps
+       gzip -9vf          ../packaging.pdf
        GZIP=-9v tar zcf   ../packaging.html.tar.gz    packaging.html
        dpkg-distaddfile   -fdebian/files        packaging.ps.gz       byhand -
        dpkg-distaddfile   -fdebian/files        packaging.pdf.gz      byhand -