]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - debian/rules
Merge branch 'master' into bug23712-rra
[debian/debian-policy.git] / debian / rules
index 07e635e68cd5cb537c4349d18e7895d5b0b5be29..7b8729090a70ca527909321f1945583bc0f0ffa9 100755 (executable)
@@ -21,6 +21,9 @@ package := $(shell grep Source debian/control | sed 's/^Source: //')
 date   := $(shell date +"%Y-%m-%d")
 version := $(shell awk -F '[()]' '/^$(package)/{ print $$2; exit }' debian/changelog)
 
+# Currently, emacs23 is required (xemacs is not sufficient).
+EMACS   := emacs23
+
 # Location of the source dir
 SRCTOP   := $(CURDIR)
 TMPTOP   := $(SRCTOP)/debian/tmp
@@ -29,7 +32,7 @@ LIBDIR          := $(TMPTOP)/usr/share/doc-base
 
 sanitycheck := debian/rules policy.sgml
 
-SGML_FILES := policy menu-policy mime-policy perl-policy
+SGML_FILES := policy menu-policy mime-policy perl-policy upgrading-checklist
 DESC_FILES := debian-policy debian-menu-policy debian-perl-policy \
               debian-mime-policy debconf-spec fhs
 
@@ -45,21 +48,25 @@ FHS_NEW_FILES    :=
 
 POLICY_FILES = $(SGML_FILES:=.sgml) $(SGML_FILES:=.txt.gz) \
               virtual-package-names-list.txt \
-              upgrading-checklist.txt libc6-migration.txt version.ent \
+              libc6-migration.txt version.ent \
                debconf_spec/debconf_specification.html \
                debconf_spec/debconf_specification.txt.gz \
-               policy.ps.gz policy.pdf.gz
+               policy.ps.gz policy.pdf.gz README.txt README.html \
+               Process.txt Process.html
+
+FILES_FROM_ORG := Process.html Process.txt README.txt README.html
 
 # policy.{pdf,ps,tpt,txt} are generated files
 FILES_TO_CLEAN  = debian/files debian/buildinfo  debian/substvars \
                  debian/postinst debian/prerm \
-                 version.ent upgrading-checklist.txt \
+                 version.ent \
                  $(SGML_FILES:=.txt.gz) $(SGML_FILES:=.html.tar.gz) \
                   $(SGML_FILES:=-1.html) \
                  policy.pdf.gz policy.ps.gz \
                  debconf_specification.xml.tar.gz \
                  policy.pdf policy.ps policy.txt policy. \
-                 body.tmp head.tmp policy.tpt
+                 body.tmp head.tmp policy.tpt \
+                 $(FILES_FROM_ORG)
 
 STAMPS_TO_CLEAN := stamp-policy stamp-build
 DIRS_TO_CLEAN   := debian/tmp fhs $(SGML_FILES:=.html)
@@ -77,8 +84,7 @@ stamp-build: version.ent $(sanitycheck)
                 $(SGML_FILES:=-1.html) \
                $(SGML_FILES:=.txt.gz) \
                policy.ps.gz policy.pdf.gz
-       links -dump upgrading-checklist.html | perl -pe 's/[\r\0]//g' > \
-                    upgrading-checklist.txt
+       $(MAKE) $(FILES_FROM_ORG)
        $(MAKE) -C debconf_spec all
        touch stamp-build