]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - debian/rules
* Really install the FHS HTML version this time
[debian/debian-policy.git] / debian / rules
index e02d2e985d6e3095ac848564b7c16f1b70bdb3f4..69b5dfd1b1b607d19d02a0cec8eb48bc0f8ef9c6 100755 (executable)
@@ -18,15 +18,15 @@ ifdef ARCH
   ha:=-a$(ARCH)
 endif
 
-# set the dpkg-architecture vars
-export DEB_BUILD_ARCH      := $(shell dpkg-architecture $(ha) -qDEB_BUILD_ARCH)
-export DEB_BUILD_GNU_CPU   := $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_CPU)
-export DEB_BUILD_GNU_SYSTEM:= $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_SYSTEM)
-export DEB_BUILD_GNU_TYPE  := $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_TYPE)
-export DEB_HOST_ARCH       := $(shell dpkg-architecture $(ha) -qDEB_HOST_ARCH)
-export DEB_HOST_GNU_CPU    := $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_CPU)
-export DEB_HOST_GNU_SYSTEM := $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_SYSTEM)
-export DEB_HOST_GNU_TYPE   := $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_TYPE)
+# set the dpkg-architecture vars; but we don't use them, so we'll comment out
+export DEB_BUILD_ARCH      := $(shell dpkg-architecture $(ha) -qDEB_BUILD_ARCH)
+export DEB_BUILD_GNU_CPU   := $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_CPU)
+export DEB_BUILD_GNU_SYSTEM:= $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_SYSTEM)
+export DEB_BUILD_GNU_TYPE  := $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_TYPE)
+export DEB_HOST_ARCH       := $(shell dpkg-architecture $(ha) -qDEB_HOST_ARCH)
+export DEB_HOST_GNU_CPU    := $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_CPU)
+export DEB_HOST_GNU_SYSTEM := $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_SYSTEM)
+export DEB_HOST_GNU_TYPE   := $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_TYPE)
 
 
 
@@ -42,6 +42,7 @@ FILES_TO_CLEAN  = debian/files debian/buildinfo  debian/substvars \
                  version.ent  policy.lout policy.lout.ld lout.li \
                  upgrading-checklist.txt policy.txt.gz \
                  menu-policy.txt.gz menu-policy.pdf.gz \
+                 perl-policy.txt.gz perl-policy.pdf.gz \
                  policy-process.txt.gz policy-process.pdf.gz \
                  mime-policy.txt.gz mime-policy.pdf.gz \
                   debconf_spec/debconf_specification.html \
@@ -50,8 +51,8 @@ FILES_TO_CLEAN  = debian/files debian/buildinfo  debian/substvars \
 STAMPS_TO_CLEAN = stamp-policy stamp-build stamp-configure
 DIRS_TO_CLEAN   = debian/tmp policy.html fhs \
                  menu-policy.html mime-policy.html \
-                 policy-process.html
-SGML_FILES      = policy menu-policy mime-policy policy-process
+                 policy-process.html perl-policy.html
+SGML_FILES      = policy menu-policy mime-policy policy-process perl-policy
 
 # Location of the source dir
 SRCTOP   := $(shell if [ "$$PWD" != "" ]; then echo $$PWD; else pwd; fi;)
@@ -73,6 +74,7 @@ FHS_BYHAND   =fhs-2.1.html.tar.gz fhs/fhs.txt
 POLICY_FILES =policy.txt.gz policy.sgml virtual-package-names-list.txt \
              upgrading-checklist.txt libc6-migration.txt version.ent \
              menu-policy.sgml menu-policy.txt.gz \
+             perl-policy.sgml perl-policy.txt.gz \
              mime-policy.sgml mime-policy.txt.gz \
               policy-process.txt.gz policy-process.sgml \
               debconf_spec/debconf_specification.html \
@@ -80,7 +82,7 @@ POLICY_FILES =policy.txt.gz policy.sgml virtual-package-names-list.txt \
 BYHAND_FILES =policy.txt.gz libc6-migration.txt \
              virtual-package-names-list.txt menu-policy.txt.gz \
              mime-policy.txt.gz policy.ps.gz policy.pdf.gz \
-              policy.html.tar.gz \
+              policy.html.tar.gz perl-policy.txt.gz \
              debconf_spec/debconf_specification.txt.gz \
              $(FHS_BYHAND)
 
@@ -114,7 +116,6 @@ stamp-build:
        GROFF_TMAC_PATH=. cd fhs && $(MAKE) fhs.ps fhs.pdf fhs.txt
        links -dump fhs-changes-2.1.html | perl -pe 's/[\r\0]//g' > \
                     fhs/fhs-changes-2.1.txt
-       cd fhs && tar zfx ../$(FHS_HTML)
        links -dump upgrading-checklist.html | perl -pe 's/[\r\0]//g' > \
                     upgrading-checklist.txt
        $(MAKE) -C debconf_spec all
@@ -151,7 +152,8 @@ stamp-policy:  build
        @test $$(id | sed -e 's/(.*$$//' -e 's/^uid=//') || \
                (echo need root priviledges; exit 1)
        $(checkdir)
-       test -f stamp-build     || $(MAKE) -f        debian/rules build
+#      This is unnecessary; commenting out
+#      test -f stamp-build     || $(MAKE) -f        debian/rules build
        -rm -rf                 $(TMPTOP)
        $(make_directory)       $(TMPTOP)/DEBIAN
 #      $(make_directory)       $(DOCDIR)/fsstnd
@@ -167,14 +169,17 @@ stamp-policy:  build
 #      $(install_file)     $(FSSTND_FILES)          $(DOCDIR)/fsstnd/
        $(install_file)     $(FHS_FILES)             $(DOCDIR)/fhs/
        $(install_file)     debian/changelog         $(DOCDIR)/
-       -gzip -fqr9         $(DOCDIR)
-       -gunzip             $(DOCDIR)/version.ent
+       # Be more specific with file compression
+       -gzip -q9           $(DOCDIR)/*.txt $(DOCDIR)/*.sgml \
+                               $(DOCDIR)/fhs/* $(DOCDIR)/changelog
        $(install_file)     debian/copyright         $(DOCDIR)/
        $(install_file)     debian-policy.desc       $(LIBDIR)/debian-policy
-       (tar cf -           policy.html) |           (cd $(DOCDIR);   tar xf -)
-       (tar cf -           menu-policy.html) |      (cd $(DOCDIR);   tar xf -)
-       (tar cf -           mime-policy.html) |      (cd $(DOCDIR);   tar xf -)
-       (tar cf -           policy-process.html) |   (cd $(DOCDIR);   tar xf -)
+       (tar cf -           policy.html) |           (cd $(DOCDIR) && tar xf -)
+       (tar cf -           menu-policy.html) |      (cd $(DOCDIR) && tar xf -)
+       (tar cf -           perl-policy.html) |      (cd $(DOCDIR) && tar xf -)
+       (tar cf -           mime-policy.html) |      (cd $(DOCDIR) && tar xf -)
+       (tar cf -           policy-process.html) |   (cd $(DOCDIR) && tar xf -)
+       tar -C $(DOCDIR)/fhs -zfx $(FHS_HTML)
        sed -e 's/#PACKAGE#/$(package)/g' debian/postinst.in > debian/postinst
        sed -e 's/#PACKAGE#/$(package)/g' debian/prerm.in > debian/prerm
        $(install_program)  debian/postinst          debian/tmp/DEBIAN/