]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - debian/rules
* Typos in various documents
[debian/debian-policy.git] / debian / rules
index bec00f898161be26d681421e791a74094adc491e..52161c9688d34e7efaf846c06cb5d8e3fc9985b9 100755 (executable)
@@ -40,20 +40,18 @@ version := $(shell LC_ALL=C dpkg-parsechangelog | \
 FILES_TO_CLEAN  = debian/files debian/buildinfo  debian/substvars \
                  debian/postinst debian/prerm \
                  version.ent  policy.lout policy.lout.ld lout.li \
-                 upgrading-checklist.text policy.text.gz \
-                 menu-policy.text.gz \
-                 policy-process.text.gz policy-process.pdf.gz  \
-                 proposal.text.gz menu-policy.pdf.gz proposal.pdf.gz \
-                 mime-policy.text.gz mime-policy.pdf.gz \
+                 upgrading-checklist.txt policy.txt.gz \
+                 menu-policy.txt.gz menu-policy.pdf.gz \
+                 policy-process.txt.gz policy-process.pdf.gz \
+                 mime-policy.txt.gz mime-policy.pdf.gz \
                   debconf_spec/debconf_specification.html \
                   debconf_spec/debconf_specification.txt.gz \
 
 STAMPS_TO_CLEAN = stamp-policy stamp-build stamp-configure
 DIRS_TO_CLEAN   = debian/tmp policy.html fhs \
-                  menu-policy.html mime-policy.html \
-                 proposal.html policy-process.html
-SGML_FILES      = policy  menu-policy mime-policy proposal \
-                  policy-process
+                 menu-policy.html mime-policy.html \
+                 policy-process.html
+SGML_FILES      = policy menu-policy mime-policy policy-process
 
 # Location of the source dir
 SRCTOP   := $(shell if [ "$$PWD" != "" ]; then echo $$PWD; else pwd; fi;)
@@ -68,21 +66,23 @@ LIBDIR        := $(TMPTOP)/usr/share/doc-base
 # And with version 2.1, we have to build the text and dvi versions
 # ourselves :-(
 FHS_ARCHIVE  =fhs-2.1-source.tar.gz
-FHS_FILES    = fhs/fhs.ps fhs/fhs.txt fhs/fhs.pdf
-FSSTND_FILES =FSSTND-FAQ fsstnd-1.2.dvi.gz fsstnd-1.2.ps.gz fsstnd-1.2.txt.gz
-POLICY_FILES =policy.text.gz policy.sgml virtual-package-names-list.text \
-             upgrading-checklist.text libc6-migration.text \
-             version.ent proposal.sgml proposal.text.gz \
-             menu-policy.sgml menu-policy.text.gz \
-             mime-policy.sgml mime-policy.text.gz \
-              policy-process.text.gz policy-process.sgml \
+FHS_HTML     =fhs-2.1.html.tar.gz
+FHS_FILES    =fhs/fhs.ps fhs/fhs.txt fhs/fhs.pdf
+FHS_BYHAND   =fhs-2.1.html.tar.gz fhs/fhs.txt
+# FSSTND_FILES =FSSTND-FAQ fsstnd-1.2.dvi.gz fsstnd-1.2.ps.gz fsstnd-1.2.txt.gz
+POLICY_FILES =policy.txt.gz policy.sgml virtual-package-names-list.txt \
+             upgrading-checklist.txt libc6-migration.txt version.ent \
+             menu-policy.sgml menu-policy.txt.gz \
+             mime-policy.sgml mime-policy.txt.gz \
+              policy-process.txt.gz policy-process.sgml \
               debconf_spec/debconf_specification.html \
               debconf_spec/debconf_specification.txt.gz
-BYHAND_FILES =policy.text.gz libc6-migration.text \
-             virtual-package-names-list.text menu-policy.text.gz \
-             mime-policy.text.gz policy.ps.gz policy.pdf.gz \
+BYHAND_FILES =policy.txt.gz libc6-migration.txt \
+             virtual-package-names-list.txt menu-policy.txt.gz \
+             mime-policy.txt.gz policy.ps.gz policy.pdf.gz \
               policy.html.tar.gz \
-             debconf_spec/debconf_specification.txt.gz
+             debconf_spec/debconf_specification.txt.gz \
+             $(FHS_BYHAND)
 
 
 install_file   = /usr/bin/install -p   -o root -g root  -m  644
@@ -100,8 +100,8 @@ stamp-build:
          nsgmls -gues $$file.sgml; \
          debiandoc2html $$file.sgml; \
          debiandoc2text $$file.sgml; \
-         if [ -f $$file.txt ]; then mv $$file.txt $$file.text; fi; \
-         gzip -9f $$file.text; \
+         if [ -f $$file.text ]; then mv $$file.text $$file.txt; fi; \
+         gzip -9f $$file.txt; \
        done
        tar zfx $(FHS_ARCHIVE)
        # Need to use a patched tmac.m macro file if we're using a pre-1.16
@@ -113,9 +113,10 @@ stamp-build:
        # The extra '.' in the tmac path doesn't matter if
        GROFF_TMAC_PATH=. cd fhs && $(MAKE) fhs.ps fhs.pdf fhs.txt
        links -dump fhs-changes-2.1.html | perl -pe 's/[\r\0]//g' > \
-                    fhs/fhs-changes-2.1.text
+                    fhs/fhs-changes-2.1.txt
+       cd fhs && tar zfx ../$(FHS_HTML)
        links -dump upgrading-checklist.html | perl -pe 's/[\r\0]//g' > \
-                    upgrading-checklist.text
+                    upgrading-checklist.txt
        $(MAKE) -C debconf_spec all
        gzip -9f debconf_spec/debconf_specification.txt
        touch stamp-build
@@ -153,7 +154,7 @@ stamp-policy:  build
        test -f stamp-build     || $(MAKE) -f        debian/rules build
        -rm -rf                 $(TMPTOP)
        $(make_directory)       $(TMPTOP)/DEBIAN
-       $(make_directory)       $(DOCDIR)/fsstnd
+#      $(make_directory)       $(DOCDIR)/fsstnd
        $(make_directory)       $(DOCDIR)/fhs
        $(make_directory)       $(LIBDIR)
        # create a substvar to reference from debian/control so that
@@ -163,35 +164,35 @@ stamp-policy:  build
        # itself...
        echo "debian-policy:Version=$(version)"      > debian/substvars
        $(install_file)     $(POLICY_FILES)          $(DOCDIR)/
-       $(install_file)     $(FSSTND_FILES)          $(DOCDIR)/fsstnd/
+#      $(install_file)     $(FSSTND_FILES)          $(DOCDIR)/fsstnd/
        $(install_file)     $(FHS_FILES)             $(DOCDIR)/fhs/
        $(install_file)     debian/changelog         $(DOCDIR)/
        -gzip -fqr9         $(DOCDIR)
+       -gunzip             $(DOCDIR)/version.ent
        $(install_file)     debian/copyright         $(DOCDIR)/
        $(install_file)     debian-policy.desc       $(LIBDIR)/debian-policy
        (tar cf -           policy.html) |           (cd $(DOCDIR);   tar xf -)
        (tar cf -           menu-policy.html) |      (cd $(DOCDIR);   tar xf -)
        (tar cf -           mime-policy.html) |      (cd $(DOCDIR);   tar xf -)
-       (tar cf -           proposal.html) |         (cd $(DOCDIR);   tar xf -)
        (tar cf -           policy-process.html) |   (cd $(DOCDIR);   tar xf -)
        sed -e 's/#PACKAGE#/$(package)/g' debian/postinst.in > debian/postinst
        sed -e 's/#PACKAGE#/$(package)/g' debian/prerm.in > debian/prerm
-       $(install_program)  debian/{postinst,prerm}  debian/tmp/DEBIAN/
+       $(install_program)  debian/postinst          debian/tmp/DEBIAN/
+       $(install_program)  debian/prerm             debian/tmp/DEBIAN/
        dpkg-gencontrol     -pdebian-policy -Pdebian/tmp -isp
        chown               -R root.root debian/tmp
        chmod               -R go=rX debian/tmp
        dpkg                --build debian/tmp ..
-       debiandoc2latexps    policy.sgml
-       gzip -9qvf           policy.ps
-       debiandoc2latexpdf   policy.sgml
-       gzip -9qfv           policy.pdf
-       GZIP=-9v tar zcf     policy.html.tar.gz    policy.html
-       $(install_file)    version.ent               $(DOCDIR)/
+       debiandoc2latexps   policy.sgml
+       gzip -9qvf          policy.ps
+       debiandoc2latexpdf  policy.sgml
+       gzip -9qfv          policy.pdf
+       GZIP=-9v tar zcf    policy.html.tar.gz    policy.html
        for i in            $(BYHAND_FILES); do                          \
          $(install_file)   $$i            ..                          ; \
          dpkg-distaddfile  -fdebian/files `basename $$i`     byhand - ; \
        done
-       touch              stamp-policy
+       touch               stamp-policy
 
 
 define checkdir