]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - debian/rules
* Typos in various documents
[debian/debian-policy.git] / debian / rules
index 91cd6c26daa906939309ea7dd0fac7bbbef74111..52161c9688d34e7efaf846c06cb5d8e3fc9985b9 100755 (executable)
@@ -5,35 +5,53 @@
 ## Created On      : Thu Oct 29 15:35:55 1998
 ## Created On Node  : tiamat.datasync.com
 ## Last Modified By : Manoj Srivastava
-## Last Modified On : Wed Jun 30 23:05:51 1999
+## Last Modified On : Wed Sep  6 09:37:43 2000
 ## Last Machine Used: glaurung.green-gryphon.com
-## Update Count            : 51
+## Update Count            : 56
 ## Status          : Unknown, Use with caution!
 ## HISTORY         :
 ## Description     :
 ## $Id$
 ###############################################################################
+
+ifdef ARCH
+  ha:=-a$(ARCH)
+endif
+
+# set the dpkg-architecture vars
+export DEB_BUILD_ARCH      := $(shell dpkg-architecture $(ha) -qDEB_BUILD_ARCH)
+export DEB_BUILD_GNU_CPU   := $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_CPU)
+export DEB_BUILD_GNU_SYSTEM:= $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_SYSTEM)
+export DEB_BUILD_GNU_TYPE  := $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_TYPE)
+export DEB_HOST_ARCH       := $(shell dpkg-architecture $(ha) -qDEB_HOST_ARCH)
+export DEB_HOST_GNU_CPU    := $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_CPU)
+export DEB_HOST_GNU_SYSTEM := $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_SYSTEM)
+export DEB_HOST_GNU_TYPE   := $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_TYPE)
+
+
+
 # The name of the package (for example, `emacs').
 package := $(shell grep Source debian/control | sed 's/^Source: //')
 arch   := $(shell dpkg --print-installation-architecture)
 date   := $(shell date +"%Y-%m-%d")
 version := $(shell LC_ALL=C dpkg-parsechangelog | \
                   grep ^Version: | sed 's/^Version: *//')
-ppackage:= packaging-manual
 
 FILES_TO_CLEAN  = debian/files debian/buildinfo  debian/substvars \
                  debian/postinst debian/prerm \
                  version.ent  policy.lout policy.lout.ld lout.li \
-                 upgrading-checklist.text policy.text.gz \
-                 packaging.lout packaging.text.gz packaging.ps \
-                 packaging.pdf.gz menu-policy.text.gz \
-                 proposal.text.gz menu-policy.pdf.gz proposal.pdf.gz \
-                 mime-policy.text.gz mime-policy.pdf.gz
-STAMPS_TO_CLEAN = stamp-policy stamp-packaging stamp-build stamp-configure
-DIRS_TO_CLEAN   = debian/tmp policy.html fhs debian/tmp-packaging \
-                 packaging.html menu-policy.html mime-policy.html \
-                 proposal.html
-SGML_FILES      = policy packaging menu-policy mime-policy proposal
+                 upgrading-checklist.txt policy.txt.gz \
+                 menu-policy.txt.gz menu-policy.pdf.gz \
+                 policy-process.txt.gz policy-process.pdf.gz \
+                 mime-policy.txt.gz mime-policy.pdf.gz \
+                  debconf_spec/debconf_specification.html \
+                  debconf_spec/debconf_specification.txt.gz \
+
+STAMPS_TO_CLEAN = stamp-policy stamp-build stamp-configure
+DIRS_TO_CLEAN   = debian/tmp policy.html fhs \
+                 menu-policy.html mime-policy.html \
+                 policy-process.html
+SGML_FILES      = policy menu-policy mime-policy policy-process
 
 # Location of the source dir
 SRCTOP   := $(shell if [ "$$PWD" != "" ]; then echo $$PWD; else pwd; fi;)
@@ -41,27 +59,38 @@ TMPTOP        := $(SRCTOP)/debian/tmp
 DOCDIR   := $(TMPTOP)/usr/share/doc/$(package)
 LIBDIR   := $(TMPTOP)/usr/share/doc-base
 
-PTMPTOP          := $(SRCTOP)/debian/tmp-packaging
-PDOCDIR          := $(PTMPTOP)/usr/share/doc/$(ppackage)
-PLIBDIR          := $(PTMPTOP)/usr/share/doc-base
-
-FHS_ARCHIVE  =$(shell ls -1 fhs*.tar.gz)
-FHS_FILES    =fhs/fhs.dvi fhs/fhs.ps fhs/fhs.txt
-FSSTND_FILES =FSSTND-FAQ fsstnd-1.2.dvi.gz fsstnd-1.2.ps.gz fsstnd-1.2.txt.gz
-POLICY_FILES =policy.text.gz policy.sgml virtual-package-names-list.text \
-             upgrading-checklist.text libc6-migration.text \
-             version.ent proposal.sgml proposal.text.gz \
-             menu-policy.sgml menu-policy.text.gz \
-             mime-policy.sgml mime-policy.text.gz
-BYHAND_FILES =policy.text.gz libc6-migration.text \
-             virtual-package-names-list.text menu-policy.text.gz \
-             mime-policy.text.gz
-PBYHAND_FILES=packaging.text.gz
+
+# While we have two versions of the FHS installed in the source package,
+# we need to modify this to handle it.  This is the easiest way to do it.
+# FHS_ARCHIVE  =$(shell ls -1 fhs*.tar.gz)
+# And with version 2.1, we have to build the text and dvi versions
+# ourselves :-(
+FHS_ARCHIVE  =fhs-2.1-source.tar.gz
+FHS_HTML     =fhs-2.1.html.tar.gz
+FHS_FILES    =fhs/fhs.ps fhs/fhs.txt fhs/fhs.pdf
+FHS_BYHAND   =fhs-2.1.html.tar.gz fhs/fhs.txt
+# FSSTND_FILES =FSSTND-FAQ fsstnd-1.2.dvi.gz fsstnd-1.2.ps.gz fsstnd-1.2.txt.gz
+POLICY_FILES =policy.txt.gz policy.sgml virtual-package-names-list.txt \
+             upgrading-checklist.txt libc6-migration.txt version.ent \
+             menu-policy.sgml menu-policy.txt.gz \
+             mime-policy.sgml mime-policy.txt.gz \
+              policy-process.txt.gz policy-process.sgml \
+              debconf_spec/debconf_specification.html \
+              debconf_spec/debconf_specification.txt.gz
+BYHAND_FILES =policy.txt.gz libc6-migration.txt \
+             virtual-package-names-list.txt menu-policy.txt.gz \
+             mime-policy.txt.gz policy.ps.gz policy.pdf.gz \
+              policy.html.tar.gz \
+             debconf_spec/debconf_specification.txt.gz \
+             $(FHS_BYHAND)
+
 
 install_file   = /usr/bin/install -p   -o root -g root  -m  644
 install_program= /usr/bin/install -p   -o root -g root  -m  755
 make_directory = /usr/bin/install -p -d -o root -g root         -m  755
 
+GROFF_VERSION := $(shell dpkg -s groff | sed -n -e 's/Version: //p')
+
 
 all build: stamp-build
 stamp-build:
@@ -71,11 +100,25 @@ stamp-build:
          nsgmls -gues $$file.sgml; \
          debiandoc2html $$file.sgml; \
          debiandoc2text $$file.sgml; \
-         if [ -f $$file.txt ]; then mv $$file.txt $$file.text; fi; \
-         gzip -9f $$file.text; \
+         if [ -f $$file.text ]; then mv $$file.text $$file.txt; fi; \
+         gzip -9f $$file.txt; \
        done
        tar zfx $(FHS_ARCHIVE)
-       lynx -dump upgrading-checklist.html > upgrading-checklist.text
+       # Need to use a patched tmac.m macro file if we're using a pre-1.16
+       # groff; version 1.16 is apparently fixed
+       if dpkg --compare-versions $(GROFF_VERSION) lt 1.16; then \
+           cp /usr/share/groff/tmac/tmac.m fhs && \
+           cd fhs && patch -p1 < ../mm1.32-patch; \
+       fi
+       # The extra '.' in the tmac path doesn't matter if
+       GROFF_TMAC_PATH=. cd fhs && $(MAKE) fhs.ps fhs.pdf fhs.txt
+       links -dump fhs-changes-2.1.html | perl -pe 's/[\r\0]//g' > \
+                    fhs/fhs-changes-2.1.txt
+       cd fhs && tar zfx ../$(FHS_HTML)
+       links -dump upgrading-checklist.html | perl -pe 's/[\r\0]//g' > \
+                    upgrading-checklist.txt
+       $(MAKE) -C debconf_spec all
+       gzip -9f debconf_spec/debconf_specification.txt
        touch stamp-build
 
 configure: stamp-configure
@@ -103,14 +146,15 @@ binary-arch:      build
 # generated by this package.  If there were any they would be
 # made here.
 
-binary-indep:  stamp-policy stamp-packaging
+binary-indep:  stamp-policy
 stamp-policy:  build
-       @test root = "`whoami`" || (echo need root priviledges; exit 1)
+       @test $$(id | sed -e 's/(.*$$//' -e 's/^uid=//') || \
+               (echo need root priviledges; exit 1)
        $(checkdir)
        test -f stamp-build     || $(MAKE) -f        debian/rules build
        -rm -rf                 $(TMPTOP)
        $(make_directory)       $(TMPTOP)/DEBIAN
-       $(make_directory)       $(DOCDIR)/fsstnd
+#      $(make_directory)       $(DOCDIR)/fsstnd
        $(make_directory)       $(DOCDIR)/fhs
        $(make_directory)       $(LIBDIR)
        # create a substvar to reference from debian/control so that
@@ -119,82 +163,36 @@ stamp-policy:  build
        # a given that the debian-policy pkg must always comply with
        # itself...
        echo "debian-policy:Version=$(version)"      > debian/substvars
-       echo "packaging-manual:Version=$(version)"   >> debian/substvars
        $(install_file)     $(POLICY_FILES)          $(DOCDIR)/
-       $(install_file)     $(FSSTND_FILES)          $(DOCDIR)/fsstnd/
+#      $(install_file)     $(FSSTND_FILES)          $(DOCDIR)/fsstnd/
        $(install_file)     $(FHS_FILES)             $(DOCDIR)/fhs/
        $(install_file)     debian/changelog         $(DOCDIR)/
        -gzip -fqr9         $(DOCDIR)
+       -gunzip             $(DOCDIR)/version.ent
        $(install_file)     debian/copyright         $(DOCDIR)/
        $(install_file)     debian-policy.desc       $(LIBDIR)/debian-policy
        (tar cf -           policy.html) |           (cd $(DOCDIR);   tar xf -)
        (tar cf -           menu-policy.html) |      (cd $(DOCDIR);   tar xf -)
        (tar cf -           mime-policy.html) |      (cd $(DOCDIR);   tar xf -)
-       (tar cf -           proposal.html) |         (cd $(DOCDIR);   tar xf -)
-       sed -e 's/#PACKAGE#/$(package)/' debian/postinst.in > debian/postinst
-       sed -e 's/#PACKAGE#/$(package)/' debian/prerm.in > debian/prerm
-       $(install_program)  debian/{postinst,prerm}  debian/tmp/DEBIAN/
+       (tar cf -           policy-process.html) |   (cd $(DOCDIR);   tar xf -)
+       sed -e 's/#PACKAGE#/$(package)/g' debian/postinst.in > debian/postinst
+       sed -e 's/#PACKAGE#/$(package)/g' debian/prerm.in > debian/prerm
+       $(install_program)  debian/postinst          debian/tmp/DEBIAN/
+       $(install_program)  debian/prerm             debian/tmp/DEBIAN/
        dpkg-gencontrol     -pdebian-policy -Pdebian/tmp -isp
        chown               -R root.root debian/tmp
        chmod               -R go=rX debian/tmp
        dpkg                --build debian/tmp ..
-       debiandoc2latexps    policy.sgml
-       mv policy.ps         ../
-       gzip -9qvf            ../policy.ps
+       debiandoc2latexps   policy.sgml
+       gzip -9qvf          policy.ps
        debiandoc2latexpdf  policy.sgml
-       mv policy.pdf        ../
-       gzip -9qfv           ../policy.pdf
-       GZIP=-9v tar zcf    ../policy.html.tar.gz    policy.html
-       dpkg-distaddfile    -fdebian/files           policy.ps.gz       byhand -
-       dpkg-distaddfile    -fdebian/files           policy.pdf.gz      byhand -
-       dpkg-distaddfile    -fdebian/files           policy.html.tar.gz byhand -
-       for i in            $(BYHAND_FILES); do \
-         $(install_file)   $$i            ..                ; \
-         dpkg-distaddfile  -fdebian/files $$i       byhand - ; \
-       done
-       touch              stamp-policy
-
-stamp-packaging:  build
-       @test root = "`whoami`" || (echo need root priviledges; exit 1)
-       $(checkdir)
-       test -f stamp-build     || $(MAKE) -f        debian/rules build
-       -rm -rf                 $(PTMPTOP)
-       $(make_directory)       $(PTMPTOP)/DEBIAN
-       $(make_directory)       $(PDOCDIR)
-       $(make_directory)       $(PLIBDIR)
-       echo "debian-policy:Version=$(version)"      > debian/substvars
-       echo "packaging-manual:Version=$(version)"   >> debian/substvars
-
-       $(install_file)    packaging.sgml            $(PDOCDIR)/
-       $(install_file)    version.ent               $(PDOCDIR)/
-       $(install_file)    debian/changelog          $(PDOCDIR)/
-       -gzip -fqr9        $(PDOCDIR)
-       $(install_file)    packaging.text.gz         $(PDOCDIR)/
-       $(install_file)    debian/copyright          $(PDOCDIR)/
-       $(install_file)    packaging-manual.desc     $(PLIBDIR)/packaging-manual
-       (tar cf -          packaging.html) |         (cd $(PDOCDIR);   tar xf -)
-       sed -e 's/#PACKAGE#/$(ppackage)/' debian/postinst.in > debian/postinst
-       sed -e 's/#PACKAGE#/$(ppackage)/' debian/prerm.in > debian/prerm
-       $(install_program) debian/{postinst,prerm}   debian/tmp-packaging/DEBIAN/
-       dpkg-gencontrol    -ppackaging-manual -Pdebian/tmp-packaging -isp
-       chown              -R root.root debian/tmp-packaging
-       chmod              -R go=rX debian/tmp-packaging
-       dpkg               --build debian/tmp-packaging ..
-       debiandoc2latexps  packaging.sgml
-       debiandoc2latexpdf packaging.sgml
-       mv packaging.ps    ../
-       mv packaging.pdf   ../
-       gzip -9vf          ../packaging.ps
-       gzip -9vf          ../packaging.pdf
-       GZIP=-9v tar zcf   ../packaging.html.tar.gz    packaging.html
-       dpkg-distaddfile   -fdebian/files        packaging.ps.gz       byhand -
-       dpkg-distaddfile   -fdebian/files        packaging.pdf.gz      byhand -
-       dpkg-distaddfile   -fdebian/files        packaging.html.tar.gz byhand -
-       for i in            $(PBYHAND_FILES); do \
-         $(install_file)   $$i            ..                ; \
-         dpkg-distaddfile  -fdebian/files $$i       byhand - ; \
+       gzip -9qfv          policy.pdf
+       GZIP=-9v tar zcf    policy.html.tar.gz    policy.html
+       for i in            $(BYHAND_FILES); do                          \
+         $(install_file)   $$i            ..                          ; \
+         dpkg-distaddfile  -fdebian/files `basename $$i`     byhand - ; \
        done
-       touch              stamp-
+       touch               stamp-policy
 
 
 define checkdir