]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - debian/rules
Remove unused debian-policy:Version substitution variable
[debian/debian-policy.git] / debian / rules
index f86477d57f9abebc98c1f6d69107a05d8837bf03..50a581ee892ec078920aa034038c368886fcf5db 100755 (executable)
 #!/usr/bin/make -f
-############################ -*- Mode: Makefile -*- ###########################
-## rules ---
-## Author          : Manoj Srivastava ( srivasta@tiamat.datasync.com )
-## Created On      : Thu Oct 29 15:35:55 1998
-## Created On Node  : tiamat.datasync.com
-## Last Modified By : Manoj Srivastava
-## Last Modified On : Wed Sep  6 09:37:43 2000
-## Last Machine Used: glaurung.green-gryphon.com
-## Update Count            : 56
-## Status          : Unknown, Use with caution!
-## HISTORY         :
-## Description     :
-## $Id$
-###############################################################################
-
-# ifdef ARCH
-#   ha:=-a$(ARCH)
-# endif
-
-# set the dpkg-architecture vars; but we don't use them, so we'll comment out
-# export DEB_BUILD_ARCH      := $(shell dpkg-architecture $(ha) -qDEB_BUILD_ARCH)
-# export DEB_BUILD_GNU_CPU   := $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_CPU)
-# export DEB_BUILD_GNU_SYSTEM:= $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_SYSTEM)
-# export DEB_BUILD_GNU_TYPE  := $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_TYPE)
-# export DEB_HOST_ARCH       := $(shell dpkg-architecture $(ha) -qDEB_HOST_ARCH)
-# export DEB_HOST_GNU_CPU    := $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_CPU)
-# export DEB_HOST_GNU_SYSTEM := $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_SYSTEM)
-# export DEB_HOST_GNU_TYPE   := $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_TYPE)
 
+ifdef ARCH
+  ha:=-a$(ARCH)
+endif
 
-# The name of the package (for example, `emacs').
+# set the dpkg-architecture vars; but we don't use them, so we'll comment out
+export DEB_BUILD_ARCH      ?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_ARCH)
+export DEB_BUILD_GNU_CPU   ?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_CPU)
+export DEB_BUILD_GNU_SYSTEM?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_SYSTEM)
+export DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_TYPE)
+export DEB_HOST_ARCH       ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_ARCH)
+export DEB_HOST_GNU_CPU    ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_CPU)
+export DEB_HOST_GNU_SYSTEM ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_SYSTEM)
+export DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_TYPE)
+
+arch   := $(shell dpkg --print-architecture)
+
+# Basic information
 package := $(shell grep Source debian/control | sed 's/^Source: //')
-# arch := $(shell dpkg --print-installation-architecture)
 date   := $(shell date +"%Y-%m-%d")
-version := $(shell LC_ALL=C dpkg-parsechangelog | \
-                  grep ^Version: | sed 's/^Version: *//')
+version := $(shell awk -F '[()]' '/^$(package)/{ print $$2; exit }' debian/changelog)
+
+# Currently, emacs23 is required (xemacs is not sufficient).
+EMACS   := emacs23
 
 # Location of the source dir
-SRCTOP   := $(shell if [ "$$PWD" != "" ]; then echo $$PWD; else pwd; fi;)
+SRCTOP   := $(CURDIR)
 TMPTOP   := $(SRCTOP)/debian/tmp
 DOCDIR   := $(TMPTOP)/usr/share/doc/$(package)
 LIBDIR   := $(TMPTOP)/usr/share/doc-base
 
+sanitycheck := debian/rules policy.sgml
 
-SGML_FILES      = policy menu-policy mime-policy policy-process perl-policy
-DESC_FILES      = debian-policy debian-menu-policy debian-perl-policy \
-                  debian-mime-policy debian-policy-process debconf-spec \
-                 fhs
+SGML_FILES := policy menu-policy perl-policy upgrading-checklist
+DESC_FILES := copyright-format-1.0 debian-policy debian-menu-policy \
+             debian-perl-policy debconf-spec fhs
 
 # While we have two versions of the FHS installed in the source package,
 # we need to modify this to handle it.  This is the easiest way to do it.
-# FHS_ARCHIVE  =$(shell ls -1 fhs*.tar.gz)
-# And with version 2.1, we have to build the text and dvi versions
-# ourselves :-(
-FHS_ARCHIVE  =fhs-2.1-source.tar.gz
-FHS_HTML     =fhs-2.1.html.tar.gz
-FHS_FILES    =fhs/fhs.ps fhs/fhs.txt fhs/fhs.pdf
-FHS_BYHAND   =fhs-2.1.html.tar.gz fhs/fhs.txt
-# FSSTND_FILES =FSSTND-FAQ fsstnd-1.2.dvi.gz fsstnd-1.2.ps.gz fsstnd-1.2.txt.gz
+# FHS_ARCHIVE := $(wildcard fhs*.tar.gz)
+FHS_ARCHIVE  := fhs-2.3-source.tar.gz
+FHS_HTML     := fhs-2.3.html
+FHS_FILES    := fhs-2.3.ps.gz fhs-2.3.txt.gz fhs-2.3.pdf.gz
+FHS_NEW_ARCHIVE  := 
+FHS_NEW_HTML     := 
+FHS_NEW_FILES    := 
+
 POLICY_FILES = $(SGML_FILES:=.sgml) $(SGML_FILES:=.txt.gz) \
               virtual-package-names-list.txt \
-              upgrading-checklist.txt libc6-migration.txt version.ent \
+              libc6-migration.txt version.ent \
+               copyright-format/copyright-format-1.0.html \
+               copyright-format/copyright-format-1.0.txt.gz \
                debconf_spec/debconf_specification.html \
-               debconf_spec/debconf_specification.txt.gz
-BYHAND_FILES = $(SGML_FILES:=.txt.gz) $(SGML_FILES:=.html.tar.gz) \
-              debconf_spec/debconf_specification.txt.gz \
-              debconf_spec/debconf_specification.html \
-              libc6-migration.txt virtual-package-names-list.txt \
-              policy.ps.gz policy.pdf.gz upgrading-checklist.txt \
-              $(FHS_BYHAND)
-
-FILES_TO_CLEAN  = debian/files debian/buildinfo  debian/substvars \
+               debconf_spec/debconf_specification.txt.gz \
+               policy.ps.gz policy.pdf.gz README.txt README.html \
+               Process.txt Process.html
+
+FILES_FROM_ORG := Process.html Process.txt README.txt README.html
+
+# policy.{pdf,ps,tpt,txt} are generated files
+FILES_TO_CLEAN  = copyright-format-1.0.xml.tar.gz \
+                  debian/files debian/buildinfo  debian/substvars \
                  debian/postinst debian/prerm \
-                 version.ent upgrading-checklist.txt \
+                 version.ent \
                  $(SGML_FILES:=.txt.gz) $(SGML_FILES:=.html.tar.gz) \
+                  $(SGML_FILES:=-1.html) \
                  policy.pdf.gz policy.ps.gz \
-                 debconf_specification.xml.tar.gz
-
-STAMPS_TO_CLEAN = stamp-policy stamp-build stamp-configure
-DIRS_TO_CLEAN   = debian/tmp fhs $(SGML_FILES:=.html)
-
-
-install_file   = /usr/bin/install -p   -o root -g root  -m  644
-install_program= /usr/bin/install -p   -o root -g root  -m  755
-make_directory = /usr/bin/install -p -d -o root -g root         -m  755
-
-GROFF_VERSION := $(shell dpkg -s groff | sed -n -e 's/Version: //p')
-
-
-all build: stamp-build
-stamp-build:
-       $(checkdir)
-       -test -f stamp-configure || $(MAKE) -f debian/rules configure
-       # Set PERL5LIB to use our version of DebianDoc_SGML::Format::Text
-       set -e; \
-       for file in $(SGML_FILES); do \
-         nsgmls -gues $$file.sgml; \
-         debiandoc2html $$file.sgml; \
-         env PERL5LIB=. debiandoc2text $$file.sgml; \
-         if [ -f $$file.text ]; then mv $$file.text $$file.txt; fi; \
-         gzip -9 $$file.txt; \
-         tar -cf $$file.html.tar $$file.html; \
-         gzip -9 $$file.html.tar; \
-       done
-       tar -zxf $(FHS_ARCHIVE)
-       # Need to use a patched tmac.m macro file if we're using a pre-1.16
-       # groff; version 1.16 is apparently fixed
-       if dpkg --compare-versions $(GROFF_VERSION) lt 1.16; then \
-           cp /usr/share/groff/tmac/tmac.m fhs && \
-           cd fhs && patch -p1 < ../mm1.32-patch; \
-       fi
-       # The extra '.' in the tmac path doesn't matter if
-       GROFF_TMAC_PATH=. cd fhs && $(MAKE) fhs.ps fhs.pdf fhs.txt
-       links -dump fhs-changes-2.1.html | perl -pe 's/[\r\0]//g' > \
-                    fhs/fhs-changes-2.1.txt
-       links -dump upgrading-checklist.html | perl -pe 's/[\r\0]//g' > \
-                    upgrading-checklist.txt
+                 debconf_specification.xml.tar.gz \
+                 policy.pdf policy.ps policy.txt policy. \
+                 body.tmp head.tmp policy.tpt \
+                 $(FILES_FROM_ORG)
+
+STAMPS_TO_CLEAN := stamp-policy stamp-build
+DIRS_TO_CLEAN   := debian/tmp fhs $(SGML_FILES:=.html)
+
+
+install_file    := install -p  -o root -g root  -m  644
+install_program := install -p  -o root -g root  -m  755
+make_directory  := install -p -d       -o root -g root  -m  755
+
+
+all build build-indep: stamp-build
+build-arch:
+stamp-build: version.ent $(sanitycheck)
+       $(MAKE) $(SGML_FILES:=.sgml.validate) \
+               $(SGML_FILES:=.html.tar.gz) \
+                $(SGML_FILES:=-1.html) \
+               $(SGML_FILES:=.txt.gz) \
+               policy.ps.gz policy.pdf.gz
+       $(MAKE) $(FILES_FROM_ORG)
+       $(MAKE) -C copyright-format all
        $(MAKE) -C debconf_spec all
-       gzip -9f debconf_spec/debconf_specification.txt
        touch stamp-build
 
-configure: stamp-configure
-stamp-configure:
-       rm -f version.ent
-       echo "<!entity version \"$(version)\">" >> version.ent
-       echo "<!entity date    \"$(date)\">"        >> version.ent
-       touch stamp-configure
+configure: version.ent
+version.ent: debian/changelog
+       rm -f $@
+       echo "<!entity version \"$(version)\">" >> $@
+       echo "<!entity date    \"$(date)\">"    >> $@
 
-clean:
+clean: $(sanitycheck)
 # Undoes the effect of `make -f debian/rules build'.
-       $(checkdir)
+       $(MAKE) -C copyright-format clean
        $(MAKE) -C debconf_spec clean
        rm -f  $(FILES_TO_CLEAN) $(STAMPS_TO_CLEAN)
        rm -rf $(DIRS_TO_CLEAN)
@@ -140,79 +112,62 @@ clean:
 
 
 binary:                binary-indep binary-arch
-binary-arch:   build
-       $(checkdir)
+binary-arch:   build $(sanitycheck)
 # There are no architecture-dependent files to be uploaded
 # generated by this package.  If there were any they would be
 # made here.
 
 binary-indep:  stamp-policy
-stamp-policy:  build
+stamp-policy:  build $(sanitycheck)
        @test $$(id | sed -e 's/(.*$$//' -e 's/^uid=//') || \
                (echo need root priviledges; exit 1)
-       $(checkdir)
 #      This is unnecessary; commenting out
 #      test -f stamp-build     || $(MAKE) -f        debian/rules build
-       -rm -rf                 $(TMPTOP)
+       rm -rf                  $(TMPTOP)
        $(make_directory)       $(TMPTOP)/DEBIAN
-#      $(make_directory)       $(DOCDIR)/fsstnd
        $(make_directory)       $(DOCDIR)/fhs
        $(make_directory)       $(LIBDIR)
-       # create a substvar to reference from debian/control so that
-       # we don't hardcode the policy compliance of the policy
-       # package.  I guess some might question this but I take it as
-       # a given that the debian-policy pkg must always comply with
-       # itself...
-       echo "debian-policy:Version=$(version)"      > debian/substvars
        $(install_file)     $(POLICY_FILES)          $(DOCDIR)/
-#      $(install_file)     $(FSSTND_FILES)          $(DOCDIR)/fsstnd/
-       $(install_file)     $(FHS_FILES)             $(DOCDIR)/fhs/
        $(install_file)     debian/changelog         $(DOCDIR)/
        # Be more specific with file compression
-       -gzip -9            $(DOCDIR)/*.txt $(DOCDIR)/*.sgml \
-                               $(DOCDIR)/fhs/* $(DOCDIR)/changelog
+       gzip -f9            $(DOCDIR)/*.txt $(DOCDIR)/*.sgml \
+                               $(DOCDIR)/changelog
+# These are allready compressed
+       #$(install_file)    $(FHS_NEW_FILES)         $(DOCDIR)/fhs/
+       $(install_file)     $(FHS_FILES)             $(DOCDIR)/fhs/
        $(install_file)     debian/copyright         $(DOCDIR)/
+       GZIP=-9 cd copyright-format && \
+         tar -zcf ../copyright-format-1.0.xml.tar.gz *
+       $(install_file)     copyright-format-1.0.xml.tar.gz $(DOCDIR)/
+       @set -ex; \
        GZIP=-9 cd debconf_spec && \
          tar -zcf ../debconf_specification.xml.tar.gz *
        $(install_file)     debconf_specification.xml.tar.gz $(DOCDIR)/
-       set -e; \
+       @set -ex; \
        for file in $(DESC_FILES); do \
          $(install_file) $$file.desc $(LIBDIR)/$$file; \
        done
-       set -e; \
+       @set -ex; \
        for file in $(SGML_FILES); do \
          tar -C $(DOCDIR) -zxf $$file.html.tar.gz; \
        done
-       tar -C $(DOCDIR)/fhs -zxf $(FHS_HTML)
-       sed -e 's/#PACKAGE#/$(package)/g' debian/postinst.in > debian/postinst
-       sed -e 's/#PACKAGE#/$(package)/g' debian/prerm.in > debian/prerm
-       $(install_program)  debian/postinst          debian/tmp/DEBIAN/
-       $(install_program)  debian/prerm             debian/tmp/DEBIAN/
-       dpkg-gencontrol     -pdebian-policy -Pdebian/tmp -isp
+       for file in $(SGML_FILES); do \
+         $(install_file) $${file}-1.html $(DOCDIR); \
+       done
+       $(install_file)     $(FHS_HTML)   $(DOCDIR)/fhs
+       @set -ex; \
+       cd debian/tmp; \
+       find . -path "./DEBIAN" -prune -o -type f -printf '%P\0' \
+           | xargs -r0 md5sum > DEBIAN/md5sums
+       dpkg-gencontrol     -p$(package) -Pdebian/tmp -isp
        chown               -R root:root debian/tmp
        chmod               -R go=rX debian/tmp
        dpkg                --build debian/tmp ..
-       # Set PERL5LIB to use our version of DebianDoc_SGML::Format::LaTeX
-       env PERL5LIB=. debiandoc2latexps   policy.sgml
-       gzip -9f            policy.ps
-       env PERL5LIB=. debiandoc2latexpdf  policy.sgml
-       gzip -9f            policy.pdf
-       set -e; \
-       for i in            $(BYHAND_FILES); do                          \
-         $(install_file)   $$i            ..                          ; \
-         dpkg-distaddfile  -fdebian/files `basename $$i`     byhand - ; \
-       done
        touch               stamp-policy
 
 
-define checkdir
-       test -f debian/rules -a -f policy.sgml
-endef
-
-source diff:
-       @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
-
-.PHONY: configure build binary binary-arch binary-indep clean checkroot
+.PHONY: configure build build-arch build-indep binary binary-arch
+.PHONY: binary-indep clean checkroot
 
 #Local variables:
 #mode: makefile