]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - debian/rules
Remove unused debian-policy:Version substitution variable
[debian/debian-policy.git] / debian / rules
index 6a2803303ebf2c4caba99bfa53801dc1b75ca275..50a581ee892ec078920aa034038c368886fcf5db 100755 (executable)
@@ -32,9 +32,9 @@ LIBDIR          := $(TMPTOP)/usr/share/doc-base
 
 sanitycheck := debian/rules policy.sgml
 
-SGML_FILES := policy menu-policy mime-policy perl-policy upgrading-checklist
-DESC_FILES := copyright-format debian-policy debian-menu-policy debian-perl-policy \
-              debian-mime-policy debconf-spec fhs
+SGML_FILES := policy menu-policy perl-policy upgrading-checklist
+DESC_FILES := copyright-format-1.0 debian-policy debian-menu-policy \
+             debian-perl-policy debconf-spec fhs
 
 # While we have two versions of the FHS installed in the source package,
 # we need to modify this to handle it.  This is the easiest way to do it.
@@ -49,8 +49,8 @@ FHS_NEW_FILES    :=
 POLICY_FILES = $(SGML_FILES:=.sgml) $(SGML_FILES:=.txt.gz) \
               virtual-package-names-list.txt \
               libc6-migration.txt version.ent \
-               copyright-format/copyright-format.html \
-               copyright-format/copyright-format.txt.gz \
+               copyright-format/copyright-format-1.0.html \
+               copyright-format/copyright-format-1.0.txt.gz \
                debconf_spec/debconf_specification.html \
                debconf_spec/debconf_specification.txt.gz \
                policy.ps.gz policy.pdf.gz README.txt README.html \
@@ -59,7 +59,7 @@ POLICY_FILES = $(SGML_FILES:=.sgml) $(SGML_FILES:=.txt.gz) \
 FILES_FROM_ORG := Process.html Process.txt README.txt README.html
 
 # policy.{pdf,ps,tpt,txt} are generated files
-FILES_TO_CLEAN  = copyright-format.xml.tar.gz \
+FILES_TO_CLEAN  = copyright-format-1.0.xml.tar.gz \
                   debian/files debian/buildinfo  debian/substvars \
                  debian/postinst debian/prerm \
                  version.ent \
@@ -127,12 +127,6 @@ stamp-policy:  build $(sanitycheck)
        $(make_directory)       $(TMPTOP)/DEBIAN
        $(make_directory)       $(DOCDIR)/fhs
        $(make_directory)       $(LIBDIR)
-       # create a substvar to reference from debian/control so that
-       # we don't hardcode the policy compliance of the policy
-       # package.  I guess some might question this but I take it as
-       # a given that the debian-policy pkg must always comply with
-       # itself...
-       echo "debian-policy:Version=$(version)"      > debian/substvars
        $(install_file)     $(POLICY_FILES)          $(DOCDIR)/
        $(install_file)     debian/changelog         $(DOCDIR)/
        # Be more specific with file compression
@@ -143,8 +137,8 @@ stamp-policy:  build $(sanitycheck)
        $(install_file)     $(FHS_FILES)             $(DOCDIR)/fhs/
        $(install_file)     debian/copyright         $(DOCDIR)/
        GZIP=-9 cd copyright-format && \
-         tar -zcf ../copyright-format.xml.tar.gz *
-       $(install_file)     copyright-format.xml.tar.gz $(DOCDIR)/
+         tar -zcf ../copyright-format-1.0.xml.tar.gz *
+       $(install_file)     copyright-format-1.0.xml.tar.gz $(DOCDIR)/
        @set -ex; \
        GZIP=-9 cd debconf_spec && \
          tar -zcf ../debconf_specification.xml.tar.gz *