]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - debian/rules
Remove unused debian-policy:Version substitution variable
[debian/debian-policy.git] / debian / rules
index 4fa4518f6025ca9d00892df9815d627cd4435bfc..50a581ee892ec078920aa034038c368886fcf5db 100755 (executable)
@@ -21,6 +21,9 @@ package := $(shell grep Source debian/control | sed 's/^Source: //')
 date   := $(shell date +"%Y-%m-%d")
 version := $(shell awk -F '[()]' '/^$(package)/{ print $$2; exit }' debian/changelog)
 
+# Currently, emacs23 is required (xemacs is not sufficient).
+EMACS   := emacs23
+
 # Location of the source dir
 SRCTOP   := $(CURDIR)
 TMPTOP   := $(SRCTOP)/debian/tmp
@@ -29,9 +32,9 @@ LIBDIR          := $(TMPTOP)/usr/share/doc-base
 
 sanitycheck := debian/rules policy.sgml
 
-SGML_FILES := policy menu-policy mime-policy perl-policy
-DESC_FILES := debian-policy debian-menu-policy debian-perl-policy \
-              debian-mime-policy debconf-spec fhs
+SGML_FILES := policy menu-policy perl-policy upgrading-checklist
+DESC_FILES := copyright-format-1.0 debian-policy debian-menu-policy \
+             debian-perl-policy debconf-spec fhs
 
 # While we have two versions of the FHS installed in the source package,
 # we need to modify this to handle it.  This is the easiest way to do it.
@@ -45,20 +48,28 @@ FHS_NEW_FILES    :=
 
 POLICY_FILES = $(SGML_FILES:=.sgml) $(SGML_FILES:=.txt.gz) \
               virtual-package-names-list.txt \
-              upgrading-checklist.txt libc6-migration.txt version.ent \
+              libc6-migration.txt version.ent \
+               copyright-format/copyright-format-1.0.html \
+               copyright-format/copyright-format-1.0.txt.gz \
                debconf_spec/debconf_specification.html \
                debconf_spec/debconf_specification.txt.gz \
-               policy.ps.gz policy.pdf.gz
+               policy.ps.gz policy.pdf.gz README.txt README.html \
+               Process.txt Process.html
+
+FILES_FROM_ORG := Process.html Process.txt README.txt README.html
 
 # policy.{pdf,ps,tpt,txt} are generated files
-FILES_TO_CLEAN  = debian/files debian/buildinfo  debian/substvars \
+FILES_TO_CLEAN  = copyright-format-1.0.xml.tar.gz \
+                  debian/files debian/buildinfo  debian/substvars \
                  debian/postinst debian/prerm \
-                 version.ent upgrading-checklist.txt \
+                 version.ent \
                  $(SGML_FILES:=.txt.gz) $(SGML_FILES:=.html.tar.gz) \
+                  $(SGML_FILES:=-1.html) \
                  policy.pdf.gz policy.ps.gz \
                  debconf_specification.xml.tar.gz \
                  policy.pdf policy.ps policy.txt policy. \
-                 body.tmp head.tmp policy.tpt
+                 body.tmp head.tmp policy.tpt \
+                 $(FILES_FROM_ORG)
 
 STAMPS_TO_CLEAN := stamp-policy stamp-build
 DIRS_TO_CLEAN   := debian/tmp fhs $(SGML_FILES:=.html)
@@ -69,14 +80,16 @@ install_program := install -p       -o root -g root  -m  755
 make_directory  := install -p -d       -o root -g root  -m  755
 
 
-all build: stamp-build
+all build build-indep: stamp-build
+build-arch:
 stamp-build: version.ent $(sanitycheck)
        $(MAKE) $(SGML_FILES:=.sgml.validate) \
                $(SGML_FILES:=.html.tar.gz) \
+                $(SGML_FILES:=-1.html) \
                $(SGML_FILES:=.txt.gz) \
                policy.ps.gz policy.pdf.gz
-       links -dump upgrading-checklist.html | perl -pe 's/[\r\0]//g' > \
-                    upgrading-checklist.txt
+       $(MAKE) $(FILES_FROM_ORG)
+       $(MAKE) -C copyright-format all
        $(MAKE) -C debconf_spec all
        touch stamp-build
 
@@ -88,6 +101,7 @@ version.ent: debian/changelog
 
 clean: $(sanitycheck)
 # Undoes the effect of `make -f debian/rules build'.
+       $(MAKE) -C copyright-format clean
        $(MAKE) -C debconf_spec clean
        rm -f  $(FILES_TO_CLEAN) $(STAMPS_TO_CLEAN)
        rm -rf $(DIRS_TO_CLEAN)
@@ -113,12 +127,6 @@ stamp-policy:  build $(sanitycheck)
        $(make_directory)       $(TMPTOP)/DEBIAN
        $(make_directory)       $(DOCDIR)/fhs
        $(make_directory)       $(LIBDIR)
-       # create a substvar to reference from debian/control so that
-       # we don't hardcode the policy compliance of the policy
-       # package.  I guess some might question this but I take it as
-       # a given that the debian-policy pkg must always comply with
-       # itself...
-       echo "debian-policy:Version=$(version)"      > debian/substvars
        $(install_file)     $(POLICY_FILES)          $(DOCDIR)/
        $(install_file)     debian/changelog         $(DOCDIR)/
        # Be more specific with file compression
@@ -128,6 +136,10 @@ stamp-policy:  build $(sanitycheck)
        #$(install_file)    $(FHS_NEW_FILES)         $(DOCDIR)/fhs/
        $(install_file)     $(FHS_FILES)             $(DOCDIR)/fhs/
        $(install_file)     debian/copyright         $(DOCDIR)/
+       GZIP=-9 cd copyright-format && \
+         tar -zcf ../copyright-format-1.0.xml.tar.gz *
+       $(install_file)     copyright-format-1.0.xml.tar.gz $(DOCDIR)/
+       @set -ex; \
        GZIP=-9 cd debconf_spec && \
          tar -zcf ../debconf_specification.xml.tar.gz *
        $(install_file)     debconf_specification.xml.tar.gz $(DOCDIR)/
@@ -139,6 +151,9 @@ stamp-policy:  build $(sanitycheck)
        for file in $(SGML_FILES); do \
          tar -C $(DOCDIR) -zxf $$file.html.tar.gz; \
        done
+       for file in $(SGML_FILES); do \
+         $(install_file) $${file}-1.html $(DOCDIR); \
+       done
        $(install_file)     $(FHS_HTML)   $(DOCDIR)/fhs
        @set -ex; \
        cd debian/tmp; \
@@ -151,7 +166,8 @@ stamp-policy:  build $(sanitycheck)
        touch               stamp-policy
 
 
-.PHONY: configure build binary binary-arch binary-indep clean checkroot
+.PHONY: configure build build-arch build-indep binary binary-arch
+.PHONY: binary-indep clean checkroot
 
 #Local variables:
 #mode: makefile