]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - debian/rules
Improve Description and Changes specification for *.changes
[debian/debian-policy.git] / debian / rules
index b17a4429a0d5efabaa1cbcc09c08e3396f1b3259..4fa4518f6025ca9d00892df9815d627cd4435bfc 100755 (executable)
@@ -1,18 +1,4 @@
 #!/usr/bin/make -f
-############################ -*- Mode: Makefile -*- ###########################
-## rules ---
-## Author          : Manoj Srivastava ( srivasta@tiamat.datasync.com )
-## Created On      : Thu Oct 29 15:35:55 1998
-## Created On Node  : tiamat.datasync.com
-## Last Modified By : Manoj Srivastava
-## Last Modified On : Tue Oct 26 15:20:25 2004
-## Last Machine Used: glaurung.internal.golden-gryphon.com
-## Update Count            : 62
-## Status          : Unknown, Use with caution!
-## HISTORY         :
-## Description     :
-## $Id$
-###############################################################################
 
 ifdef ARCH
   ha:=-a$(ARCH)
@@ -28,7 +14,7 @@ export DEB_HOST_GNU_CPU    ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_CPU
 export DEB_HOST_GNU_SYSTEM ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_SYSTEM)
 export DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_TYPE)
 
-arch   := $(shell dpkg --print-installation-architecture)
+arch   := $(shell dpkg --print-architecture)
 
 # Basic information
 package := $(shell grep Source debian/control | sed 's/^Source: //')
@@ -43,9 +29,9 @@ LIBDIR          := $(TMPTOP)/usr/share/doc-base
 
 sanitycheck := debian/rules policy.sgml
 
-SGML_FILES := policy menu-policy mime-policy policy-process perl-policy
+SGML_FILES := policy menu-policy mime-policy perl-policy
 DESC_FILES := debian-policy debian-menu-policy debian-perl-policy \
-              debian-mime-policy debian-policy-process debconf-spec fhs
+              debian-mime-policy debconf-spec fhs
 
 # While we have two versions of the FHS installed in the source package,
 # we need to modify this to handle it.  This is the easiest way to do it.
@@ -156,11 +142,8 @@ stamp-policy:  build $(sanitycheck)
        $(install_file)     $(FHS_HTML)   $(DOCDIR)/fhs
        @set -ex; \
        cd debian/tmp; \
-       find . -type f -printf '%P\0' | xargs -r0 md5sum > DEBIAN/md5sums
-       sed -e 's/#PACKAGE#/$(package)/g' debian/postinst.in > debian/postinst
-       sed -e 's/#PACKAGE#/$(package)/g' debian/prerm.in > debian/prerm
-       $(install_program)  debian/postinst          debian/tmp/DEBIAN/
-       $(install_program)  debian/prerm             debian/tmp/DEBIAN/
+       find . -path "./DEBIAN" -prune -o -type f -printf '%P\0' \
+           | xargs -r0 md5sum > DEBIAN/md5sums
        dpkg-gencontrol     -p$(package) -Pdebian/tmp -isp
        chown               -R root:root debian/tmp
        chmod               -R go=rX debian/tmp