]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - debian/rules
* Fix the debconf spec to (postinst -> postrm) closes
[debian/debian-policy.git] / debian / rules
index 028c067823bf86ef62ab14d6bb853663b34d3418..450b4a3bffc54286cd103d13cfe2142b169a5704 100755 (executable)
@@ -5,9 +5,9 @@
 ## Created On      : Thu Oct 29 15:35:55 1998
 ## Created On Node  : tiamat.datasync.com
 ## Last Modified By : Manoj Srivastava
-## Last Modified On : Wed Sep  6 09:37:43 2000
+## Last Modified On : Sat Oct 26 12:29:03 2002
 ## Last Machine Used: glaurung.green-gryphon.com
-## Update Count            : 56
+## Update Count            : 58
 ## Status          : Unknown, Use with caution!
 ## HISTORY         :
 ## Description     :
@@ -45,7 +45,8 @@ LIBDIR          := $(TMPTOP)/usr/share/doc-base
 
 SGML_FILES      = policy menu-policy mime-policy policy-process perl-policy
 DESC_FILES      = debian-policy debian-menu-policy debian-perl-policy \
-                  debian-mime-policy debian-policy-process debconf-spec
+                  debian-mime-policy debian-policy-process debconf-spec \
+                 fhs
 
 # While we have two versions of the FHS installed in the source package,
 # we need to modify this to handle it.  This is the easiest way to do it.
@@ -66,7 +67,7 @@ BYHAND_FILES = $(SGML_FILES:=.txt.gz) $(SGML_FILES:=.html.tar.gz) \
               debconf_spec/debconf_specification.txt.gz \
               debconf_spec/debconf_specification.html \
               libc6-migration.txt virtual-package-names-list.txt \
-              policy.ps.gz policy.pdf.gz \
+              policy.ps.gz policy.pdf.gz upgrading-checklist.txt \
               $(FHS_BYHAND)
 
 FILES_TO_CLEAN  = debian/files debian/buildinfo  debian/substvars \
@@ -108,8 +109,8 @@ stamp-build:
            cp /usr/share/groff/tmac/tmac.m fhs && \
            cd fhs && patch -p1 < ../mm1.32-patch; \
        fi
-       # The extra '.' in the tmac path doesn't matter if
-       GROFF_TMAC_PATH=. cd fhs && $(MAKE) fhs.ps fhs.pdf fhs.txt
+       # The extra '.' in the tmac path won't harm if unnecessary
+       GROFF_TMAC_PATH=. GROFF_NO_SGR=1 $(MAKE) -C fhs fhs.ps fhs.pdf fhs.txt
        links -dump fhs-changes-2.1.html | perl -pe 's/[\r\0]//g' > \
                     fhs/fhs-changes-2.1.txt
        links -dump upgrading-checklist.html | perl -pe 's/[\r\0]//g' > \
@@ -170,10 +171,11 @@ stamp-policy:  build
        -gzip -9            $(DOCDIR)/*.txt $(DOCDIR)/*.sgml \
                                $(DOCDIR)/fhs/* $(DOCDIR)/changelog
        $(install_file)     debian/copyright         $(DOCDIR)/
-       GZIP=-9 tar -C debconf_spec -zcf debconf_specification.xml.tar.gz *
+       GZIP=-9 cd debconf_spec && \
+         tar -zcf ../debconf_specification.xml.tar.gz *
        $(install_file)     debconf_specification.xml.tar.gz $(DOCDIR)/
        set -e; \
-        for file in $(DESC_FILES); do \
+       for file in $(DESC_FILES); do \
          $(install_file) $$file.desc $(LIBDIR)/$$file; \
        done
        set -e; \