]> git.donarmstrong.com Git - debhelper.git/blobdiff - debian/rules
r407: * suidmanager is obsolete now, and so is dh_suidmanager. Instead,
[debhelper.git] / debian / rules
index 225db74c2b144bfac74d08ad9deee2483ec7857c..23de85d45eed7eed4951bc059abc93542bf5a3ab 100755 (executable)
@@ -20,7 +20,8 @@ export DH_COMPAT=3
 # Figure out the current debhelper version.
 VERSION=$(shell expr "`dpkg-parsechangelog 2>/dev/null |grep Version:`" : '.*Version: \(.*\)')
 
-export DH_VERBOSE=1
+# Debug
+#export DH_VERBOSE=1
 
 build: test
 # Nothing to do.       
@@ -97,7 +98,6 @@ binary-indep: build
        ./dh_link
        ./dh_compress
        ./dh_fixperms
-       ./dh_suidregister
        ./dh_installdeb
        ./dh_gencontrol
        ./dh_md5sums
@@ -107,7 +107,7 @@ binary-indep: build
 # author.
 installhook:
        cp debian/changelog /home/pub/programs/debhelper/CHANGES
-       echo $(VERSION) > /home/pub/programs/debhelper/LATEST-VERSION-IS
+       echo -n $(VERSION) > /home/pub/programs/debhelper/LATEST-VERSION-IS
 
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary dist