]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - debian/rules
Policy: Obsolete the DM-Upload-Allowed field.
[debian/debian-policy.git] / debian / rules
index d242b66020baaee7f0d0acb3934ce63ffab7b099..1f69ddb37eec3ab8e594352ff0b158d617f62243 100755 (executable)
@@ -56,8 +56,9 @@ FILES_TO_CLEAN        := $(SGML_FILES:=.txt) $(SGML_FILES:=.txt.gz)           \
                   $(ORG_FILES:=.html) $(ORG_FILES:=.txt)               \
                   policy.pdf.gz policy.ps.gz                           \
                   policy.pdf policy.ps policy.tpt policy.txt           \
-                  version.ent                                          \
-                  copyright-format-1.0.xml.tar.gz                      \
+                  copyright-format/version.xml                         \
+                  debconf_spec/include/version.xml version.ent         \
+                  copyright-format.xml.tar.gz                          \
                   debconf_specification.xml.tar.gz                     \
                   debian/files
 
@@ -68,7 +69,8 @@ mkdir   := install -d -o root -g root -m 755
 
 all build build-indep: stamp-build
 build-arch:
-stamp-build: version.ent
+stamp-build: version.ent copyright-format/version.xml \
+            debconf_spec/include/version.xml
        $(MAKE) $(SGML_FILES:=.sgml.validate) \
                $(SGML_FILES:=.html.tar.gz) \
                 $(SGML_FILES:=-1.html) \
@@ -79,16 +81,30 @@ stamp-build: version.ent
        $(MAKE) -C copyright-format all
        $(MAKE) -C debconf_spec all
        GZIP=-9 cd copyright-format && \
-               tar -zcf ../copyright-format-1.0.xml.tar.gz *
+               tar -zcf ../copyright-format.xml.tar.gz *
        GZIP=-9 cd debconf_spec && \
                tar -zcf ../debconf_specification.xml.tar.gz *
        touch stamp-build
 
-configure: version.ent
+# Create the version files for inclusion in the various documents.  We want
+# to put the Policy version and date in each document, even if they
+# separately have their own versions.
+configure: version.ent copyright-format/version.xml \
+          debconf_spec/include/version.xml
 version.ent: debian/changelog
        rm -f $@
        echo "<!entity version \"$(version)\">" >> $@
        echo "<!entity date    \"$(date)\">"    >> $@
+copyright-format/version.xml: debian/changelog
+       rm -f $@
+       echo '<?xml version="1.0" standalone="no"?>' >  $@
+       echo '<!ENTITY version "$(version)">'        >> $@
+       echo '<!ENTITY date    "$(date)">'           >> $@
+debconf_spec/include/version.xml: debian/changelog
+       rm -f $@
+       echo '<?xml version="1.0" standalone="no"?>' >  $@
+       echo '<!ENTITY version "$(version)">'        >> $@
+       echo '<!ENTITY date    "$(date)">'           >> $@
 
 clean:
        rm -f $(STAMPS_TO_CLEAN)
@@ -122,7 +138,7 @@ stamp-binary: stamp-build
 #
 # Install DocBook XML source.
 #
-       $(install)      copyright-format-1.0.xml.tar.gz         $(DOCDIR)/
+       $(install)      copyright-format.xml.tar.gz             $(DOCDIR)/
        $(install)      debconf_specification.xml.tar.gz        $(DOCDIR)/
 #
 # Install generated HTML directories.
@@ -131,6 +147,13 @@ stamp-binary: stamp-build
                tar -C $(DOCDIR) -zxf $$file.html.tar.gz;       \
        done
 #
+# Make upgrading-checklist-1.html a symlink to the copy in the policy.html
+# directory.  This is temporary until it becomes a proper appendix.
+#
+       rm -f $(DOCDIR)/upgrading-checklist-1.html
+       ln -s policy.html/upgrading-checklist.html \
+               $(DOCDIR)/upgrading-checklist-1.html
+#
 # Install doc-base files.
 #
        @set -ex; for file in $(DESC_FILES); do                 \