]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - debian/rules
Sync with upstream
[debian/debian-policy.git] / debian / rules
index ec65489838ad41c9d2cd90b17d3b2cc676fad1ca..1e31ad42664f77226b76326e76606098a9eabab2 100755 (executable)
 ## Created On      : Thu Oct 29 15:35:55 1998
 ## Created On Node  : tiamat.datasync.com
 ## Last Modified By : Manoj Srivastava
-## Last Modified On : Wed Jun 30 23:05:51 1999
-## Last Machine Used: glaurung.green-gryphon.com
-## Update Count            : 51
+## Last Modified On : Tue Oct 26 15:20:25 2004
+## Last Machine Used: glaurung.internal.golden-gryphon.com
+## Update Count            : 62
 ## Status          : Unknown, Use with caution!
 ## HISTORY         :
 ## Description     :
 ## $Id$
 ###############################################################################
-# The name of the package (for example, `emacs').
-package := $(shell grep Source debian/control | sed 's/^Source: //')
+
+ifdef ARCH
+  ha:=-a$(ARCH)
+endif
+
+# set the dpkg-architecture vars; but we don't use them, so we'll comment out
+export DEB_BUILD_ARCH      ?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_ARCH)
+export DEB_BUILD_GNU_CPU   ?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_CPU)
+export DEB_BUILD_GNU_SYSTEM?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_SYSTEM)
+export DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_TYPE)
+export DEB_HOST_ARCH       ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_ARCH)
+export DEB_HOST_GNU_CPU    ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_CPU)
+export DEB_HOST_GNU_SYSTEM ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_SYSTEM)
+export DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_TYPE)
+
 arch   := $(shell dpkg --print-installation-architecture)
-date   := $(shell date +"%Y-%m-%d")
-version := $(shell LC_ALL=C dpkg-parsechangelog | \
-                  grep ^Version: | sed 's/^Version: *//')
-ppackage:= packaging-manual
 
-FILES_TO_CLEAN  = debian/files debian/buildinfo  debian/substvars \
-                 version.ent  policy.lout policy.lout.ld lout.li \
-                 upgrading-checklist.text policy.text.gz \
-                 packaging.lout packaging.text.gz packaging.ps \
-                  packaging.pdf.gz menu-policy.text.gz \
-                  proposal.text.gz menu-policy.pdf.gz proposal.pdf.gz
-STAMPS_TO_CLEAN = stamp-policy stamp-packaging stamp-build stamp-configure
-DIRS_TO_CLEAN   = debian/tmp policy.html fhs debian/tmp-packaging \
-                  packaging.html menu-policy.html proposal.html
-SGML_FILES      = policy packaging menu-policy proposal
+# Basic information
+package := $(shell grep Source debian/control | sed 's/^Source: //')
+date   := $(shell date +"%Y-%m-%d")
+version := $(shell awk -F '[()]' '/^$(package)/{ print $$2; exit }' debian/changelog)
 
 # Location of the source dir
-SRCTOP   := $(shell if [ "$$PWD" != "" ]; then echo $$PWD; else pwd; fi;)
+SRCTOP   := $(CURDIR)
 TMPTOP   := $(SRCTOP)/debian/tmp
-DOCDIR   := $(TMPTOP)/usr/doc/$(package)
+DOCDIR   := $(TMPTOP)/usr/share/doc/$(package)
 LIBDIR   := $(TMPTOP)/usr/share/doc-base
 
-PTMPTOP          := $(SRCTOP)/debian/tmp-packaging
-PDOCDIR          := $(PTMPTOP)/usr/doc/$(ppackage)
-PLIBDIR          := $(PTMPTOP)/usr/share/doc-base
+sanitycheck := debian/rules policy.sgml
+
+SGML_FILES := policy menu-policy mime-policy policy-process perl-policy
+DESC_FILES := debian-policy debian-menu-policy debian-perl-policy \
+              debian-mime-policy debian-policy-process debconf-spec fhs
+
+# While we have two versions of the FHS installed in the source package,
+# we need to modify this to handle it.  This is the easiest way to do it.
+# FHS_ARCHIVE := $(wildcard fhs*.tar.gz)
+FHS_ARCHIVE  := fhs-2.3-source.tar.gz
+FHS_HTML     := fhs-2.3.html
+FHS_FILES    := fhs-2.3.ps.gz fhs-2.3.txt.gz fhs-2.3.pdf.gz
+FHS_NEW_ARCHIVE  := 
+FHS_NEW_HTML     := 
+FHS_NEW_FILES    := 
+
+POLICY_FILES = $(SGML_FILES:=.sgml) $(SGML_FILES:=.txt.gz) \
+              virtual-package-names-list.txt \
+              upgrading-checklist.txt libc6-migration.txt version.ent \
+               debconf_spec/debconf_specification.html \
+               debconf_spec/debconf_specification.txt.gz \
+               policy.ps.gz policy.pdf.gz
+
+# policy.{pdf,ps,tpt,txt} are generated files
+FILES_TO_CLEAN  = debian/files debian/buildinfo  debian/substvars \
+                 debian/postinst debian/prerm \
+                 version.ent upgrading-checklist.txt \
+                 $(SGML_FILES:=.txt.gz) $(SGML_FILES:=.html.tar.gz) \
+                 policy.pdf.gz policy.ps.gz \
+                 debconf_specification.xml.tar.gz \
+                  policy.pdf policy.ps policy.txt policy.
 
-FHS_ARCHIVE  =$(shell ls -1 fhs*.tar.gz)
-FHS_FILES    =fhs/fhs.dvi fhs/fhs.ps fhs/fhs.txt
-FSSTND_FILES =FSSTND-FAQ fsstnd-1.2.dvi.gz fsstnd-1.2.ps.gz fsstnd-1.2.txt.gz
-POLICY_FILES =policy.text.gz policy.sgml virtual-package-names-list.text \
-             upgrading-checklist.text libc6-migration.text \
-             version.ent proposal.sgml proposal.text.gz \
-              menu-policy.sgml menu-policy.text.gz
-BYHAND_FILES =policy.text.gz libc6-migration.text \
-              virtual-package-names-list.text menu-policy.text.gz
-PBYHAND_FILES=packaging.text.gz
+STAMPS_TO_CLEAN := stamp-policy stamp-build
+DIRS_TO_CLEAN   := debian/tmp fhs $(SGML_FILES:=.html)
 
-install_file   = /usr/bin/install -p   -o root -g root  -m  644
-install_program= /usr/bin/install -p   -o root -g root  -m  755
-make_directory = /usr/bin/install -p -d -o root -g root         -m  755
+
+install_file    := install -p  -o root -g root  -m  644
+install_program := install -p  -o root -g root  -m  755
+make_directory  := install -p -d       -o root -g root  -m  755
 
 
 all build: stamp-build
-stamp-build:
-       $(checkdir)
-       -test -f stamp-configure || $(MAKE) -f debian/rules configure
-       for file in $(SGML_FILES); do \
-         nsgmls -gues $$file.sgml; \
-         debiandoc2html $$file.sgml; \
-         debiandoc2text $$file.sgml; \
-         if [ -f $$file.txt ]; then mv $$file.txt $$file.text; fi; \
-         gzip -9f $$file.text; \
-       done
-       tar zfx $(FHS_ARCHIVE)
-       lynx -dump upgrading-checklist.html > upgrading-checklist.text
+stamp-build: version.ent $(sanitycheck)
+       $(MAKE) $(SGML_FILES:=.sgml.validate) \
+               $(SGML_FILES:=.html.tar.gz) \
+               $(SGML_FILES:=.txt.gz) \
+               policy.ps.gz policy.pdf.gz
+       links -dump upgrading-checklist.html | perl -pe 's/[\r\0]//g' > \
+                    upgrading-checklist.txt
+       $(MAKE) -C debconf_spec all
        touch stamp-build
 
-configure: stamp-configure
-stamp-configure:
-       rm -f version.ent
-       echo "<!entity version \"$(version)\">" >> version.ent
-       echo "<!entity date    \"$(date)\">"        >> version.ent
-       touch stamp-configure
+configure: version.ent
+version.ent: debian/changelog
+       rm -f $@
+       echo "<!entity version \"$(version)\">" >> $@
+       echo "<!entity date    \"$(date)\">"    >> $@
 
-clean:
+clean: $(sanitycheck)
 # Undoes the effect of `make -f debian/rules build'.
-       $(checkdir)
+       $(MAKE) -C debconf_spec clean
        rm -f  $(FILES_TO_CLEAN) $(STAMPS_TO_CLEAN)
        rm -rf $(DIRS_TO_CLEAN)
        rm -f core `find . \( -name '*.orig' -o -name '*.rej' -o \
@@ -92,20 +111,19 @@ clean:
 
 
 binary:                binary-indep binary-arch
-binary-arch:   build
-       $(checkdir)
+binary-arch:   build $(sanitycheck)
 # There are no architecture-dependent files to be uploaded
 # generated by this package.  If there were any they would be
 # made here.
 
-binary-indep:  stamp-policy stamp-packaging
-stamp-policy:  build
-       @test root = "`whoami`" || (echo need root priviledges; exit 1)
-       $(checkdir)
-       test -f stamp-build     || $(MAKE) -f        debian/rules build
-       -rm -rf                 $(TMPTOP)
+binary-indep:  stamp-policy
+stamp-policy:  build $(sanitycheck)
+       @test $$(id | sed -e 's/(.*$$//' -e 's/^uid=//') || \
+               (echo need root priviledges; exit 1)
+#      This is unnecessary; commenting out
+#      test -f stamp-build     || $(MAKE) -f        debian/rules build
+       rm -rf                  $(TMPTOP)
        $(make_directory)       $(TMPTOP)/DEBIAN
-       $(make_directory)       $(DOCDIR)/fsstnd
        $(make_directory)       $(DOCDIR)/fhs
        $(make_directory)       $(LIBDIR)
        # create a substvar to reference from debian/control so that
@@ -114,87 +132,42 @@ stamp-policy:  build
        # a given that the debian-policy pkg must always comply with
        # itself...
        echo "debian-policy:Version=$(version)"      > debian/substvars
-       echo "packaging-manual:Version=$(version)"   >> debian/substvars
        $(install_file)     $(POLICY_FILES)          $(DOCDIR)/
-       $(install_file)     $(FSSTND_FILES)          $(DOCDIR)/fsstnd/
-       $(install_file)     $(FHS_FILES)             $(DOCDIR)/fhs/
        $(install_file)     debian/changelog         $(DOCDIR)/
-       -gzip -fqr9         $(DOCDIR)
+       # Be more specific with file compression
+       gzip -f9            $(DOCDIR)/*.txt $(DOCDIR)/*.sgml \
+                               $(DOCDIR)/changelog
+# These are allready compressed
+       #$(install_file)    $(FHS_NEW_FILES)         $(DOCDIR)/fhs/
+       $(install_file)     $(FHS_FILES)             $(DOCDIR)/fhs/
        $(install_file)     debian/copyright         $(DOCDIR)/
-       $(install_file)     debian-policy.desc       $(LIBDIR)/debian-policy
-       (tar cf -           policy.html) |           (cd $(DOCDIR);   tar xf -)
-       (tar cf -           menu-policy.html) |      (cd $(DOCDIR);   tar xf -)
-       (tar cf -           proposal.html) |         (cd $(DOCDIR);   tar xf -)
-       $(install_program)  debian/{postinst,prerm}  debian/tmp/DEBIAN/
-       dpkg-gencontrol     -pdebian-policy -Pdebian/tmp -isp
-       chown               -R root.root debian/tmp
-       chmod               -R go=rX debian/tmp
-       dpkg                --build debian/tmp ..
-       debiandoc2latexps    policy.sgml
-       mv policy.ps         ../
-       gzip -9qvf            ../policy.ps
-       debiandoc2latexpdf  policy.sgml
-       mv policy.pdf        ../
-       gzip -9qfv           ../policy.pdf
-       GZIP=-9v tar zcf    ../policy.html.tar.gz    policy.html
-       dpkg-distaddfile    -fdebian/files           policy.ps.gz       byhand -
-       dpkg-distaddfile    -fdebian/files           policy.pdf.gz      byhand -
-       dpkg-distaddfile    -fdebian/files           policy.html.tar.gz byhand -
-       for i in            $(BYHAND_FILES); do \
-         $(install_file)   $$i            ..                ; \
-         dpkg-distaddfile  -fdebian/files $$i       byhand - ; \
+       GZIP=-9 cd debconf_spec && \
+         tar -zcf ../debconf_specification.xml.tar.gz *
+       $(install_file)     debconf_specification.xml.tar.gz $(DOCDIR)/
+       @set -ex; \
+       for file in $(DESC_FILES); do \
+         $(install_file) $$file.desc $(LIBDIR)/$$file; \
        done
-       touch              stamp-policy
-
-stamp-packaging:  build
-       @test root = "`whoami`" || (echo need root priviledges; exit 1)
-       $(checkdir)
-       test -f stamp-build     || $(MAKE) -f        debian/rules build
-       -rm -rf                 $(PTMPTOP)
-       $(make_directory)       $(PTMPTOP)/DEBIAN
-       $(make_directory)       $(PDOCDIR)
-       $(make_directory)       $(PLIBDIR)
-       echo "debian-policy:Version=$(version)"      > debian/substvars
-       echo "packaging-manual:Version=$(version)"   >> debian/substvars
-
-       $(install_file)    packaging.sgml            $(PDOCDIR)/
-       $(install_file)    version.ent               $(PDOCDIR)/
-       $(install_file)    debian/changelog          $(PDOCDIR)/
-       -gzip -fqr9        $(PDOCDIR)
-       $(install_file)    packaging.text.gz         $(PDOCDIR)/
-       $(install_file)    debian/copyright          $(PDOCDIR)/
-       $(install_file)    packaging-manual.desc     $(PLIBDIR)/packaging-manual
-       (tar cf -          packaging.html) |         (cd $(PDOCDIR);   tar xf -)
-       $(install_program) debian/{postinst,prerm}   debian/tmp-packaging/DEBIAN/
-       dpkg-gencontrol    -ppackaging-manual -Pdebian/tmp-packaging -isp
-       chown              -R root.root debian/tmp-packaging
-       chmod              -R go=rX debian/tmp-packaging
-       dpkg               --build debian/tmp-packaging ..
-       debiandoc2latexps  packaging.sgml
-       debiandoc2latexpdf packaging.sgml
-       mv packaging.ps    ../
-       mv packaging.pdf   ../
-       gzip -9vf          ../packaging.ps
-       gzip -9vf          ../packaging.pdf
-       GZIP=-9v tar zcf   ../packaging.html.tar.gz    packaging.html
-       dpkg-distaddfile   -fdebian/files        packaging.ps.gz       byhand -
-       dpkg-distaddfile   -fdebian/files        packaging.pdf.gz      byhand -
-       dpkg-distaddfile   -fdebian/files        packaging.html.tar.gz byhand -
-       for i in            $(PBYHAND_FILES); do \
-         $(install_file)   $$i            ..                ; \
-         dpkg-distaddfile  -fdebian/files $$i       byhand - ; \
+       @set -ex; \
+       for file in $(SGML_FILES); do \
+         tar -C $(DOCDIR) -zxf $$file.html.tar.gz; \
        done
-       touch              stamp-
-
-
-define checkdir
-       test -f debian/rules -a -f policy.sgml
-endef
+       $(install_file)     $(FHS_HTML)   $(DOCDIR)/fhs
+       @set -ex; \
+       cd debian/tmp; \
+       find . -type f -printf '%P\0' | xargs -r0 md5sum > DEBIAN/md5sums
+       sed -e 's/#PACKAGE#/$(package)/g' debian/postinst.in > debian/postinst
+       sed -e 's/#PACKAGE#/$(package)/g' debian/prerm.in > debian/prerm
+       $(install_program)  debian/postinst          debian/tmp/DEBIAN/
+       $(install_program)  debian/prerm             debian/tmp/DEBIAN/
+       dpkg-gencontrol     -p$(package) -Pdebian/tmp -isp
+       chown               -R root:root debian/tmp
+       chmod               -R go=rX debian/tmp
+       dpkg                --build debian/tmp ..
+       touch               stamp-policy
 
-source diff:
-       @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
 
-.PHONY: binary binary-arch binary-indep clean checkroot
+.PHONY: configure build binary binary-arch binary-indep clean checkroot
 
 #Local variables:
 #mode: makefile