]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - debian/rules
Sync with upstream
[debian/debian-policy.git] / debian / rules
index cfbfb6f5c0a047a9fe98d980b0c6b1a0324251a4..1e31ad42664f77226b76326e76606098a9eabab2 100755 (executable)
@@ -5,30 +5,30 @@
 ## Created On      : Thu Oct 29 15:35:55 1998
 ## Created On Node  : tiamat.datasync.com
 ## Last Modified By : Manoj Srivastava
-## Last Modified On : Sat Oct 26 12:29:03 2002
-## Last Machine Used: glaurung.green-gryphon.com
-## Update Count            : 58
+## Last Modified On : Tue Oct 26 15:20:25 2004
+## Last Machine Used: glaurung.internal.golden-gryphon.com
+## Update Count            : 62
 ## Status          : Unknown, Use with caution!
 ## HISTORY         :
 ## Description     :
 ## $Id$
 ###############################################################################
 
-ifdef ARCH
-  ha:=-a$(ARCH)
-endif
+ifdef ARCH
+  ha:=-a$(ARCH)
+endif
 
 # set the dpkg-architecture vars; but we don't use them, so we'll comment out
-export DEB_BUILD_ARCH      ?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_ARCH)
-export DEB_BUILD_GNU_CPU   ?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_CPU)
-export DEB_BUILD_GNU_SYSTEM?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_SYSTEM)
-export DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_TYPE)
-export DEB_HOST_ARCH       ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_ARCH)
-export DEB_HOST_GNU_CPU    ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_CPU)
-export DEB_HOST_GNU_SYSTEM ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_SYSTEM)
-export DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_TYPE)
+export DEB_BUILD_ARCH      ?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_ARCH)
+export DEB_BUILD_GNU_CPU   ?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_CPU)
+export DEB_BUILD_GNU_SYSTEM?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_SYSTEM)
+export DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_TYPE)
+export DEB_HOST_ARCH       ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_ARCH)
+export DEB_HOST_GNU_CPU    ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_CPU)
+export DEB_HOST_GNU_SYSTEM ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_SYSTEM)
+export DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_TYPE)
 
-# arch := $(shell dpkg --print-installation-architecture)
+arch   := $(shell dpkg --print-installation-architecture)
 
 # Basic information
 package := $(shell grep Source debian/control | sed 's/^Source: //')
@@ -50,12 +50,13 @@ DESC_FILES := debian-policy debian-menu-policy debian-perl-policy \
 # While we have two versions of the FHS installed in the source package,
 # we need to modify this to handle it.  This is the easiest way to do it.
 # FHS_ARCHIVE := $(wildcard fhs*.tar.gz)
-# And with version 2.1, we have to build the text and dvi versions
-# ourselves :-(
-FHS_ARCHIVE  := fhs-2.1-source.tar.gz
-FHS_HTML     := fhs-2.1.html.tar.gz
-FHS_FILES    := fhs/fhs.ps fhs/fhs.txt fhs/fhs.pdf
-# FSSTND_FILES := FSSTND-FAQ fsstnd-1.2.dvi.gz fsstnd-1.2.ps.gz fsstnd-1.2.txt.gz
+FHS_ARCHIVE  := fhs-2.3-source.tar.gz
+FHS_HTML     := fhs-2.3.html
+FHS_FILES    := fhs-2.3.ps.gz fhs-2.3.txt.gz fhs-2.3.pdf.gz
+FHS_NEW_ARCHIVE  := 
+FHS_NEW_HTML     := 
+FHS_NEW_FILES    := 
+
 POLICY_FILES = $(SGML_FILES:=.sgml) $(SGML_FILES:=.txt.gz) \
               virtual-package-names-list.txt \
               upgrading-checklist.txt libc6-migration.txt version.ent \
@@ -63,12 +64,14 @@ POLICY_FILES = $(SGML_FILES:=.sgml) $(SGML_FILES:=.txt.gz) \
                debconf_spec/debconf_specification.txt.gz \
                policy.ps.gz policy.pdf.gz
 
+# policy.{pdf,ps,tpt,txt} are generated files
 FILES_TO_CLEAN  = debian/files debian/buildinfo  debian/substvars \
                  debian/postinst debian/prerm \
                  version.ent upgrading-checklist.txt \
                  $(SGML_FILES:=.txt.gz) $(SGML_FILES:=.html.tar.gz) \
                  policy.pdf.gz policy.ps.gz \
-                 debconf_specification.xml.tar.gz
+                 debconf_specification.xml.tar.gz \
+                  policy.pdf policy.ps policy.txt policy.
 
 STAMPS_TO_CLEAN := stamp-policy stamp-build
 DIRS_TO_CLEAN   := debian/tmp fhs $(SGML_FILES:=.html)
@@ -85,17 +88,6 @@ stamp-build: version.ent $(sanitycheck)
                $(SGML_FILES:=.html.tar.gz) \
                $(SGML_FILES:=.txt.gz) \
                policy.ps.gz policy.pdf.gz
-       tar -zxf $(FHS_ARCHIVE)
-       # Need to use a patched tmac.m macro file if we're using a pre-1.16
-       # groff; version 1.16 is apparently fixed
-       if dpkg --compare-versions "$(shell dpkg -s groff | sed -n -e 's/Version: //p')" lt 1.16; then \
-           cp /usr/share/groff/tmac/tmac.m fhs && \
-           cd fhs && patch -p1 < ../mm1.32-patch; \
-       fi
-       # The extra '.' in the tmac path won't harm if unnecessary
-       GROFF_TMAC_PATH=. GROFF_NO_SGR=1 $(MAKE) -C fhs fhs.ps fhs.pdf fhs.txt
-       links -dump fhs-changes-2.1.html | perl -pe 's/[\r\0]//g' > \
-                    fhs/fhs-changes-2.1.txt
        links -dump upgrading-checklist.html | perl -pe 's/[\r\0]//g' > \
                     upgrading-checklist.txt
        $(MAKE) -C debconf_spec all
@@ -132,7 +124,6 @@ stamp-policy:  build $(sanitycheck)
 #      test -f stamp-build     || $(MAKE) -f        debian/rules build
        rm -rf                  $(TMPTOP)
        $(make_directory)       $(TMPTOP)/DEBIAN
-#      $(make_directory)       $(DOCDIR)/fsstnd
        $(make_directory)       $(DOCDIR)/fhs
        $(make_directory)       $(LIBDIR)
        # create a substvar to reference from debian/control so that
@@ -142,12 +133,13 @@ stamp-policy:  build $(sanitycheck)
        # itself...
        echo "debian-policy:Version=$(version)"      > debian/substvars
        $(install_file)     $(POLICY_FILES)          $(DOCDIR)/
-#      $(install_file)     $(FSSTND_FILES)          $(DOCDIR)/fsstnd/
-       $(install_file)     $(FHS_FILES)             $(DOCDIR)/fhs/
        $(install_file)     debian/changelog         $(DOCDIR)/
        # Be more specific with file compression
        gzip -f9            $(DOCDIR)/*.txt $(DOCDIR)/*.sgml \
-                               $(DOCDIR)/fhs/* $(DOCDIR)/changelog
+                               $(DOCDIR)/changelog
+# These are allready compressed
+       #$(install_file)    $(FHS_NEW_FILES)         $(DOCDIR)/fhs/
+       $(install_file)     $(FHS_FILES)             $(DOCDIR)/fhs/
        $(install_file)     debian/copyright         $(DOCDIR)/
        GZIP=-9 cd debconf_spec && \
          tar -zcf ../debconf_specification.xml.tar.gz *
@@ -160,7 +152,10 @@ stamp-policy:  build $(sanitycheck)
        for file in $(SGML_FILES); do \
          tar -C $(DOCDIR) -zxf $$file.html.tar.gz; \
        done
-       tar -C $(DOCDIR)/fhs -zxf $(FHS_HTML)
+       $(install_file)     $(FHS_HTML)   $(DOCDIR)/fhs
+       @set -ex; \
+       cd debian/tmp; \
+       find . -type f -printf '%P\0' | xargs -r0 md5sum > DEBIAN/md5sums
        sed -e 's/#PACKAGE#/$(package)/g' debian/postinst.in > debian/postinst
        sed -e 's/#PACKAGE#/$(package)/g' debian/prerm.in > debian/prerm
        $(install_program)  debian/postinst          debian/tmp/DEBIAN/