]> git.donarmstrong.com Git - debhelper.git/blobdiff - debian/rules
r1086: * Several man pae typo fixes by Ruben Porras. Closes: #202819
[debhelper.git] / debian / rules
index b2d030f7c1a2304ef06905b939679170f604c9cd..0c22f0e476e47fcb1f6299cfda28587019f79e95 100755 (executable)
@@ -23,7 +23,7 @@ build: test build-stamp
 build-stamp:
        # Generate the main man page. All the perl cruft is to get a list
        # of debhelper commands with short descriptions into the man page.
-       pod2man -c Debhelper -r "$(VERSION)" debhelper.pod | \
+       pod2man --section=7 -c Debhelper -r "$(VERSION)" debhelper.pod | \
        perl -e ' \
                undef $$/; \
                foreach (@ARGV) { \
@@ -39,9 +39,9 @@ build-stamp:
                                s/#LIST#/$$collect/; \
                                print; \
                        }; \
-               }' `find . -type f -perm +1 -maxdepth 1 -name "dh_*" | sort` > debhelper.1
+               }' `find . -type f -perm +100 -maxdepth 1 -name "dh_*" | sort` > debhelper.7
        # Turn all executables into man pages.
-       find . -type f -perm +1 -maxdepth 1 -name "dh_*" \
+       find . -type f -perm +100 -maxdepth 1 -name "dh_*" \
                -exec pod2man -c Debhelper -r "$(VERSION)" {} {}.1 \;
        printf "package Debian::Debhelper::Dh_Version;\n\$$version='$(VERSION)';" > \
                Debian/Debhelper/Dh_Version.pm
@@ -51,12 +51,12 @@ build-stamp:
 clean:
        ./dh_testdir
        ./dh_testroot
-       -./dh_clean *.1 *-stamp Debian/Debhelper/Dh_Version.pm
+       -./dh_clean *.1 *.7 *-stamp Debian/Debhelper/Dh_Version.pm
 
 test: test-stamp
 test-stamp:
        ./dh_clean
-       DH_VERSION=10 perl -MTest::Harness -e 'runtests grep { ! /CVS/ } @ARGV' t/*
+       DH_VERSION=10 perl -MTest::Harness -e 'runtests grep { ! /CVS/ && ! /\.svn/ } @ARGV' t/*
        ./dh_clean
        touch test-stamp
 
@@ -72,9 +72,9 @@ binary-indep: build
        ./dh_install -X .1 dh_* usr/bin
        ./dh_install Debian/Debhelper/*.pm $(PERLLIBDIR)/Debian/Debhelper/
        ./dh_install autoscripts usr/share/debhelper
-       ./dh_installdocs doc
+       ./dh_installdocs doc/*
        ./dh_installexamples examples/*
-       ./dh_installman *.1
+       ./dh_installman *.1 *.7
        ./dh_installchangelogs
        ./dh_shlibdeps
        ./dh_link
@@ -88,9 +88,10 @@ binary-indep: build
 
 # Update the debhelper web page. Not intended for use by anyone except the
 # author.
+DIR=/home/web/kitenet.net/programs/debhelper
 installhook:
-       cp debian/changelog /home/pub/programs/debhelper/CHANGES
-       echo -n $(VERSION) > /home/pub/programs/debhelper/LATEST-VERSION-IS
+       cp debian/changelog $(DIR)/CHANGES
+       echo -n $(VERSION) > $(DIR)/LATEST-VERSION-IS
 
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary dist