]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - debian/rules
Merge branch 'master' into bug575639-rra
[debian/debian-policy.git] / debian / rules
index 43f2157656cddea602da14c66975ca4b68f4e9fb..052193ff2fc865d9204264ddc5c5db47167119ed 100755 (executable)
@@ -38,7 +38,7 @@ LIBDIR          := $(TMPTOP)/usr/share/doc-base
 
 sanitycheck := debian/rules policy.sgml
 
-SGML_FILES := policy menu-policy mime-policy perl-policy
+SGML_FILES := policy menu-policy mime-policy perl-policy upgrading-checklist
 DESC_FILES := debian-policy debian-menu-policy debian-perl-policy \
               debian-mime-policy debconf-spec fhs
 
@@ -54,7 +54,7 @@ FHS_NEW_FILES    :=
 
 POLICY_FILES = $(SGML_FILES:=.sgml) $(SGML_FILES:=.txt.gz) \
               virtual-package-names-list.txt \
-              upgrading-checklist.txt libc6-migration.txt version.ent \
+              libc6-migration.txt version.ent \
                debconf_spec/debconf_specification.html \
                debconf_spec/debconf_specification.txt.gz \
                policy.ps.gz policy.pdf.gz README.txt README.html \
@@ -63,7 +63,7 @@ POLICY_FILES = $(SGML_FILES:=.sgml) $(SGML_FILES:=.txt.gz) \
 # policy.{pdf,ps,tpt,txt} are generated files
 FILES_TO_CLEAN  = debian/files debian/buildinfo  debian/substvars \
                  debian/postinst debian/prerm \
-                 version.ent upgrading-checklist.txt \
+                 version.ent \
                  $(SGML_FILES:=.txt.gz) $(SGML_FILES:=.html.tar.gz) \
                   $(SGML_FILES:=-1.html) \
                  policy.pdf.gz policy.ps.gz \
@@ -83,7 +83,8 @@ make_directory  := install -p -d      -o root -g root  -m  755
 
 
 all build: stamp-build
-stamp-build: version.ent $(sanitycheck)
+stamp-build: version.ent $(sanitycheck) README.txt README.html \
+              Process.txt Process.html
        $(MAKE) $(SGML_FILES:=.sgml.validate) \
                $(SGML_FILES:=.html.tar.gz) \
                 $(SGML_FILES:=-1.html) \
@@ -92,8 +93,6 @@ stamp-build: version.ent $(sanitycheck)
 ifneq (,$(strip $(HAVE_ORG_EMACS)))
        $(MAKE) $(FILES_FROM_ORG)
 endif
-       links -dump upgrading-checklist.html | perl -pe 's/[\r\0]//g' > \
-                    upgrading-checklist.txt
        $(MAKE) -C debconf_spec all
        touch stamp-build