]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - debian/rules
* Added doc-base support for all of the HTML docs in the package
[debian/debian-policy.git] / debian / rules
index fbc93b413cea79be9c540886888eab2368ec9391..028c067823bf86ef62ab14d6bb853663b34d3418 100755 (executable)
 ## Created On      : Thu Oct 29 15:35:55 1998
 ## Created On Node  : tiamat.datasync.com
 ## Last Modified By : Manoj Srivastava
-## Last Modified On : Fri Oct 30 00:53:33 1998
-## Last Machine Used: tiamat.datasync.com
-## Update Count            : 30
+## Last Modified On : Wed Sep  6 09:37:43 2000
+## Last Machine Used: glaurung.green-gryphon.com
+## Update Count            : 56
 ## Status          : Unknown, Use with caution!
 ## HISTORY         :
 ## Description     :
-##
+## $Id$
 ###############################################################################
+
+# ifdef ARCH
+#   ha:=-a$(ARCH)
+# endif
+
+# set the dpkg-architecture vars; but we don't use them, so we'll comment out
+# export DEB_BUILD_ARCH      := $(shell dpkg-architecture $(ha) -qDEB_BUILD_ARCH)
+# export DEB_BUILD_GNU_CPU   := $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_CPU)
+# export DEB_BUILD_GNU_SYSTEM:= $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_SYSTEM)
+# export DEB_BUILD_GNU_TYPE  := $(shell dpkg-architecture $(ha) -qDEB_BUILD_GNU_TYPE)
+# export DEB_HOST_ARCH       := $(shell dpkg-architecture $(ha) -qDEB_HOST_ARCH)
+# export DEB_HOST_GNU_CPU    := $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_CPU)
+# export DEB_HOST_GNU_SYSTEM := $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_SYSTEM)
+# export DEB_HOST_GNU_TYPE   := $(shell dpkg-architecture $(ha) -qDEB_HOST_GNU_TYPE)
+
+
 # The name of the package (for example, `emacs').
 package := $(shell grep Source debian/control | sed 's/^Source: //')
-arch   :=$(shell dpkg --print-architecture)
+# arch := $(shell dpkg --print-installation-architecture)
 date   := $(shell date +"%Y-%m-%d")
 version := $(shell LC_ALL=C dpkg-parsechangelog | \
                   grep ^Version: | sed 's/^Version: *//')
 
-FILES_TO_CLEAN  = debian/files debian/buildinfo  debian/substvars \
-                 version.ent  policy.lout policy.lout.ld lout.li \
-                 upgrading-checklist.text policy.text.gz
-STAMPS_TO_CLEAN = stamp-binary stamp-build stamp-configure
-DIRS_TO_CLEAN   = debian/tmp policy.html
-
 # Location of the source dir
 SRCTOP   := $(shell if [ "$$PWD" != "" ]; then echo $$PWD; else pwd; fi;)
 TMPTOP   := $(SRCTOP)/debian/tmp
-DOCDIR   := $(TMPTOP)/usr/doc/$(package)
+DOCDIR   := $(TMPTOP)/usr/share/doc/$(package)
 LIBDIR   := $(TMPTOP)/usr/share/doc-base
 
-FSSTND_FILES   =FSSTND-FAQ fsstnd-1.2.dvi.gz fsstnd-1.2.ps.gz fsstnd-1.2.txt.gz
-POLICY_FILES   =policy.text.gz policy.sgml virtual-package-names-list.text \
-               upgrading-checklist.text libc6-migration.text
-BYHAND_FILES   =policy.text.gz libc6-migration.text\
-               virtual-package-names-list.text
+
+SGML_FILES      = policy menu-policy mime-policy policy-process perl-policy
+DESC_FILES      = debian-policy debian-menu-policy debian-perl-policy \
+                  debian-mime-policy debian-policy-process debconf-spec
+
+# While we have two versions of the FHS installed in the source package,
+# we need to modify this to handle it.  This is the easiest way to do it.
+# FHS_ARCHIVE  =$(shell ls -1 fhs*.tar.gz)
+# And with version 2.1, we have to build the text and dvi versions
+# ourselves :-(
+FHS_ARCHIVE  =fhs-2.1-source.tar.gz
+FHS_HTML     =fhs-2.1.html.tar.gz
+FHS_FILES    =fhs/fhs.ps fhs/fhs.txt fhs/fhs.pdf
+FHS_BYHAND   =fhs-2.1.html.tar.gz fhs/fhs.txt
+# FSSTND_FILES =FSSTND-FAQ fsstnd-1.2.dvi.gz fsstnd-1.2.ps.gz fsstnd-1.2.txt.gz
+POLICY_FILES = $(SGML_FILES:=.sgml) $(SGML_FILES:=.txt.gz) \
+              virtual-package-names-list.txt \
+              upgrading-checklist.txt libc6-migration.txt version.ent \
+               debconf_spec/debconf_specification.html \
+               debconf_spec/debconf_specification.txt.gz
+BYHAND_FILES = $(SGML_FILES:=.txt.gz) $(SGML_FILES:=.html.tar.gz) \
+              debconf_spec/debconf_specification.txt.gz \
+              debconf_spec/debconf_specification.html \
+              libc6-migration.txt virtual-package-names-list.txt \
+              policy.ps.gz policy.pdf.gz \
+              $(FHS_BYHAND)
+
+FILES_TO_CLEAN  = debian/files debian/buildinfo  debian/substvars \
+                 debian/postinst debian/prerm \
+                 version.ent upgrading-checklist.txt \
+                 $(SGML_FILES:=.txt.gz) $(SGML_FILES:=.html.tar.gz) \
+                 policy.pdf.gz policy.ps.gz \
+                 debconf_specification.xml.tar.gz
+
+STAMPS_TO_CLEAN = stamp-policy stamp-build stamp-configure
+DIRS_TO_CLEAN   = debian/tmp fhs $(SGML_FILES:=.html)
+
 
 install_file   = /usr/bin/install -p   -o root -g root  -m  644
 install_program= /usr/bin/install -p   -o root -g root  -m  755
 make_directory = /usr/bin/install -p -d -o root -g root         -m  755
 
+GROFF_VERSION := $(shell dpkg -s groff | sed -n -e 's/Version: //p')
+
 
 all build: stamp-build
 stamp-build:
        $(checkdir)
        -test -f stamp-configure || $(MAKE) -f debian/rules configure
-       nsgmls -gues policy.sgml        # check SGML syntax
-       debiandoc2html policy.sgml
-       debiandoc2text policy.sgml
-       lynx -dump upgrading-checklist.html > upgrading-checklist.text
-       gzip -9 policy.text
+       set -e; \
+       for file in $(SGML_FILES); do \
+         nsgmls -gues $$file.sgml; \
+         debiandoc2html $$file.sgml; \
+         debiandoc2text $$file.sgml; \
+         if [ -f $$file.text ]; then mv $$file.text $$file.txt; fi; \
+         gzip -9 $$file.txt; \
+         tar -cf $$file.html.tar $$file.html; \
+         gzip -9 $$file.html.tar; \
+       done
+       tar -zxf $(FHS_ARCHIVE)
+       # Need to use a patched tmac.m macro file if we're using a pre-1.16
+       # groff; version 1.16 is apparently fixed
+       if dpkg --compare-versions $(GROFF_VERSION) lt 1.16; then \
+           cp /usr/share/groff/tmac/tmac.m fhs && \
+           cd fhs && patch -p1 < ../mm1.32-patch; \
+       fi
+       # The extra '.' in the tmac path doesn't matter if
+       GROFF_TMAC_PATH=. cd fhs && $(MAKE) fhs.ps fhs.pdf fhs.txt
+       links -dump fhs-changes-2.1.html | perl -pe 's/[\r\0]//g' > \
+                    fhs/fhs-changes-2.1.txt
+       links -dump upgrading-checklist.html | perl -pe 's/[\r\0]//g' > \
+                    upgrading-checklist.txt
+       $(MAKE) -C debconf_spec all
+       gzip -9f debconf_spec/debconf_specification.txt
        touch stamp-build
 
 configure: stamp-configure
@@ -60,9 +124,11 @@ stamp-configure:
        echo "<!entity version \"$(version)\">" >> version.ent
        echo "<!entity date    \"$(date)\">"        >> version.ent
        touch stamp-configure
+
 clean:
 # Undoes the effect of `make -f debian/rules build'.
        $(checkdir)
+       $(MAKE) -C debconf_spec clean
        rm -f  $(FILES_TO_CLEAN) $(STAMPS_TO_CLEAN)
        rm -rf $(DIRS_TO_CLEAN)
        rm -f core `find . \( -name '*.orig' -o -name '*.rej' -o \
@@ -78,14 +144,17 @@ binary-arch:       build
 # generated by this package.  If there were any they would be
 # made here.
 
-binary-indep:  stamp-binary
-stamp-binary:  build
-       @test root = "`whoami`" || (echo need root priviledges; exit 1)
+binary-indep:  stamp-policy
+stamp-policy:  build
+       @test $$(id | sed -e 's/(.*$$//' -e 's/^uid=//') || \
+               (echo need root priviledges; exit 1)
        $(checkdir)
-       test -f stamp-build     || $(MAKE) -f        debian/rules build
+#      This is unnecessary; commenting out
+#      test -f stamp-build     || $(MAKE) -f        debian/rules build
        -rm -rf                 $(TMPTOP)
        $(make_directory)       $(TMPTOP)/DEBIAN
-       $(make_directory)       $(DOCDIR)/fsstnd
+#      $(make_directory)       $(DOCDIR)/fsstnd
+       $(make_directory)       $(DOCDIR)/fhs
        $(make_directory)       $(LIBDIR)
        # create a substvar to reference from debian/control so that
        # we don't hardcode the policy compliance of the policy
@@ -94,26 +163,43 @@ stamp-binary:  build
        # itself...
        echo "debian-policy:Version=$(version)"      > debian/substvars
        $(install_file)     $(POLICY_FILES)          $(DOCDIR)/
-       $(install_file)     $(FSSTND_FILES)          $(DOCDIR)/fsstnd/
+#      $(install_file)     $(FSSTND_FILES)          $(DOCDIR)/fsstnd/
+       $(install_file)     $(FHS_FILES)             $(DOCDIR)/fhs/
        $(install_file)     debian/changelog         $(DOCDIR)/
-       -gzip -fqr9         $(DOCDIR)
-       $(install_file)     debian-policy.desc       $(LIBDIR)/
+       # Be more specific with file compression
+       -gzip -9            $(DOCDIR)/*.txt $(DOCDIR)/*.sgml \
+                               $(DOCDIR)/fhs/* $(DOCDIR)/changelog
        $(install_file)     debian/copyright         $(DOCDIR)/
-       (tar cf -           policy.html) |           (cd $(DOCDIR);   tar xf -)
-       $(install_program)  debian/{postinst,prerm}  debian/tmp/DEBIAN/
-       dpkg-gencontrol     -isp
-       chown               -R root.root debian/tmp
+       GZIP=-9 tar -C debconf_spec -zcf debconf_specification.xml.tar.gz *
+       $(install_file)     debconf_specification.xml.tar.gz $(DOCDIR)/
+       set -e; \
+        for file in $(DESC_FILES); do \
+         $(install_file) $$file.desc $(LIBDIR)/$$file; \
+       done
+       set -e; \
+       for file in $(SGML_FILES); do \
+         tar -C $(DOCDIR) -zxf $$file.html.tar.gz; \
+       done
+       tar -C $(DOCDIR)/fhs -zxf $(FHS_HTML)
+       sed -e 's/#PACKAGE#/$(package)/g' debian/postinst.in > debian/postinst
+       sed -e 's/#PACKAGE#/$(package)/g' debian/prerm.in > debian/prerm
+       $(install_program)  debian/postinst          debian/tmp/DEBIAN/
+       $(install_program)  debian/prerm             debian/tmp/DEBIAN/
+       dpkg-gencontrol     -pdebian-policy -Pdebian/tmp -isp
+       chown               -R root:root debian/tmp
        chmod               -R go=rX debian/tmp
        dpkg                --build debian/tmp ..
-       debiandoc2ps        -pa4 -1 -O policy.sgml | gzip -9v >  ../policy.ps.gz
-       GZIP=-9v tar zcf    ../policy.html.tar.gz    policy.html
-       dpkg-distaddfile    -fdebian/files           policy.ps.gz       byhand -
-       dpkg-distaddfile    -fdebian/files           policy.html.tar.gz byhand -
-       for i in            $(BYHAND_FILES); do \
-         $(install_file)   $$i            ..                ; \
-         dpkg-distaddfile  -fdebian/files $$i       byhand - ; \
+       debiandoc2latexps   policy.sgml
+       gzip -9f            policy.ps
+       debiandoc2latexpdf  policy.sgml
+       gzip -9f            policy.pdf
+       set -e; \
+       for i in            $(BYHAND_FILES); do                          \
+         $(install_file)   $$i            ..                          ; \
+         dpkg-distaddfile  -fdebian/files `basename $$i`     byhand - ; \
        done
-       touch              stamp-binary
+       touch               stamp-policy
+
 
 define checkdir
        test -f debian/rules -a -f policy.sgml
@@ -122,7 +208,7 @@ endef
 source diff:
        @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
 
-.PHONY: binary binary-arch binary-indep clean checkroot
+.PHONY: configure build binary binary-arch binary-indep clean checkroot
 
 #Local variables:
 #mode: makefile