]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - debconf_spec/Makefile
Build-Depends on emacs24-nox|emacs24 instead of emacs23.
[debian/debian-policy.git] / debconf_spec / Makefile
index a34ade79fdcdab2b15f34883486f0257fedc48f3..ba5c251622ef634c30d65f01a1903c271222bdba 100644 (file)
@@ -1,12 +1,17 @@
-all: debconf_specification.txt debconf_specification.html
+all: debconf_specification.txt.gz debconf_specification.html
 
 %.html: %.xml html.dsl
        jade -V nochunks -t sgml -d html.dsl \
-               /usr/lib/sgml/declaration/xml.dcl $< > $@
-       -tidy -i -m -f /dev/null $@
+               /usr/share/xml/declaration/xml.dcl $< > $@
+       -tidy -q -i -m -f /dev/null $@
 
 %.txt: %.html
        links -dump $< | perl -pe 's/[\r\0]//g' > $@
 
+%.txt.gz: %.txt
+       gzip -cf9 $< > $@
+
 clean:
        rm -f *.css *.html *.txt *.txt.gz
+
+.DELETE_ON_ERROR: