]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - debconf_spec/Makefile
* There have been numerous changes since the last major change, and
[debian/debian-policy.git] / debconf_spec / Makefile
diff --git a/debconf_spec/Makefile b/debconf_spec/Makefile
new file mode 100644 (file)
index 0000000..59b0dd7
--- /dev/null
@@ -0,0 +1,12 @@
+all: debconf_specification.txt debconf_specification.html
+
+%.html: %.xml html.dsl
+       jade -V nochunks -t sgml -d html.dsl \
+               /usr/lib/sgml/declaration/xml.dcl $< > $@
+       -tidy -i -m -f /dev/null $@
+
+%.txt: %.html
+       links -dump $< | perl -pe 's/[\r\0]//g' > $@
+
+clean:
+       rm -f *.css *.html *.txt