]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - README.html
Specification of date format -- bug #569174.
[debian/debian-policy.git] / README.html
index 2da20e2af48860a2b1eea99ef8a3af77b3477276..438927dde6d28694126ff3bb3d877a4edc86113e 100644 (file)
@@ -4,16 +4,10 @@
 <html xmlns="http://www.w3.org/1999/xhtml"
 lang="en" xml:lang="en">
 <head>
-<div style="text-align:right;font-size:70%;white-space:nowrap;">
- <a accesskey="h" href="http://www.debian.org/"> UP </a>
- |
- <a accesskey="H" href="http://wiki.debian.org/Teams/Policy"> HOME </a>
-</div>
-
 <title>Debian Policy</title>
 <meta http-equiv="Content-Type" content="text/html;charset=utf-8"/>
 <meta name="generator" content="Org-mode"/>
-<meta name="generated" content="2009-09-15 15:48:45 CDT"/>
+<meta name="generated" content="2010-06-04 09:42:57 PDT"/>
 <meta name="author" content="Manoj Srivastava And Russ Allbery"/>
 <meta name="description" content=""/>
 <meta name="keywords" content=""/>
@@ -43,8 +37,8 @@ lang="en" xml:lang="en">
                                  font-weight:bold; }
 
   body {
-   color: DarkSlateGrey;
-   background-color: gainsboro;
+   color: black;
+   background-color: white;
    font-family: Palatino, "Palatino Linotype", "Hoefler Text", "Times New Roman", Times, Georgia, Utopia, serif;
   }
   .org-agenda-date          { color: #87cefa;    }
@@ -58,12 +52,6 @@ lang="en" xml:lang="en">
     font-weight: bold;
   }
  
-  a {
-    color: inherit;
-    background-color: inherit;
-    font: inherit;
-    text-decoration: inherit;
-  }
   a:hover { text-decoration: underline; }
   .todo  { font-weight:bold; }
   .done { font-weight:bold; }
@@ -120,6 +108,12 @@ org_html_manager.setup ();
 </head>
 <body>
 <div id="content">
+<div id="org-div-home-and-up" style="text-align:right;font-size:70%;white-space:nowrap;">
+ <a accesskey="h" href="http://www.debian.org/"> UP </a>
+ |
+ <a accesskey="H" href="http://wiki.debian.org/Teams/Policy"> HOME </a>
+</div>
+
 <h1 class="title">Debian Policy</h1>
 
 
@@ -158,9 +152,9 @@ to manage the repository but not otherwise used)
 
 </div>
 
-<div id="outline-container-1.1" class="outline-3">
-<h3 id="sec-1.1">Interacting with the team </h3>
-<div class="outline-text-3" id="text-1.1">
+<div id="outline-container-1_1" class="outline-3">
+<h3 id="sec-1_1">Interacting with the team </h3>
+<div class="outline-text-3" id="text-1_1">
 
 
 <ul>
@@ -198,14 +192,18 @@ git commit
 git checkout master
 git pull
 
-# If there are changes in master that make the branch not apply cleanly:
- : git checkout -b temp master; git merge &lt;local-branch-name&gt;
-# If error, reset temp, merge master into local; else skip these three lines
- : git reset --hard HEAD;
- : git checkout &lt;local-branch-name&gt;; 
+git checkout master
+git merge --no-commit &lt;local-branch-name&gt;
+git reset --hard HEAD;
+git checkout &lt;local-branch-name&gt;; 
+
+# If there are changes in master that make the branch not apply cleanly, there
+# should have been en error during the merge step above. If there was an
+# error, merge the master branch into the local branch, fix the conflicts, and
+# commit the new version of the local branch.
  : git merge master
-# get rid of the temp branch:
- : git branch -D temp
+# Edit files to remove conflict
+ : git commit -s 
 
 # Checkout the local branch, to create the patch to send to the policy
 git checkout &lt;local-branch-name&gt;
@@ -219,7 +217,6 @@ git send-email --from <span style="font-style: italic;">"you &lt;<a href="mailto
 
 
 
-
 <p>
 &lt;local-branch-name&gt; is some convenient name designating your local
 changes. You may want to use some common prefix like local-. You can
@@ -396,18 +393,18 @@ help you get started.
 
 </div>
 
-<div id="outline-container-4.1" class="outline-3">
-<h3 id="sec-4.1">Maintenance procedures </h3>
-<div class="outline-text-3" id="text-4.1">
+<div id="outline-container-4_1" class="outline-3">
+<h3 id="sec-4_1">Maintenance procedures </h3>
+<div class="outline-text-3" id="text-4_1">
 
 
 </div>
 
 </div>
 
-<div id="outline-container-4.2" class="outline-3">
-<h3 id="sec-4.2">Repository layout </h3>
-<div class="outline-text-3" id="text-4.2">
+<div id="outline-container-4_2" class="outline-3">
+<h3 id="sec-4_2">Repository layout </h3>
+<div class="outline-text-3" id="text-4_2">
 
 
 <p>
@@ -432,9 +429,9 @@ The Git repository used for Debian Policy has the following branches:
 
 </div>
 
-<div id="outline-container-4.3" class="outline-3">
-<h3 id="sec-4.3">Managing a bug </h3>
-<div class="outline-text-3" id="text-4.3">
+<div id="outline-container-4_3" class="outline-3">
+<h3 id="sec-4_3">Managing a bug </h3>
+<div class="outline-text-3" id="text-4_3">
 
 
 <p>
@@ -491,12 +488,20 @@ git push origin bug12345-rra
 # update your local master branch
 git checkout master
 git pull
-# If there are changes in master that make the branch not apply cleanly:
-: git checkout -b temp master; git merge bug12345-rra
-# If error;
-: git reset --hard HEAD;
-: git checkout bug12345-rra; git branch -D temp
-: git merge master
+
+git checkout master
+git merge --no-commit bug12345-rra
+git reset --hard HEAD;
+
+# If there are changes in master that make the branch not apply cleanly, there
+# should have been en error during the merge step above. If there was an
+# error, merge the master branch into the local branch, fix the conflicts, and
+# commit the new version of the local branch.
+ : git checkout bug12345-rra
+ : git merge master
+# Edit files to remove conflict
+ : git commit -s 
+
 git checkout master
 git merge bug12345-rra
 # edit debian/changelog and upgrading-checklist.html
@@ -509,7 +514,6 @@ git push origin :bug12345-rra
 
 
 
-
 <p>
 For the debian/changelog entry, use the following format:
 </p>
@@ -524,7 +528,6 @@ For the debian/changelog entry, use the following format:
 
 
 
-
 <p>
 For example:
 </p>
@@ -540,14 +543,13 @@ For example:
 
 
 
-
 </div>
 
 </div>
 
-<div id="outline-container-4.4" class="outline-3">
-<h3 id="sec-4.4">Updating branches </h3>
-<div class="outline-text-3" id="text-4.4">
+<div id="outline-container-4_4" class="outline-3">
+<h3 id="sec-4_4">Updating branches </h3>
+<div class="outline-text-3" id="text-4_4">
 
 
 <p>
@@ -569,7 +571,6 @@ git push --all origin
 
 
 
-
 <p>
 assuming that you haven't packed the refs in your repository.
 </p>
@@ -577,9 +578,9 @@ assuming that you haven't packed the refs in your repository.
 
 </div>
 
-<div id="outline-container-4.5" class="outline-3">
-<h3 id="sec-4.5">Making a release </h3>
-<div class="outline-text-3" id="text-4.5">
+<div id="outline-container-4_5" class="outline-3">
+<h3 id="sec-4_5">Making a release </h3>
+<div class="outline-text-3" id="text-4_5">
 
 
 <p>
@@ -603,7 +604,6 @@ git push --tags origin
 
 
 
-
 <p>
 replacing the version number with the version of the release, of course.
 </p>
@@ -616,9 +616,9 @@ new release.
 
 </div>
 
-<div id="outline-container-4.6" class="outline-3">
-<h3 id="sec-4.6">Setting release goals </h3>
-<div class="outline-text-3" id="text-4.6">
+<div id="outline-container-4_6" class="outline-3">
+<h3 id="sec-4_6">Setting release goals </h3>
+<div class="outline-text-3" id="text-4_6">
 
 
 <p>
@@ -669,10 +669,9 @@ reach one of the resolution states above.
 </div>
 <div id="postamble">
 <p class="author"> Author: Manoj Srivastava And Russ Allbery
-<a href="mailto:srivasta@debian.org">&lt;srivasta@debian.org&gt;</a>
 </p>
-<p class="date"> Date: 2009-09-15 15:48:45 CDT</p>
-<p class="creator">HTML generated by org-mode 6.30trans in emacs 23</p>
+<p class="date"> Date: 2010-06-04 09:42:57 PDT</p>
+<p class="creator">HTML generated by org-mode 6.36c in emacs 23</p>
 </div>
 </div>
 </body>