]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - README.html
Ignore upgrading-checklist.html
[debian/debian-policy.git] / README.html
index 765c626a4d2040dc47cedeccad2b69c7e3492172..19608a2560c59701f7a20ffe4daa4a0db050839e 100644 (file)
@@ -13,22 +13,19 @@ lang="en" xml:lang="en">
 <title>Debian Policy</title>
 <meta http-equiv="Content-Type" content="text/html;charset=utf-8"/>
 <meta name="generator" content="Org-mode"/>
-<meta name="generated" content="2009-09-12 17:30:48 CDT"/>
-<meta name="author" content="Manoj Srivastava"/>
+<meta name="generated" content="2009-10-05 00:20:29 CDT"/>
+<meta name="author" content="Manoj Srivastava And Russ Allbery"/>
 <meta name="description" content=""/>
 <meta name="keywords" content=""/>
 
-<link href="/styles/simple_screen.css" type="text/css" rel="stylesheet" media="screen" />
-<link href="/styles/simple_print.css"  type="text/css" rel="stylesheet" media="print" />
-<link href="/styles/common.css"        type="text/css" rel="stylesheet" />
 <style type="text/css">
   html { font-family: Times, serif; font-size: 12pt; }
   .title  { text-align: center; }
   p.verse { margin-left: 3% }
   pre {
         border: 1pt solid #AEBDCC;
-        color: gainsboro;
-        background-color: DarkSlateGrey;
+        color: #000000;
+        background-color: LightSlateGray;
         padding: 5pt;
         font-family: "Courier New", courier, monospace;
         font-size: 90%;
@@ -46,8 +43,8 @@ lang="en" xml:lang="en">
                                  font-weight:bold; }
 
   body {
-    color: LightSlateGray;
-    background-color: #000000;
+   color: DarkSlateGrey;
+   background-color: gainsboro;
    font-family: Palatino, "Palatino Linotype", "Hoefler Text", "Times New Roman", Times, Georgia, Utopia, serif;
   }
   .org-agenda-date          { color: #87cefa;    }
@@ -179,7 +176,7 @@ Request tracker:: <a href="http://bugs.debian.org/src:debian-policy">http://bugs
 <p>Debian Policy uses a formal procedure and a set of user tags to manage
 the lifecycle of change proposals. For definitions of those tags and
 proposal states and information about what the next step is for each
-phase, see PolicyChangesProcess.
+phase, see <a href="./Process.html">Policy changes process</a>.
 </p>
 <p>
 Once the wording for a change has been finalized, please send a patch
@@ -201,21 +198,25 @@ git commit
 git checkout master
 git pull
 
-# If there are changes in master that make the branch not apply cleanly:
- : git checkout -b temp master; git merge &lt;local-branch-name&gt;
-# If error, reset temp, merge master into local; else skip these three lines
- : git reset --hard HEAD;
- : git checkout &lt;local-branch-name&gt;; 
+git checkout master
+git merge --no-commit &lt;local-branch-name&gt;
+git reset --hard HEAD;
+git checkout &lt;local-branch-name&gt;; 
+
+# If there are changes in master that make the branch not apply cleanly, there
+# should have been en error during the merge step above. If there was an
+# error, merge the master branch into the local branch, fix the conflicts, and
+# commit the new version of the local branch.
  : git merge master
-# get rid of the temp branch:
- : git branch -D temp
+# Edit files to remove conflict
+ : git commit -s 
 
 # Checkout the local branch, to create the patch to send to the policy
 git checkout &lt;local-branch-name&gt;
 dir=$(mktemp -d)
 git format-patch -o $dir -s master
 # check out the patches created in $dir
-git send-email --from <span style="color: #ffc1c1;">"you &lt;<a href="mailto:your&#64;email">your&#64;email</a>&gt;"</span>             \
+git send-email --from <span style="font-style: italic;">"you &lt;<a href="mailto:your&#64;email">your&#64;email</a>&gt;"</span>             \
                --to debian-policy@lists.debian.org   \
                $dir/
 </pre>
@@ -328,7 +329,7 @@ In addition to the main technical manual, the team currently also maintains:
 </li>
 </ul>
 
-<p>These documents are maintained using the <a href="http://wiki.debian.org/PolicyChangesProcess">Policy changes process</a>, and
+<p>These documents are maintained using the <a href="./Process.html">Policy changes process</a>, and
 the current state of all change proposals is tracked using the
 <a href="http://bugs.debian.org/src:debian-policy">debian-policy BTS</a>.
 </p>
@@ -350,7 +351,7 @@ will involve guiding the discussion, seeking additional input
 (particularly from experts in the area being discussed), possibly
 raising the issue on other mailing lists, proposing or getting other
 people to propose specific wording changes, and writing diffs against
-the current Policy document. All of the steps of <a href="http://wiki.debian.org/PolicyChangesProcess">Policy changes process</a> 
+the current Policy document. All of the steps of <a href="./Process.html">Policy changes process</a> 
 can be done by people other than Policy team members except
 the final acceptance steps and almost every change can be worked on
 independently, so there's a lot of opportunity for people to help.
@@ -494,12 +495,20 @@ git push origin bug12345-rra
 # update your local master branch
 git checkout master
 git pull
-# If there are changes in master that make the branch not apply cleanly:
-: git checkout -b temp master; git merge bug12345-rra
-# If error;
-: git reset --hard HEAD;
-: git checkout bug12345-rra; git branch -D temp
-: git merge master
+
+git checkout master
+git merge --no-commit bug12345-rra
+git reset --hard HEAD;
+
+# If there are changes in master that make the branch not apply cleanly, there
+# should have been en error during the merge step above. If there was an
+# error, merge the master branch into the local branch, fix the conflicts, and
+# commit the new version of the local branch.
+ : git checkout bug12345-rra
+ : git merge master
+# Edit files to remove conflict
+ : git commit -s 
+
 git checkout master
 git merge bug12345-rra
 # edit debian/changelog and upgrading-checklist.html
@@ -563,7 +572,7 @@ branches. The equivalent of the following commands should do that:
 
 <pre class="src src-Sh">for i in `git show-ref --heads | awk '{print $2}'`; do
     j=$(basename $i)
-    if [ <span style="color: #ffc1c1;">"$j"</span> != <span style="color: #ffc1c1;">"master"</span> ]; then
+    if [ <span style="font-style: italic;">"$j"</span> != <span style="font-style: italic;">"master"</span> ]; then
         git checkout $j &amp;&amp; git merge master
     fi
 done
@@ -633,11 +642,10 @@ Policy release. Resolving a bug means one of the following:
 </p>
 <ul>
 <li>
-Proposing new language to address the bug that's seconded and
-approved by the readers of the Policy list following the
-PolicyChangesProcess (or that's accepted by one of the Policy
-delegates if the change isn't normative; i.e., doesn't change the
-technical meaning of the document).
+Proposing new language to address the bug that's seconded and approved by
+the readers of the Policy list following the <a href="./Progress.html">Policy changes process</a> (or
+that's accepted by one of the Policy delegates if the change isn't
+normative; i.e., doesn't change the technical meaning of the document).
 </li>
 <li>
 Determining that the bug is not relevant to Policy and closing it.
@@ -672,11 +680,11 @@ reach one of the resolution states above.
 </div>
 </div>
 <div id="postamble">
-<p class="author"> Author: Manoj Srivastava
+<p class="author"> Author: Manoj Srivastava And Russ Allbery
 <a href="mailto:srivasta@debian.org">&lt;srivasta@debian.org&gt;</a>
 </p>
-<p class="date"> Date: 2009-09-12 17:30:48 CDT</p>
-<p class="creator">HTML generated by org-mode 6.30trans in emacs 23</p>
+<p class="date"> Date: 2009-10-05 00:20:29 CDT</p>
+<p class="creator">HTML generated by org-mode 6.31trans in emacs 23</p>
 </div>
 </div>
 </body>