]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
Final changes before primetime.
[neurodebian.git] / Makefile
index 39fe377f91cb704bde281923c86e2defdb63f095..fb0bc49bf6f00a19901ab1014ee0e9ff7546838f 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,75 +1,61 @@
-# Makefile for Sphinx documentation
-#
-
-# You can set these variables from the command line.
-SPHINXOPTS    =
-SPHINXBUILD   = sphinx-build
-PAPER         =
-
-# Internal variables.
-PAPEROPT_a4     = -D latex_paper_size=a4
-PAPEROPT_letter = -D latex_paper_size=letter
-ALLSPHINXOPTS   = -d build/doctrees $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) source
-
-.PHONY: help clean html web pickle htmlhelp latex changes linkcheck
-
-help:
-       @echo "Please use \`make <target>' where <target> is one of"
-       @echo "  html      to make standalone HTML files"
-       @echo "  pickle    to make pickle files"
-       @echo "  json      to make JSON files"
-       @echo "  htmlhelp  to make HTML files and a HTML help project"
-       @echo "  latex     to make LaTeX files, you can set PAPER=a4 or PAPER=letter"
-       @echo "  changes   to make an overview over all changed/added/deprecated items"
-       @echo "  linkcheck to check all external links for integrity"
+#WWW_UPLOAD_URI = neuro.debian.net:/home/www/neuro.debian.net/www
+WWW_UPLOAD_URI = ../www
+WWW_DIR = build/html/
+
+all: updatedb upload-website
+
+
+pics:
+       $(MAKE) -C artwork
+
+
+html: pics source
+       rsync -rvlhp sphinx/ build/src
+       cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build 2>&1
+
 
 clean:
-       -rm -rf build/*
-
-html:
-       mkdir -p build/html build/doctrees
-       $(SPHINXBUILD) -b html $(ALLSPHINXOPTS) build/html
-       @echo
-       @echo "Build finished. The HTML pages are in build/html."
-
-pickle:
-       mkdir -p build/pickle build/doctrees
-       $(SPHINXBUILD) -b pickle $(ALLSPHINXOPTS) build/pickle
-       @echo
-       @echo "Build finished; now you can process the pickle files."
-
-web: pickle
-
-json:
-       mkdir -p build/json build/doctrees
-       $(SPHINXBUILD) -b json $(ALLSPHINXOPTS) build/json
-       @echo
-       @echo "Build finished; now you can process the JSON files."
-
-htmlhelp:
-       mkdir -p build/htmlhelp build/doctrees
-       $(SPHINXBUILD) -b htmlhelp $(ALLSPHINXOPTS) build/htmlhelp
-       @echo
-       @echo "Build finished; now you can run HTML Help Workshop with the" \
-             ".hhp project file in build/htmlhelp."
-
-latex:
-       mkdir -p build/latex build/doctrees
-       $(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) build/latex
-       @echo
-       @echo "Build finished; the LaTeX files are in build/latex."
-       @echo "Run \`make all-pdf' or \`make all-ps' in that directory to" \
-             "run these through (pdf)latex."
-
-changes:
-       mkdir -p build/changes build/doctrees
-       $(SPHINXBUILD) -b changes $(ALLSPHINXOPTS) build/changes
-       @echo
-       @echo "The overview file is in build/changes."
-
-linkcheck:
-       mkdir -p build/linkcheck build/doctrees
-       $(SPHINXBUILD) -b linkcheck $(ALLSPHINXOPTS) build/linkcheck
-       @echo
-       @echo "Link check complete; look for any errors in the above output " \
-             "or in build/linkcheck/output.txt."
+       -rm html-stamp source-stamp
+       $(MAKE) -C artwork clean
+
+
+distclean: clean
+       -rm -rf build
+
+
+source: source-stamp
+source-stamp: build/db.db
+       PYTHONPATH=. python neurodebian/dde.py \
+               --cfg neurodebian.cfg \
+               --db build/db.db \
+               --outdir build/src \
+               --pkgaddenum pkgs \
+               commandisirrelevant
+       rm -f html-stamp
+       touch $@
+
+
+removecache:
+       -rm -rf build/cache
+
+removedb:
+       -rm build/db.db
+
+
+updatedb: removedb removecache build/db.db
+
+
+build/db.db:
+       mkdir -p build
+       PYTHONPATH=. python neurodebian/dde.py \
+               --cfg neurodebian.cfg \
+               --db build/db.db \
+               updatedb
+       -rm source-stamp
+
+
+upload-website: html
+       rsync -rvzlhp --delete --exclude=debian --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
+
+.PHONY: removedb removecache updatedb upload-website clean distclean pics html
+