]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
ENH: Make neurodebian.cfg also visible on the website so we could easily fetch up...
[neurodebian.git] / Makefile
index 7b980d4058993bfbfc3db717259c53e0d023b7ac..f2876a1740f680b4cc18d330e4c647d5eb39eb55 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -18,6 +18,7 @@ html: pics source
        rsync -rvlhpt sphinx/ build/src
        cd artwork;     cp button_w200.png logo_tuned/fmri_w200.png ../build/src/_static; cd ..
        cp 3rd/jquery.livetwitter/jquery.livetwitter.min.js build/src/_static
+       cp neurodebian.cfg build/src/_static
        cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build 2>&1
        mv $(WWW_DIR)/_static/robots.txt $(WWW_DIR)/
        cp -r build/src/lists $(WWW_DIR)/
@@ -81,7 +82,7 @@ upload-website-stamp: .git/index
 mirmon:
        # update and generate mirrors report
        [ -x /usr/bin/mirmon ] && mirmon -q -get update -c mirmon-neurodebian.conf 2>&1 \
-        | grep -v 'date: invalid date.*DOCTYPE'
+        | grep -v 'date: invalid date.*DOCTYPE' || :
        # [ -x $(WWW_UPLOAD_URI_STATIC)/mirrors-check.ihtml ] &&
        # everything must be in place!
        cat $(WWW_UPLOAD_URI_STATIC)/{index-header,mirrors-status,index-trailer}.ihtml \