]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
Merge commit newdesign (web-20130424-72-g6662d1c)
[neurodebian.git] / Makefile
index c316277f202e186d6eac15886c9c61a62a939b6b..de232c7f9ba364e6fdb7691eb0ad89497e3be0b1 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,11 +1,11 @@
-WWW_UPLOAD_URI = neurodebian@neurodebian.ovgu.de:/home/neurodebian/www
-#WWW_UPLOAD_URI = ../www
+#WWW_UPLOAD_URI = neurodebian@neurodebian.ovgu.de:/home/neurodebian/www
+WWW_UPLOAD_URI = ../../www
 WWW_DIR = build/html/
 
 WWW_UPLOAD_URI_STATIC=$(WWW_UPLOAD_URI)/_static
 
-BIGMESS_OPTS = -c neurodebian_repo.cfg
-BIGMESS_CMD = PYTHONPATH=.:../bigmess:$(PYTHONPATH) ../bigmess/bin/bigmess
+BIGMESS_OPTS = -c neurodebian.cfg
+BIGMESS_CMD = PYTHONPATH=.:3rd/bigmess:$(PYTHONPATH) 3rd/bigmess/bin/bigmess
 BIGMESS = $(BIGMESS_CMD) $(BIGMESS_OPTS)
 
 # Lentghy one due to updatedb
@@ -13,6 +13,12 @@ all: updatedb upload-website mirmon
 # Quick one -- just rebuilds html if new changes and adjusts the status of the mirrors
 refresh: upload-website-stamp mirmon
 
+website-build-depends:
+       : # Python modules
+       sudo apt-get install python-sphinx python-argparse python-xdg python-debian
+       : # JavaScripts
+       sudo apt-get install libjs-jquery-easing libjs-jquery-mousewheel libjs-jquery-fancybox
+
 
 pics:
        $(MAKE) -C artwork
@@ -52,10 +58,12 @@ source-stamp:
        $(BIGMESS) mkpkgtocs -d build/src/pkglists > build/src/pkgs.rst
        touch $@
 
-
-updatedb:
+cachefiles:
        $(BIGMESS) cachefiles -f
+
+updatedb: cachefiles
        $(BIGMESS) updatedb
+       -rm source-stamp
 
 upload-website: html
        rsync -rvzlhp --delete \
@@ -77,5 +85,5 @@ mirmon:
        cat $(WWW_UPLOAD_URI_STATIC)/{index-header,mirrors-status,index-trailer}.ihtml \
         >| $(WWW_UPLOAD_URI)/mirrors-status.html
 
-.PHONY: removedb removecache updatedb upload-website clean distclean pics html mirmon
+.PHONY: removedb removecache cachefiles updatedb upload-website clean distclean pics html mirmon