]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
apparently there is no substitution for chroot_sources but there is one for config...
[neurodebian.git] / Makefile
index 97e75699974e13822046208e27d457fbfd6db8a0..dd9097c32b44ee5a94a517bb6a7621a89d5b40ca 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -9,7 +9,7 @@ pics:
        $(MAKE) -C artwork
 
 
-html: pics
+html: pics source
        rsync -rvlhp sphinx/ build/src
        cd artwork;     cp button_w200.png logo_tuned/fmri_w200.png ../build/src/_static; cd ..
        cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build 2>&1
@@ -57,7 +57,9 @@ build/db.db:
 
 
 upload-website: html
-       rsync -rvzlhp --delete --exclude=debian --exclude=debian-local --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
+       rsync -rvzlhp --delete \
+        --exclude=debian --exclude=debian-local --exclude=_files \
+        --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
 
 .PHONY: removedb removecache updatedb upload-website clean distclean pics html