]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
apparently there is no substitution for chroot_sources but there is one for config...
[neurodebian.git] / Makefile
index 88b9e1be12b76d2f03655040ec14dea14edb8149..dd9097c32b44ee5a94a517bb6a7621a89d5b40ca 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -26,7 +26,7 @@ distclean: clean
 
 
 source: source-stamp
-source-stamp:
+source-stamp: build/db.db
        PYTHONPATH=. python neurodebian/dde.py \
                --cfg neurodebian.cfg \
                --db build/db.db \
@@ -57,7 +57,9 @@ build/db.db:
 
 
 upload-website: html
-       rsync -rvzlhp --delete --exclude=debian --exclude=debian-local --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
+       rsync -rvzlhp --delete \
+        --exclude=debian --exclude=debian-local --exclude=_files \
+        --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
 
 .PHONY: removedb removecache updatedb upload-website clean distclean pics html