]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
Add EndOfLife data to ubuntu release
[neurodebian.git] / Makefile
index 88b9e1be12b76d2f03655040ec14dea14edb8149..cbd3f0fc835c59fdae57cb5e4148301ecd635cbc 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -12,8 +12,10 @@ pics:
 html: pics source
        rsync -rvlhp sphinx/ build/src
        cd artwork;     cp button_w200.png logo_tuned/fmri_w200.png ../build/src/_static; cd ..
+       cp 3rd/jquery.livetwitter/jquery.livetwitter.min.js build/src/_static
        cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build 2>&1
        mv $(WWW_DIR)/_static/robots.txt $(WWW_DIR)/
+       cp -r build/src/lists $(WWW_DIR)/
 
 
 clean:
@@ -26,12 +28,13 @@ distclean: clean
 
 
 source: source-stamp
-source-stamp:
+source-stamp: build/db.db
        PYTHONPATH=. python neurodebian/dde.py \
                --cfg neurodebian.cfg \
                --db build/db.db \
                --outdir build/src \
                --pkgaddenum pkgs \
+               --extracts /home/www/neuro.debian.net/www/debian/extracts \
                commandisirrelevant
        rm -f html-stamp
        touch $@
@@ -57,7 +60,9 @@ build/db.db:
 
 
 upload-website: html
-       rsync -rvzlhp --delete --exclude=debian --exclude=debian-local --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
+       rsync -rvzlhp --delete \
+        --exclude=debian --exclude=debian-local --exclude=_files \
+        --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
 
 .PHONY: removedb removecache updatedb upload-website clean distclean pics html