]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
Move on to repository config files.
[neurodebian.git] / Makefile
index 0e76bedee44079531318cd481a6e0910679e5ba7..a65b6d16e54c97b9b3553e867036032c8fec3677 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,84 +1,39 @@
-# Makefile for Sphinx documentation
-#
-
-# You can set these variables from the command line.
-SPHINXOPTS    =
-SPHINXBUILD   = sphinx-build
-PAPER         =
-
-# Internal variables.
-SRCDIR = build/source
-PAPEROPT_a4     = -D latex_paper_size=a4
-PAPEROPT_letter = -D latex_paper_size=letter
-ALLSPHINXOPTS   = -d build/doctrees $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) $(SRCDIR)
-
 
 WWW_UPLOAD_URI = elrond:/home/hanke/public_html/archive
 WWW_DIR = build/html
 
 
-.PHONY: help clean html web pickle htmlhelp latex changes linkcheck
+prep:
+       mkdir -p build/src
+       cp -r sphinx/* build/src
 
 
-prep:
-       mkdir -p build
-       cp -r source build/
+html: prep source
+       cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build
 
 
 clean:
        -rm -rf build
 
-html: prep
-       mkdir -p build/html build/doctrees
-       $(SPHINXBUILD) -b html $(ALLSPHINXOPTS) build/html
-       @echo
-       @echo "Build finished. The HTML pages are in build/html."
 
-pickle: prep
-       mkdir -p build/pickle build/doctrees
-       $(SPHINXBUILD) -b pickle $(ALLSPHINXOPTS) build/pickle
-       @echo
-       @echo "Build finished; now you can process the pickle files."
+distclean: clean
+       -rm -rf cache
 
-web: pickle
 
-json: prep
-       mkdir -p build/json build/doctrees
-       $(SPHINXBUILD) -b json $(ALLSPHINXOPTS) build/json
-       @echo
-       @echo "Build finished; now you can process the JSON files."
+source:
+       ./reblender generate \
+               --cfg debneuro.cfg \
+               --db build/db.db \
+               --outdir build/src \
+               --pkgaddenum pkgs
 
-htmlhelp: prep
-       mkdir -p build/htmlhelp build/doctrees
-       $(SPHINXBUILD) -b htmlhelp $(ALLSPHINXOPTS) build/htmlhelp
-       @echo
-       @echo "Build finished; now you can run HTML Help Workshop with the" \
-             ".hhp project file in build/htmlhelp."
 
-latex: prep
-       mkdir -p build/latex build/doctrees
-       $(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) build/latex
-       @echo
-       @echo "Build finished; the LaTeX files are in build/latex."
-       @echo "Run \`make all-pdf' or \`make all-ps' in that directory to" \
-             "run these through (pdf)latex."
-
-changes: prep
-       mkdir -p build/changes build/doctrees
-       $(SPHINXBUILD) -b changes $(ALLSPHINXOPTS) build/changes
-       @echo
-       @echo "The overview file is in build/changes."
-
-linkcheck: prep
-       mkdir -p build/linkcheck build/doctrees
-       $(SPHINXBUILD) -b linkcheck $(ALLSPHINXOPTS) build/linkcheck
-       @echo
-       @echo "Link check complete; look for any errors in the above output " \
-       "or in build/linkcheck/output.txt."
-
-
-update-db:
-       ./reblender
+refresh-db:
+       mkdir -p build
+#      rm -f build/db.db
+       ./reblender refreshdb \
+               --cfg debneuro.cfg \
+               --db build/db.db
 
 
 upload-website: html