]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
Merge branch 'master' of ssh://alioth.debian.org/git/pkg-exppsy/neurodebian
[neurodebian.git] / Makefile
index 5fec98bba7d6221f77d3a203bcc10a91a0756587..97e75699974e13822046208e27d457fbfd6db8a0 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -9,8 +9,9 @@ pics:
        $(MAKE) -C artwork
 
 
-html: pics source
+html: pics
        rsync -rvlhp sphinx/ build/src
+       cd artwork;     cp button_w200.png logo_tuned/fmri_w200.png ../build/src/_static; cd ..
        cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build 2>&1
        mv $(WWW_DIR)/_static/robots.txt $(WWW_DIR)/
 
@@ -40,7 +41,7 @@ removecache:
        -rm -rf build/cache
 
 removedb:
-       -rm build/db.db
+       -rm -f build/db.db
 
 
 updatedb: removedb removecache build/db.db
@@ -52,7 +53,7 @@ build/db.db:
                --cfg neurodebian.cfg \
                --db build/db.db \
                updatedb
-       -rm source-stamp
+       -rm -f source-stamp
 
 
 upload-website: html