]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
Don't kill survery/ on website update
[neurodebian.git] / Makefile
index 4f37cf71ae3b7012393a60c6a02db4bc7fabd198..94886961acd0c1e30496000cbcbebd310c1afe95 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -12,8 +12,10 @@ pics:
 html: pics source
        rsync -rvlhp sphinx/ build/src
        cd artwork;     cp button_w200.png logo_tuned/fmri_w200.png ../build/src/_static; cd ..
+       cp 3rd/jquery.livetwitter/jquery.livetwitter.min.js build/src/_static
        cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build 2>&1
        mv $(WWW_DIR)/_static/robots.txt $(WWW_DIR)/
+       cp -r build/src/lists $(WWW_DIR)/
 
 
 clean:
@@ -59,7 +61,7 @@ build/db.db:
 
 upload-website: html
        rsync -rvzlhp --delete \
-        --exclude=debian --exclude=debian-local --exclude=_files \
+        --exclude=debian --exclude=debian-local --exclude=_files --exclude=survey \
         --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
 
 .PHONY: removedb removecache updatedb upload-website clean distclean pics html