]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
Merge remote branch 'alioth/master'
[neurodebian.git] / Makefile
index 3e2ceafff8530799add6ebbbfd04fcd25276b1d0..880f0d2f4123dccda9de3cafeb38c2dfd791ea09 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -11,8 +11,10 @@ pics:
 
 html: pics source
        rsync -rvlhp sphinx/ build/src
+       cd artwork;     cp button_w200.png logo_tuned/fmri_w200.png ../build/src/_static; cd ..
        cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build 2>&1
        mv $(WWW_DIR)/_static/robots.txt $(WWW_DIR)/
+       cp -r build/src/lists $(WWW_DIR)/
 
 
 clean:
@@ -31,6 +33,7 @@ source-stamp: build/db.db
                --db build/db.db \
                --outdir build/src \
                --pkgaddenum pkgs \
+               --extracts /home/www/neuro.debian.net/www/debian/extracts \
                commandisirrelevant
        rm -f html-stamp
        touch $@
@@ -40,7 +43,7 @@ removecache:
        -rm -rf build/cache
 
 removedb:
-       -rm build/db.db
+       -rm -f build/db.db
 
 
 updatedb: removedb removecache build/db.db
@@ -52,11 +55,13 @@ build/db.db:
                --cfg neurodebian.cfg \
                --db build/db.db \
                updatedb
-       -rm source-stamp
+       -rm -f source-stamp
 
 
 upload-website: html
-       rsync -rvzlhp --delete --exclude=debian --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
+       rsync -rvzlhp --delete \
+        --exclude=debian --exclude=debian-local --exclude=_files \
+        --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
 
 .PHONY: removedb removecache updatedb upload-website clean distclean pics html