]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
New repository setup instruction.
[neurodebian.git] / Makefile
index 0220a20dd7c235bcc2df3ead1962698c126c6645..880f0d2f4123dccda9de3cafeb38c2dfd791ea09 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,22 +1,20 @@
-WWW_UPLOAD_URI = neuro.debian.net:/home/www/neuro.debian.net/www
-WWW_DIR = build/html
+#WWW_UPLOAD_URI = neuro.debian.net:/home/www/neuro.debian.net/www
+WWW_UPLOAD_URI = ../www
+WWW_DIR = build/html/
 
-all: html
-
-
-prep:
-       if [ ! -d build ]; then mkdir build; fi
-       rsync -rvlhp sphinx/ build/src
+all: updatedb upload-website
 
 
 pics:
        $(MAKE) -C artwork
 
 
-html: html-stamp
-html-stamp: pics prep source
-       cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build
-       touch $@
+html: pics source
+       rsync -rvlhp sphinx/ build/src
+       cd artwork;     cp button_w200.png logo_tuned/fmri_w200.png ../build/src/_static; cd ..
+       cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build 2>&1
+       mv $(WWW_DIR)/_static/robots.txt $(WWW_DIR)/
+       cp -r build/src/lists $(WWW_DIR)/
 
 
 clean:
@@ -26,7 +24,6 @@ clean:
 
 distclean: clean
        -rm -rf build
-       -rm -rf cache
 
 
 source: source-stamp
@@ -36,16 +33,20 @@ source-stamp: build/db.db
                --db build/db.db \
                --outdir build/src \
                --pkgaddenum pkgs \
+               --extracts /home/www/neuro.debian.net/www/debian/extracts \
                commandisirrelevant
        rm -f html-stamp
        touch $@
 
 
+removecache:
+       -rm -rf build/cache
+
 removedb:
-       -rm build/db.db
+       -rm -f build/db.db
 
 
-updatedb: distclean build/db.db
+updatedb: removedb removecache build/db.db
 
 
 build/db.db:
@@ -54,9 +55,13 @@ build/db.db:
                --cfg neurodebian.cfg \
                --db build/db.db \
                updatedb
+       -rm -f source-stamp
 
 
 upload-website: html
-       rsync -rvzlhp --delete --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
+       rsync -rvzlhp --delete \
+        --exclude=debian --exclude=debian-local --exclude=_files \
+        --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
+
+.PHONY: removedb removecache updatedb upload-website clean distclean pics html
 
-.PHONY: prep