]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
Remove old neurodebian python module completely
[neurodebian.git] / Makefile
index 305b1015ee65ce60f467d4fd99df8a55684db0d8..849e4a3e2deceedc3c7a5d5764cc61b5cf924c2a 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -36,36 +36,19 @@ distclean: clean
 
 
 source: source-stamp
-source-stamp: build/db.db
-       PYTHONPATH=.:$(PYTHONPATH) python neurodebian/dde.py \
-               --cfg neurodebian.cfg \
-               --db build/db.db \
-               --outdir build/src \
-               --pkgaddenum pkgs \
-               --extracts /home/www/neuro.debian.net/www/debian/extracts \
-               commandisirrelevant
-       rm -f html-stamp
+source-stamp: 
+       mkdir -p build/src/pkgs/
+       mkdir -p build/src/lists/
+       mkdir -p build/src/pkglists/
+       PYTHONPATH=.:../bigmess:$(PYTHONPATH) ../bigmess/bin/bigmess genpkgs -d build/src/pkgs/
+       PYTHONPATH=.:../bigmess:$(PYTHONPATH) ../bigmess/bin/bigmess genaptlists -d build/src/lists/
+       PYTHONPATH=.:../bigmess:$(PYTHONPATH) ../bigmess/bin/bigmess genmirrorselect > build/src/sources_lists
+       PYTHONPATH=.:../bigmess:$(PYTHONPATH) ../bigmess/bin/bigmess genpkglists \
+               -d build/src/pkglists > build/src/pkgs.rst
        touch $@
 
 
-removecache:
-       -rm -rf build/cache
-
-removedb:
-       -rm -f build/db.db
-
-
-updatedb: removedb removecache build/db.db
-
-
-build/db.db:
-       mkdir -p build
-       PYTHONPATH=.:$(PYTHONPATH) python neurodebian/dde.py \
-               --cfg neurodebian.cfg \
-               --db build/db.db \
-               updatedb
-       -rm -f source-stamp
-
+updatedb:
 
 upload-website: html
        rsync -rvzlhp --delete \
@@ -80,7 +63,8 @@ upload-website-stamp: .git/index
 
 mirmon:
        # update and generate mirrors report
-       [ -x /usr/bin/mirmon ] && mirmon -q -get update -c mirmon-neurodebian.conf
+       [ -x /usr/bin/mirmon ] && mirmon -q -get update -c mirmon-neurodebian.conf 2>&1 \
+        | grep -v 'date: invalid date.*DOCTYPE' || :
        # [ -x $(WWW_UPLOAD_URI_STATIC)/mirrors-check.ihtml ] &&
        # everything must be in place!
        cat $(WWW_UPLOAD_URI_STATIC)/{index-header,mirrors-status,index-trailer}.ihtml \