]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
ENH: mask out mirmon failures due to missing timestamp: invalid date .DOCTYPE
[neurodebian.git] / Makefile
index 9b90a01b5e16ac23b2d600082b1b74c60463b1b7..7b980d4058993bfbfc3db717259c53e0d023b7ac 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -24,7 +24,7 @@ html: pics source
        cp -r sphinx/survey/2011/figures/* $(WWW_DIR)/_images/
        @echo "I: extracting header/trailer to be reused in non-sphinx pages"
        sed -ne '1,/<!-- HEADNOTES -->/p' $(WWW_DIR)/index.html >| $(WWW_DIR)/_static/index-header.ihtml
-       sed -ne '/<h2>Comments<\/h2>/,$p' $(WWW_DIR)/index.html >| $(WWW_DIR)/_static/index-trailer.ihtml
+       sed -ne '/<h2>Comments<\/h2>/,$$p' $(WWW_DIR)/index.html >| $(WWW_DIR)/_static/index-trailer.ihtml
 
 clean:
        -rm html-stamp source-stamp upload-website-stamp
@@ -80,7 +80,8 @@ upload-website-stamp: .git/index
 
 mirmon:
        # update and generate mirrors report
-       [ -x /usr/bin/mirmon ] && mirmon -q -get update -c mirmon-neurodebian.conf
+       [ -x /usr/bin/mirmon ] && mirmon -q -get update -c mirmon-neurodebian.conf 2>&1 \
+        | grep -v 'date: invalid date.*DOCTYPE'
        # [ -x $(WWW_UPLOAD_URI_STATIC)/mirrors-check.ihtml ] &&
        # everything must be in place!
        cat $(WWW_UPLOAD_URI_STATIC)/{index-header,mirrors-status,index-trailer}.ihtml \