]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
ENH: mask out mirmon failures due to missing timestamp: invalid date .DOCTYPE
[neurodebian.git] / Makefile
index 4b9e35a7c432e465bdc0be57ec29b89b60395f49..7b980d4058993bfbfc3db717259c53e0d023b7ac 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -2,7 +2,12 @@
 WWW_UPLOAD_URI = ../www
 WWW_DIR = build/html/
 
-all: updatedb upload-website
+WWW_UPLOAD_URI_STATIC=$(WWW_UPLOAD_URI)/_static
+
+# Lentghy one due to updatedb
+all: updatedb upload-website mirmon
+# Quick one -- just rebuilds html if new changes and adjusts the status of the mirrors
+refresh: upload-website-stamp mirmon
 
 
 pics:
@@ -10,14 +15,16 @@ pics:
 
 
 html: pics source
-       rsync -rvlhp sphinx/ build/src
+       rsync -rvlhpt sphinx/ build/src
        cd artwork;     cp button_w200.png logo_tuned/fmri_w200.png ../build/src/_static; cd ..
        cp 3rd/jquery.livetwitter/jquery.livetwitter.min.js build/src/_static
        cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build 2>&1
        mv $(WWW_DIR)/_static/robots.txt $(WWW_DIR)/
        cp -r build/src/lists $(WWW_DIR)/
        cp -r sphinx/survey/2011/figures/* $(WWW_DIR)/_images/
-
+       @echo "I: extracting header/trailer to be reused in non-sphinx pages"
+       sed -ne '1,/<!-- HEADNOTES -->/p' $(WWW_DIR)/index.html >| $(WWW_DIR)/_static/index-header.ihtml
+       sed -ne '/<h2>Comments<\/h2>/,$$p' $(WWW_DIR)/index.html >| $(WWW_DIR)/_static/index-trailer.ihtml
 
 clean:
        -rm html-stamp source-stamp upload-website-stamp
@@ -71,5 +78,14 @@ upload-website: html
 upload-website-stamp: .git/index
        $(MAKE) upload-website
 
-.PHONY: removedb removecache updatedb upload-website clean distclean pics html
+mirmon:
+       # update and generate mirrors report
+       [ -x /usr/bin/mirmon ] && mirmon -q -get update -c mirmon-neurodebian.conf 2>&1 \
+        | grep -v 'date: invalid date.*DOCTYPE'
+       # [ -x $(WWW_UPLOAD_URI_STATIC)/mirrors-check.ihtml ] &&
+       # everything must be in place!
+       cat $(WWW_UPLOAD_URI_STATIC)/{index-header,mirrors-status,index-trailer}.ihtml \
+        >| $(WWW_UPLOAD_URI)/mirrors-status.html
+
+.PHONY: removedb removecache updatedb upload-website clean distclean pics html mirmon