]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
The survey 2011 results.
[neurodebian.git] / Makefile
index 880f0d2f4123dccda9de3cafeb38c2dfd791ea09..76ca1c270e7008628db9f03b9f2a363b9e2924bd 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -12,9 +12,11 @@ pics:
 html: pics source
        rsync -rvlhp sphinx/ build/src
        cd artwork;     cp button_w200.png logo_tuned/fmri_w200.png ../build/src/_static; cd ..
+       cp 3rd/jquery.livetwitter/jquery.livetwitter.min.js build/src/_static
        cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build 2>&1
        mv $(WWW_DIR)/_static/robots.txt $(WWW_DIR)/
        cp -r build/src/lists $(WWW_DIR)/
+       cp -r sphinx/survey/2011/figures/* $(WWW_DIR)/_images/
 
 
 clean:
@@ -60,7 +62,7 @@ build/db.db:
 
 upload-website: html
        rsync -rvzlhp --delete \
-        --exclude=debian --exclude=debian-local --exclude=_files \
+        --exclude=debian --exclude=debian-local --exclude=_files --exclude=survey \
         --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
 
 .PHONY: removedb removecache updatedb upload-website clean distclean pics html